Quantcast

Jump to content

» «
Photo

Need help with TASK_WANDER_IN_AREA

4 replies to this topic
sollaholla
  • sollaholla

    C# Dev.

  • Members
  • Joined: 19 May 2016
  • United-States

#1

Posted 02 June 2016 - 10:23 PM

I've been trying to get this to work but the ped just stands there and does nothing.

Function.Call(Hash.CLEAR_PED_TASKS_IMMEDIATELY, suspect);
Function.Call(Hash.TASK_WANDER_IN_AREA, suspect, blipLocation.X, blipLocation.Y, blipLocation.Z, 70, 0.0f, 0.0f);

It only gets called one frame.

 


AHK1221
  • AHK1221

    Is it that time already?

  • Members
  • Joined: 19 Dec 2015
  • Pakistan

#2

Posted 03 June 2016 - 10:18 AM

I've been trying to get this to work but the ped just stands there and does nothing.

Function.Call(Hash.CLEAR_PED_TASKS_IMMEDIATELY, suspect);
Function.Call(Hash.TASK_WANDER_IN_AREA, suspect, blipLocation.X, blipLocation.Y, blipLocation.Z, 70, 0.0f, 0.0f);

It only gets called one frame.

 

Its clear u use SHV so just do:

 suspect.Task.WanderAround();

sollaholla
  • sollaholla

    C# Dev.

  • Members
  • Joined: 19 May 2016
  • United-States

#3

Posted 03 June 2016 - 04:17 PM Edited by sollaholla, 03 June 2016 - 04:18 PM.

Its clear u use SHV so just do:

 suspect.Task.WanderAround();

I'm looking to do it in a radius of an area, also I've tried that method, and 50% of the time it does nothing. I've also tried

Task.WanderAround(blipLocation, 70);

Also does not work all the time.


Ezio Baggins
  • Ezio Baggins

    Player Hater

  • Members
  • Joined: 07 Jun 2017
  • India

#4

Posted 3 weeks ago

Any solutions ? Still having the same problem 


NoNameSet
  • NoNameSet

    Crackhead

  • Members
  • Joined: 22 Jul 2017
  • Germany

#5

Posted 3 weeks ago Edited by NoNameSet, 3 weeks ago.

Any solutions ? Still having the same problem 

I have gotten it to work (RPH)

public static void WanderInArea(this Ped ped, Vector3 Position, float radius)
        {
            NativeFunction.Natives.TASK_WANDER_IN_AREA(ped, Position.X, Position.Y, Position.Z, radius, 0.0f, 0.0f);
        }
//doesn't seem to have any difference from the examples above
//the only time this didn't work for me was when the player was too far away from the ped




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users