Quantcast

Jump to content

» «
Photo

SAxVCxLC MTA Compatible Build

SA Released SA WIP
50 replies to this topic
PlatinumSerb
  • PlatinumSerb

    ...

  • Members
  • Joined: 23 Mar 2004

#1

Posted 22 January 2016 - 04:26 AM Edited by PlatinumSerb, 03 February 2016 - 06:25 AM.

**I have permission to create a new topic so I dont clutter the official SAxVCxLC topic.**


AKPkFpF.png
 

 

Im happy to present a version of MTA that allows you to play a map with all 3 Renderware era cities(SA, VC, and LC) online!

 

There is still an signed limit with MTA that prevents us from fully utilizing the id limit hacks provided by FLA, so I've had to make some changes to the original SAxVCxLC. The map included in this build is the same map from build 0.06a, but some of the LC ids have changed to now use original unused SA ids. There have also been some changes to the .img files. This game should still be playable in single player but its intent is mostly multiplayer. I will still focus on the single player map in the other topic. There is one official server currently up. The install includes the server files so feel free to host your own servers! 

Map(Click to Enlarge):
70m3WSq.jpg

 

Media:
VX1NIVFb.jpg ye1djXLb.jpg

 

CkXhthbb.jpg h6zRgzFb.jpg

 

Download:

Mirror 1  - Mega.nz(Includes the SAxVCxLC(MTA compatible build) and MTA Installer)

(Updated 1/24/2016 - files in original download were missing)

 

Install Instructions(found in the readme):

Step 1. 
Simply Drag All the files form "put_in_sa_root" into a directory with a new/clean install of GTA:San Andreas. 
Allow replacement of any required files. 
 
Step 2.
Once the files have been placed into a GTA: San Andreas directory run the 
"INSTALL - SAxVCxLC.bat" file.
**Let the archives rebuild - the window will close by itself once its done.**
 
Step 3: 
Run the MTA installer(mtasa-1.6.0-SAxVCxLC-01.exe). Make sure to set you SAxVCxLC(MTA compatible build) as your default SA game directory.
Once you start up the game go Settings->Multiplayer and check "Use customized GTA:SA files." (Set your Username in Settings as well)
 
***If step 2 DOES NOT WORK then you must do this:***
- Open up gta3.img delete "fences.txd" and all of the radar*.txd files(radar01.txd-radar63.txd)
- Rebuild "gta3.img"
- Add all the files inside "models\addToImg\" to "gta_int.img"
- Rebuild "gta_int.img"
 
If the above does not work either just download this gta_int.img and replace your existing one inside "\models."
 

Official Server(will also appear ingame under the Internet tab on the Server Browser):

SAxVCxLC Official Server - mtasa://104.40.193.27:22003

 

 

Special Thanks:
Everyone credited in the SAxVCxLC topic.

Fastman92 - helping with initial debugging of MTA.
MTA Team - for making MTA and making it open source.

Russell_Stone -  for hosting the official server!  :)
LINK 2012 - help with debugging the last issue. 
IgorX - helping test.

 

Enjoy!

  • X-Seti, Blackbird88, fastman92 and 21 others like this

The_GTA
  • The_GTA

    revenclaw

  • Members
  • Joined: 27 Dec 2012
  • Germany
  • Modding Milestone [Magic.TXD]

#2

Posted 22 January 2016 - 07:44 AM

Cool Idea. I always wanted to make this. It must have been made by a very fast man!

Blackbird88
  • Blackbird88

    DualShock 3 Buttons EVERYWHERE

  • Members
  • Joined: 21 Jul 2008
  • Czech-Republic

#3

Posted 22 January 2016 - 10:14 AM

Simply awesome. I had no idea MTA could handle it :O


undertaker fan
  • undertaker fan

    Hustler

  • Members
  • Joined: 22 Feb 2011
  • Pakistan

#4

Posted 22 January 2016 - 11:36 AM

it awesome man will try it! keep it up!


cosmys
  • cosmys

    Player Hater

  • Members
  • Joined: 21 Aug 2010
  • Poland

#5

Posted 22 January 2016 - 03:39 PM

The MTA Installer doesn't launch for me ... :(


PlatinumSerb
  • PlatinumSerb

    ...

  • Members
  • Joined: 23 Mar 2004

#6

Posted 24 January 2016 - 05:27 AM

The MTA Installer doesn't launch for me ... :(

Can I get some more info? Are you getting an error message? Which operating system are you on?


fastman92
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009
  • Poland
  • Best Conversion 2016 [GTA: Underground] [Contribution]
    Contribution Award [Mods]

#7

Posted 24 January 2016 - 09:16 AM

Does your build work with unsigned ID - over 32768?
  • dkluin likes this

Rented
  • Rented

    San Andreas Rewind Lead Developer

  • The Connection
  • Joined: 24 Oct 2010
  • England

#8

Posted 24 January 2016 - 11:54 AM Edited by Rented, 24 January 2016 - 12:55 PM.

I got 3 hours before I have to get ready for work, come lets play guys!
 
Edit:
Fixed last issue, but now there is a new one.

PlatinumSerb
  • PlatinumSerb

    ...

  • Members
  • Joined: 23 Mar 2004

#9

Posted 24 January 2016 - 05:13 PM

I got 3 hours before I have to get ready for work, come lets play guys!
 
Edit:
Fixed last issue, but now there is a new one.

Whats the issue?


Blackalien
  • Blackalien

    Keepin' it Old Shool

  • Members
  • Joined: 23 Feb 2015
  • Bulgaria

#10

Posted 24 January 2016 - 07:12 PM

The MTA Installer doesn't launch for me ... :(

Same goes for me. The process is showing in task manager but nothing is happening, I aslo tried running the installer in compatibility mode but without success.

  • cosmys likes this

MrSmarter22
  • MrSmarter22

    BloodFighter lvl 100

  • Members
  • Joined: 25 Dec 2010
  • None

#11

Posted 24 January 2016 - 07:53 PM

everytime I run the Install SAxVCxLC batch file, it says that the archive has to be opened, and that it isnt opened correctly. Any idea how to fix that? Tried various things already, such as running it as an administrator etc.


PlatinumSerb
  • PlatinumSerb

    ...

  • Members
  • Joined: 23 Mar 2004

#12

Posted 25 January 2016 - 01:33 AM Edited by PlatinumSerb, 25 January 2016 - 01:34 AM.

 

The MTA Installer doesn't launch for me ... :(

Same goes for me. The process is showing in task manager but nothing is happening, I aslo tried running the installer in compatibility mode but without success.

 

 

Which windows are you running?

 

everytime I run the Install SAxVCxLC batch file, it says that the archive has to be opened, and that it isnt opened correctly. Any idea how to fix that? Tried various things already, such as running it as an administrator etc.

Do that step manually, like this: 
***If step 2 DOES NOT WORK then you must do this:***

- Open up gta3.img delete "fences.txd" and all of the radar*.txd files(radar01.txd-radar63.txd)
- Rebuild "gta3.img"
- Add all the files inside "models\addToImg\" to "gta_int.img"
- Rebuild "gta_int.img"
 
 
Important: I have updated the download link. The original build I had posted had some missing files that I forgot about and it was causing loading issues in VC. These issues should now be resolved. Please re-download the files from Mirror 1 and reinstall. Sorry for the inconvenience. 
  • Nexerade likes this

MrSmarter22
  • MrSmarter22

    BloodFighter lvl 100

  • Members
  • Joined: 25 Dec 2010
  • None

#13

Posted 25 January 2016 - 09:18 AM Edited by MrSmarter22, 25 January 2016 - 09:29 AM.

Did that and now get the following error: Error 0x534134, model ID 18677 does not have loaded collision.

  • ILOVEGTA8 likes this

cosmys
  • cosmys

    Player Hater

  • Members
  • Joined: 21 Aug 2010
  • Poland

#14

Posted 25 January 2016 - 09:43 AM

 

 

The MTA Installer doesn't launch for me ... :(

Same goes for me. The process is showing in task manager but nothing is happening, I aslo tried running the installer in compatibility mode but without success.

 

 

Which windows are you running?

 

everytime I run the Install SAxVCxLC batch file, it says that the archive has to be opened, and that it isnt opened correctly. Any idea how to fix that? Tried various things already, such as running it as an administrator etc.

Do that step manually, like this: 
***If step 2 DOES NOT WORK then you must do this:***

- Open up gta3.img delete "fences.txd" and all of the radar*.txd files(radar01.txd-radar63.txd)
- Rebuild "gta3.img"
- Add all the files inside "models\addToImg\" to "gta_int.img"
- Rebuild "gta_int.img"
 
 
Important: I have updated the download link. The original build I had posted had some missing files that I forgot about and it was causing loading issues in VC. These issues should now be resolved. Please re-download the files from Mirror 1 and reinstall. Sorry for the inconvenience. 

 

 

I am using Windows Vista Ultimate 32bit SP2.


Blackalien
  • Blackalien

    Keepin' it Old Shool

  • Members
  • Joined: 23 Feb 2015
  • Bulgaria

#15

Posted 25 January 2016 - 10:41 AM

I have Windows 7 Ultimate 64bit

BlackBK
  • BlackBK

    Player Hater

  • BUSTED!
  • Joined: 26 Jan 2016
  • Brazil

#16

Posted 26 January 2016 - 03:16 AM Edited by BlackBK, 26 January 2016 - 04:34 AM.

someone who has achieved could provide the file gta 3 and gta_int reconstructed to download?


ILOVEGTA8
  • ILOVEGTA8

    Player Hater

  • BUSTED!
  • Joined: 28 Jan 2016
  • United-States

#17

Posted 28 January 2016 - 03:50 PM

hi bro very good mod., congratulations but unfortunately I  not got it run mode online  :(

  • Nexerade likes this

aotlunla
  • aotlunla

    Player Hater

  • Members
  • Joined: 01 Sep 2014
  • Thailand

#18

Posted 28 January 2016 - 04:23 PM

Great Man !!!
  • ILOVEGTA8 likes this

PlatinumSerb
  • PlatinumSerb

    ...

  • Members
  • Joined: 23 Mar 2004

#19

Posted 29 January 2016 - 02:56 AM

 

 

 

The MTA Installer doesn't launch for me ... :(

Same goes for me. The process is showing in task manager but nothing is happening, I aslo tried running the installer in compatibility mode but without success.

 

 

Which windows are you running?

 

everytime I run the Install SAxVCxLC batch file, it says that the archive has to be opened, and that it isnt opened correctly. Any idea how to fix that? Tried various things already, such as running it as an administrator etc.

Do that step manually, like this: 
***If step 2 DOES NOT WORK then you must do this:***

- Open up gta3.img delete "fences.txd" and all of the radar*.txd files(radar01.txd-radar63.txd)
- Rebuild "gta3.img"
- Add all the files inside "models\addToImg\" to "gta_int.img"
- Rebuild "gta_int.img"
 
 
Important: I have updated the download link. The original build I had posted had some missing files that I forgot about and it was causing loading issues in VC. These issues should now be resolved. Please re-download the files from Mirror 1 and reinstall. Sorry for the inconvenience. 

 

 

I am using Windows Vista Ultimate 32bit SP2.

 

 

 

I have Windows 7 Ultimate 64bit

 

Have you tried running as administrator? Anyone else having this issue with the installer?

 

Did that and now get the following error: Error 0x534134, model ID 18677 does not have loaded collision.

You made sure to put all the .col files from "models\addToImg\" into gta_int.img and then rebuilt the 

 

hi bro very good mod., congratulations but unfortunately I  not got it run mode online   :(

Single player works? Can you provide more details?

  • ILOVEGTA8 likes this

ILOVEGTA8
  • ILOVEGTA8

    Player Hater

  • BUSTED!
  • Joined: 28 Jan 2016
  • United-States

#20

Posted 29 January 2016 - 11:07 PM Edited by ILOVEGTA8, 29 January 2016 - 11:10 PM.

offline yes but I have to hit enter twice, however this current version offline not play I think I'm doing things wrong., you could make an installer for people who have difficulty just like me!?


PlatinumSerb
  • PlatinumSerb

    ...

  • Members
  • Joined: 23 Mar 2004

#21

Posted 30 January 2016 - 02:00 AM

offline yes but I have to hit enter twice, however this current version offline not play I think I'm doing things wrong., you could make an installer for people who have difficulty just like me!?

I am confused. When you download this build from this topic and install it, are you able to play it in single player? I'd gladly make a new installer if I knew what the issue was.

  • ILOVEGTA8 likes this

ILOVEGTA8
  • ILOVEGTA8

    Player Hater

  • BUSTED!
  • Joined: 28 Jan 2016
  • United-States

#22

Posted 30 January 2016 - 03:28 AM Edited by ILOVEGTA8, 30 January 2016 - 12:34 PM.

I tried all of the above ways and did not work

33wxli8.jpg

280iqvl.jpg

25ip2r6.jpg

if not the bother you could just leave all ready files. so only we would have to play all the files to the game folder andreplace then install the MTA and simply play


cosmys
  • cosmys

    Player Hater

  • Members
  • Joined: 21 Aug 2010
  • Poland

#23

Posted 30 January 2016 - 11:41 AM

 

 

 

 

The MTA Installer doesn't launch for me ... :(

Same goes for me. The process is showing in task manager but nothing is happening, I aslo tried running the installer in compatibility mode but without success.

 

 

Which windows are you running?

 

everytime I run the Install SAxVCxLC batch file, it says that the archive has to be opened, and that it isnt opened correctly. Any idea how to fix that? Tried various things already, such as running it as an administrator etc.

Do that step manually, like this: 
***If step 2 DOES NOT WORK then you must do this:***

- Open up gta3.img delete "fences.txd" and all of the radar*.txd files(radar01.txd-radar63.txd)
- Rebuild "gta3.img"
- Add all the files inside "models\addToImg\" to "gta_int.img"
- Rebuild "gta_int.img"
 
 
Important: I have updated the download link. The original build I had posted had some missing files that I forgot about and it was causing loading issues in VC. These issues should now be resolved. Please re-download the files from Mirror 1 and reinstall. Sorry for the inconvenience. 

 

 

I am using Windows Vista Ultimate 32bit SP2.

 

 

 

I have Windows 7 Ultimate 64bit

 

Have you tried running as administrator? Anyone else having this issue with the installer?

 

Did that and now get the following error: Error 0x534134, model ID 18677 does not have loaded collision.

You made sure to put all the .col files from "models\addToImg\" into gta_int.img and then rebuilt the 

 

hi bro very good mod., congratulations but unfortunately I  not got it run mode online   :(

Single player works? Can you provide more details?

 

 

I tried running this as administator every time, doesn't work.

  • ILOVEGTA8 likes this

PlatinumSerb
  • PlatinumSerb

    ...

  • Members
  • Joined: 23 Mar 2004

#24

Posted 03 February 2016 - 05:30 AM Edited by PlatinumSerb, 03 February 2016 - 06:23 AM.

I have tested the installer on Windows 7 and Windows 10 without issues. Try downloading a standard MTA Installer and see if you have the same issue. Is anyone else having issues with the installer?

I've been quiet busy the past few weeks so I haven't really been able to promote this, but hopefully more people come across the mod and give it a try. 

 

Edit: took a look at the server log and I see some activity. Glad to see that some people have been able to get it working. If anyone has trouble running the .bat file, just download this gta_int.img file and replace the current one inside your \models folder.

  • Sweet Bellic likes this

Exciter
  • Exciter

    Player Hater

  • Members
  • Joined: 06 Feb 2016
  • Norway

#25

Posted 06 February 2016 - 12:41 AM

Awesome product! Thank you!

 

I had a problem running the bat at first. In my case it was that the bat could not find the files because the working directory of the bat was wrong. To fix this, I added the following line on top in the bat file (sets the working directory to the disk and directory of the bat file).

CHDIR /D %~dp0

On another note. Is the dedicated server also customized like the client, or is it a standard MTA 1.6 (nightly) server?

  • Sweet Bellic likes this

PlatinumSerb
  • PlatinumSerb

    ...

  • Members
  • Joined: 23 Mar 2004

#26

Posted 06 February 2016 - 02:56 AM

Awesome product! Thank you!
 
I had a problem running the bat at first. In my case it was that the bat could not find the files because the working directory of the bat was wrong. To fix this, I added the following line on top in the bat file (sets the working directory to the disk and directory of the bat file).

CHDIR /D %~dp0
On another note. Is the dedicated server also customized like the client, or is it a standard MTA 1.6 (nightly) server?

Thank you! I will add that suggestion to the first post.

The server indeed also had to be slightly customized. The new server is included in the download.
  • Sweet Bellic likes this

cosmys
  • cosmys

    Player Hater

  • Members
  • Joined: 21 Aug 2010
  • Poland

#27

Posted 10 February 2016 - 08:03 PM

I've installed Windows 7 Ultimate and now MTA installer works!


Nexerade
  • Nexerade

    Player Hater

  • Members
  • Joined: 08 May 2015
  • None

#28

Posted 20 February 2016 - 07:49 AM Edited by Nexerade, 20 February 2016 - 07:50 AM.

Cannot join any server with this mod. I can see SAxVCxLC official server 0.6, but I just cannot join. It crashes with 

 

Version = 1.6-custom.0.000
Time = Sat Feb 20 10:44:53 2016
Module = S:\SteamLibrary\steamapps\common\Grand Theft Auto San Andreas\proxy_sa.exe
Code = 0xC0000005
Offset = 0x001B6B2F
 
EAX=00000001  EBX=00000000  ECX=FFFFFFFF  EDX=00000000  ESI=00000000
EDI=00000003  EBP=00000002  ESP=0028F848  EIP=005B6B2F  FLG=00210202
CS=0023   DS=002B  SS=002B  ES=002B   FS=0053  GS=002B
 

 

And then says:

GTA:SA had trouble opening the file 'DATA\CARCOLS.DAT'

 

Standart version works fine for me in single-player, but this exactly one - no. When I'm trying to start single player with this MTA version - I got this:

 

Current process ID: 7344

Last file to be loaded: DATA\CARCOLS.DAT

Last library loaded: C:\Windows\system32\d3d9.dll

Exception adress: 0x005B6B2F ("gta_sa.exe" +0x1B6B2F)

Exception code: 0xC0000005

Exception name: EXCEPTION_ACCESs_VIOLATION

Inaccessible memory adress: 0x2D0

 

 


Blackalien
  • Blackalien

    Keepin' it Old Shool

  • Members
  • Joined: 23 Feb 2015
  • Bulgaria

#29

Posted 20 February 2016 - 08:06 AM Edited by blackalienHD, 20 February 2016 - 08:06 AM.

Use original carcols.dat
I found out that you cannot play MTA with a modified one for some reason.

Nexerade
  • Nexerade

    Player Hater

  • Members
  • Joined: 08 May 2015
  • None

#30

Posted 20 February 2016 - 08:08 AM

Use original carcols.dat
I found out that you cannot play MTA with a modified one for some reason.

 

Where is it located and can somegive give me the original one?





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users