Quantcast

Jump to content

» «
Photo

Invalid WAVE Audio data preventing me from changing startup song

8 replies to this topic
I'm Invictus
  • I'm Invictus

    Crackhead

  • Members
  • Joined: 16 Jun 2014
  • United-States

#1

Posted 22 June 2015 - 07:29 AM

I properly converted my mp3 file to 2 wav files in Audacity with mono, 48000 sample rate & project rate, tried all of the sample formats, and the bitrate is at 768kbps.

 

Drag td_loading_music.oac into

Grand Theft Auto V\x64\audio\sfx\PROLOGUE.rpf\

 

and it tells me

 

"Some files not imported, more information below.

td_loading_music.oac(Line 9): Invalid WAVE Audio data."

 


Microbots
  • Microbots

    Player Hater

  • Members
  • Joined: 02 Apr 2013

#2

Posted 22 June 2015 - 09:48 AM

What program are you using? I tried Audacity and failed. But some guy on GTA5 mods got it working. 


Mr.Arrow
  • Mr.Arrow

    God Save the Penis

  • Members
  • Joined: 08 Nov 2011
  • United-Kingdom

#3

Posted 22 June 2015 - 10:22 AM Edited by Cyberzone2, 22 June 2015 - 10:24 AM.

the file must not be bigger than the original file

You must use PCM ,mono, and 16 bit for it to work

assanges
  • assanges

    Everyday I Shufflin‘

  • New Members
  • Joined: 22 May 2015
  • None

#4

Posted 22 June 2015 - 06:27 PM

the file must not be bigger than the original file

You must use PCM ,mono, and 16 bit for it to work

 

It depends on files, and no, files can be larger than the original


jatinderXD
  • jatinderXD

    Player Hater

  • New Members
  • Joined: 21 Jun 2015
  • India

#5

Posted 23 June 2015 - 09:38 AM

Try 32000Hz, default files have 32003Hz sample rate i think. 


I'm Invictus
  • I'm Invictus

    Crackhead

  • Members
  • Joined: 16 Jun 2014
  • United-States

#6

Posted 23 June 2015 - 06:42 PM

I tried 32000Hz, 16 bit PCM, obviously mono and no luck.

 

The default info for the Intro music in the game is 48000Hz, 32-bit float, mono. Tried this too and still no luck.


I'm Invictus
  • I'm Invictus

    Crackhead

  • Members
  • Joined: 16 Jun 2014
  • United-States

#7

Posted 26 June 2015 - 11:08 PM

I'm still needing help with this.


kayesem
  • kayesem

    Player Hater

  • Members
  • Joined: 28 Jan 2016
  • Australia

#8

Posted 14 February 2016 - 06:41 AM

I properly converted my mp3 file to 2 wav files in Audacity with mono, 48000 sample rate & project rate, tried all of the sample formats, and the bitrate is at 768kbps.

 

Drag td_loading_music.oac into

Grand Theft Auto V\x64\audio\sfx\PROLOGUE.rpf\

 

and it tells me

 

"Some files not imported, more information below.

td_loading_music.oac(Line 9): Invalid WAVE Audio data."

 

 

You converted two mp3 files to one wav? Why?

 

The mod file needs to be all the same specs as the original. 

 

You need to export the original awc in open iv - open formats mode, which gives you a folder and an oac file.

 

You then drag / drop / replace the files in folder, then import back into game mods folder using the open formats oac file, not the folder or the wav files.

 

If the files are different time length, like 5 seconds instead of 1 second, it doesn't work.

 

If you convert a wav to an mp3 it's kind of abusive generally, but it's ok to do. If you convert an mp3 to a wav, well, you just don't normally, like ever, do that. To shrink a huge picture or huge audio file down is ok, but you destroy the file quality for the sake of having a puny file-size. Once it's destroyed, the extra data is lost and if you try to scale up the other way you get aliasing and distortion just like before except now with a huge file size and none of the actual quality.

 

There are two obvious sample rate settings in audacity. Mess with them as you like but one does nothing and the other one wrecks your audio. To change properly go Tracks > Resample, then type your rate (24khz, 44.1khz, 48khz etc) and hit enter.

 

When you bounce down (export) you want a 16 bit WAV file, the appropriate sample rate, file size / length, and exact file name of the one/s to be replaced.

 

If you are starting off with mp3s, it might work but the quality will be up the sh*t even if it does, and so it's not recommended. (You want to make things better, right?) If you simply have no other source of decent audio and still want to make use of what you have, you are probably going to have a bunch of metadata in your mp3 and need to make sure you clear all of it when bouncing down / exporting. Audacity makes this easy to do, and you can either edit it within the project before you export or just go ahead and when the last window comes up hit Clear to remove all metadata. I hit clear even when there is nothing there, just because

 

I have been working with open formats today and it's a pain when things end up not-so-good. Everything is quite simple but you have to be exact and precise from start to finish. GTA is really temperamental and unforgiving. We are lucky to have open iv and audacity they are freaking awesome tools and are definitely capable, you just need to be on the ball and paying attention. It's been a few years since I was modding gta iv but I'm able to vaguely recall details and past mistakes, pretty much by making them all over again.

  • NorthwindJME likes this

vector_gamer9
  • vector_gamer9

    Player Hater

  • New Members
  • Joined: 2 weeks ago
  • Egypt

#9

Posted 2 weeks ago

 

I properly converted my mp3 file to 2 wav files in Audacity with mono, 48000 sample rate & project rate, tried all of the sample formats, and the bitrate is at 768kbps.

 

Drag td_loading_music.oac into

Grand Theft Auto V\x64\audio\sfx\PROLOGUE.rpf\

 

and it tells me

 

"Some files not imported, more information below.

td_loading_music.oac(Line 9): Invalid WAVE Audio data."

 

 

You converted two mp3 files to one wav? Why?

 

The mod file needs to be all the same specs as the original. 

 

You need to export the original awc in open iv - open formats mode, which gives you a folder and an oac file.

 

You then drag / drop / replace the files in folder, then import back into game mods folder using the open formats oac file, not the folder or the wav files.

 

If the files are different time length, like 5 seconds instead of 1 second, it doesn't work.

 

If you convert a wav to an mp3 it's kind of abusive generally, but it's ok to do. If you convert an mp3 to a wav, well, you just don't normally, like ever, do that. To shrink a huge picture or huge audio file down is ok, but you destroy the file quality for the sake of having a puny file-size. Once it's destroyed, the extra data is lost and if you try to scale up the other way you get aliasing and distortion just like before except now with a huge file size and none of the actual quality.

 

There are two obvious sample rate settings in audacity. Mess with them as you like but one does nothing and the other one wrecks your audio. To change properly go Tracks > Resample, then type your rate (24khz, 44.1khz, 48khz etc) and hit enter.

 

When you bounce down (export) you want a 16 bit WAV file, the appropriate sample rate, file size / length, and exact file name of the one/s to be replaced.

 

If you are starting off with mp3s, it might work but the quality will be up the sh*t even if it does, and so it's not recommended. (You want to make things better, right?) If you simply have no other source of decent audio and still want to make use of what you have, you are probably going to have a bunch of metadata in your mp3 and need to make sure you clear all of it when bouncing down / exporting. Audacity makes this easy to do, and you can either edit it within the project before you export or just go ahead and when the last window comes up hit Clear to remove all metadata. I hit clear even when there is nothing there, just because

 

I have been working with open formats today and it's a pain when things end up not-so-good. Everything is quite simple but you have to be exact and precise from start to finish. GTA is really temperamental and unforgiving. We are lucky to have open iv and audacity they are freaking awesome tools and are definitely capable, you just need to be on the ball and paying attention. It's been a few years since I was modding gta iv but I'm able to vaguely recall details and past mistakes, pretty much by making them all over again.

 

 

I properly converted my mp3 file to 2 wav files in Audacity with mono, 48000 sample rate & project rate, tried all of the sample formats, and the bitrate is at 768kbps.

 

Drag td_loading_music.oac into

Grand Theft Auto V\x64\audio\sfx\PROLOGUE.rpf\

 

and it tells me

 

"Some files not imported, more information below.

td_loading_music.oac(Line 9): Invalid WAVE Audio data."

 

hey hey hey hey .... i'v found another easy method ..... just follow me 


if you have vegas movie studio platinum 13.0 open it

 

1 - create a new project

2 - drag and drop the "0x0C254AE9" file in the audio track 

3 - and drag your custom music in any audio track ((((BELOW))) the original file

4 - right click the original sound and go down and hover on "Switches" and select "MUTE"

5 - press make movie on the left select "Wave (microsoft)" /on the right select "48,000;16bit;Mono,PCM

6 - go down and rename the file to "0x0C254AE9"

7 - click render





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users