Quantcast

Jump to content

» «
Photo
- - - - -

[TUT] Use OpenIV "mods" folder & keep your original GTA V

151 replies to this topic
noSkill92
  • noSkill92

    Player Hater

  • New Members
  • Joined: 25 Aug 2015
  • Portugal

#31

Posted 25 August 2015 - 08:15 PM

I've copied the update folder, the x64 folder and all those x64 rpf archives into the folder "mods". Then, when I use OpenIV to modify the archive x64v.rpf (the one inside "mods" folder, not the original one) and launch the game, the launcher deletes the original x64v.rpf and downloads it again. Don't know what I'm doing wrong.


noSkill92
  • noSkill92

    Player Hater

  • New Members
  • Joined: 25 Aug 2015
  • Portugal

#32

Posted 25 August 2015 - 08:22 PM

I can't get it, it's still tracing everything from original, not from mods.

 

(FIXED)

What did you do to fix it? I'm having the same problem. 


maxpin
  • maxpin

    Player Hater

  • Members
  • Joined: 28 Sep 2013

#33

Posted 26 August 2015 - 03:56 PM Edited by maxpin, 29 August 2015 - 12:13 PM.

 

Works for me. The only downside is that it takes up a LOT of drive space.

yeah, but at least you no need to copy the whole game.

can i copy folders like update and x64 include all files and common.rpf and all x64 a - w rpf files?

Yes.

thanks for reply but i facing problem since yesterday  when play the game i can not in control of the vehicle and when Delete openiv.asi file the game works well

 

Edit: I've noticed that when i delete a EnhancedNativeTrainer.asi and leave openiv.asi the game works well

and another fix i tray i delete ent file located in C:\Users\Admin\AppData\Roaming\GTAV Enhanced Native Trainer\ent and put openiv.asi and EnhancedNativeTrainer.asi in game directory then game works well so did i have problem in ScriptHookV ?

 

Edit: finally i fixed my problem  when u make (Gravity Moon) is on it will make the game so slow specially when u driving.


PhillBellic
  • PhillBellic

  • Members
  • Joined: 03 Jul 2012
  • Australia
  • Ban Roulette Winner 2016

#34

Posted 27 August 2015 - 03:00 AM

A very useful Tutorial, Good. Soon I will be embarking on my own Set Up of this Folder. :)


WeZLi
  • WeZLi

    Player Hater

  • New Members
  • Joined: 30 Aug 2015
  • Jordan

#35

Posted 30 August 2015 - 10:30 AM

i have copied all the rpf files to the mods folders is it okay?


PhillBellic
  • PhillBellic

  • Members
  • Joined: 03 Jul 2012
  • Australia
  • Ban Roulette Winner 2016

#36

Posted 30 August 2015 - 11:19 AM

i have copied all the rpf files to the mods folders is it okay?

That should be okay. That's what I did. :)


WeZLi
  • WeZLi

    Player Hater

  • New Members
  • Joined: 30 Aug 2015
  • Jordan

#37

Posted 30 August 2015 - 11:29 AM

 

i have copied all the rpf files to the mods folders is it okay?

That should be okay. That's what I did. :)

 

nice thank you :D 


BSalgaado98
  • BSalgaado98

    Player Hater

  • Members
  • Joined: 31 Aug 2015
  • Portugal

#38

Posted 31 August 2015 - 06:40 PM

So what do I do so the game doesnt donwload the original is there any way of solving that can i change the cars and sound mod it and the game doesnt donwload the original)?


KuroChi
  • KuroChi

    Player Hater

  • New Members
  • Joined: 12 Sep 2015
  • Australia

#39

Posted 12 September 2015 - 07:08 AM

Hey,

 

So I've made myself the mods folder, with both ASI options installed, so far I have put 'x64e.rpf' and 'update' inside, but when the 'mods' folder is in my Game Directory, it crashes my game when I go to click 'Story mode' it loads for about 5 seconds and then crashes with the 'Failed Zlib' error. When I remove the mod folder the game works fine, the reason I added the mods folder was to get a car model for LSPDFR, the whole adding of the car files worked. But since the game does an update when you try it without the mods folder. So, now that I have tried the mods folder, it just crashes my game.

 

Any idea mate?


GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#40

Posted 14 September 2015 - 08:22 AM

Hey,
 
So I've made myself the mods folder, with both ASI options installed, so far I have put 'x64e.rpf' and 'update' inside, but when the 'mods' folder is in my Game Directory, it crashes my game when I go to click 'Story mode' it loads for about 5 seconds and then crashes with the 'Failed Zlib' error. When I remove the mod folder the game works fine, the reason I added the mods folder was to get a car model for LSPDFR, the whole adding of the car files worked. But since the game does an update when you try it without the mods folder. So, now that I have tried the mods folder, it just crashes my game.
 
Any idea mate?

Try to install mods with clear copy again, and after replacing each file test it in game.
The reason behind 'Failed Zlib' maybe bad file or corruption during editing.

hostrup
  • hostrup

    Player Hater

  • Members
  • Joined: 27 Apr 2015
  • Denmark

#41

Posted 17 September 2015 - 08:14 AM

Hi

 

How do I update my update.rpf file in my mods folder ,without loosing all mods I have in there? When the game updates, I have to update the update.rpf in my mods folder to, but that will overwrite all my mods in there? Right?


GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#42

Posted 17 September 2015 - 08:18 AM

There is no way to do that, unless you know for sure what files Rockstar changed or added.
So, you need copy new version of update.rpf into your mods folder and install all mods again.
This only affects update.rpf because this is the only file Rockstar change during updates.

hostrup
  • hostrup

    Player Hater

  • Members
  • Joined: 27 Apr 2015
  • Denmark

#43

Posted 17 September 2015 - 08:28 AM

Nooooo!!!! :( That sucks big time. I have no clue which files I have edited in there by now. I have made so many small changes and added so many cars by now, that it will take forever :(

 

 

Thanks anyway.. I love OpenIV ;9


Mr.Arrow
  • Mr.Arrow

    God Save the Penis

  • Members
  • Joined: 08 Nov 2011
  • United-Kingdom

#44

Posted 17 September 2015 - 09:15 AM

Rockstar only changed the handling.meta and vehicle.meta ...

Vehicles ytd and yft are unaffected in update.rpf

hostrup
  • hostrup

    Player Hater

  • Members
  • Joined: 27 Apr 2015
  • Denmark

#45

Posted 17 September 2015 - 11:02 AM

Doesnt the whole file overwrite? When I copy my update.rpf from my main GTA install, over to my mods folder. All the cars I have changed out with new ones, they will disappear?


Bitch Ass Bullshit
  • Bitch Ass Bullshit

    Punk-ass Bitch

  • Members
  • Joined: 03 Oct 2013

#46

Posted 17 September 2015 - 11:20 AM

Rockstar only changed the handling.meta and vehicle.meta ...

Vehicles ytd and yft are unaffected in update.rpf

Which is the path for the meta files. There are several in dlc_patch folder and sub folders. Or all the meta files are new?


Makan
  • Makan

    Player Hater

  • Members
  • Joined: 07 Dec 2014
  • Sweden

#47

Posted 27 September 2015 - 10:57 PM

Whenever I Install a car mod and starts the game, it just reinstalls .. Not the whole game, but it takes like 10 min to reinstall .. what's the problem?


PlazmaBoy
  • PlazmaBoy

    Player Hater

  • Members
  • Joined: 02 Oct 2015
  • Denmark

#48

Posted 02 October 2015 - 06:20 PM Edited by PlazmaBoy, 02 October 2015 - 06:31 PM.

Why is it, that some cars can't replace others? I've used an Audi S5 for the tailgater, which worked perfectly. Only problem was the lack of rear doors, hence I wanted to replace a different car. I've tried replacing the Schwarzer, Futo, Fusilade, Blista + others that I don't remember, but they all remain stock.. What can I do to either prevent this, or check it before I replace? I really don't understand it :(

 

Another thing, I downloadet a BMW 7-series, and replaced it with the Stanier (the files came that way), and the car drove with no problems. Now I replaced it with the Oracle, since it's based on the 7-series, but now I can't make a turn, without making a barrel roll.. What's wrong here? And again, how do I prevent it? I think I'm missing something :D


warhamster94
  • warhamster94

    Player Hater

  • Members
  • Joined: 06 Mar 2013

#49

Posted 05 October 2015 - 05:02 PM

how do u get the game to use the mod folder instead of the original one as mine still keps re downloading every time i mod a car


GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#50

Posted 05 October 2015 - 05:03 PM

how do u get the game to use the mod folder instead of the original one as mine still keps re downloading every time i mod a car

Just read the instruction in the first post.

warhamster94
  • warhamster94

    Player Hater

  • Members
  • Joined: 06 Mar 2013

#51

Posted 05 October 2015 - 05:05 PM Edited by warhamster94, 05 October 2015 - 05:29 PM.

yes I have followed everything that you said to do and it dosint want to use the modded folder just uses the original one

 

Got it to work now thank you for the help :) best tutorial ever


Fizzclan
  • Fizzclan

    Player Hater

  • New Members
  • Joined: 12 Oct 2015
  • Ireland

#52

Posted 12 October 2015 - 08:42 PM

I've been having an issue, whenever I setup a mods folder and say put x64e.rpf in it, I can mod it with the mods I want, when I boot into the game it runs fine just like I want, but when I exit the game the folder just deletes itself, and the asi manager uninstalls both files required....Please give me a hand here.


GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#53

Posted 13 October 2015 - 07:15 AM

I've been having an issue, whenever I setup a mods folder and say put x64e.rpf in it, I can mod it with the mods I want, when I boot into the game it runs fine just like I want, but when I exit the game the folder just deletes itself, and the asi manager uninstalls both files required....Please give me a hand here.

You probably use "Bilago's GTAV Mod Manager". This tool is removes your files. You no need to use any mod managers if you uses "mods" folder.

Fizzclan
  • Fizzclan

    Player Hater

  • New Members
  • Joined: 12 Oct 2015
  • Ireland

#54

Posted 13 October 2015 - 04:24 PM

 

I've been having an issue, whenever I setup a mods folder and say put x64e.rpf in it, I can mod it with the mods I want, when I boot into the game it runs fine just like I want, but when I exit the game the folder just deletes itself, and the asi manager uninstalls both files required....Please give me a hand here.

You probably use "Bilago's GTAV Mod Manager". This tool is removes your files. You no need to use any mod managers if you uses "mods" folder.

 

Ahh ok thanks man, i'll remove that straight away, thanks for the reply.


Fizzclan
  • Fizzclan

    Player Hater

  • New Members
  • Joined: 12 Oct 2015
  • Ireland

#55

Posted 14 October 2015 - 09:11 PM

How do I use trainers, such as Script Hook, It wont load in-game, but the modified rpf files do.


GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#56

Posted 15 October 2015 - 05:14 AM

@Fizzclan "mods" folder is only for RPF mods.


ILS_Supernova
  • ILS_Supernova

    All! Of! You! Are! Going! To! Die!

  • Members
  • Joined: 26 Oct 2011
  • None

#57

Posted 16 October 2015 - 03:07 PM

Hello All!
 
I need help please . .I've followed how to run the mods through mods folder . . . I load the game and get a few seconds into the loading screens after pressing story mod and the game crashes. I then tried it with openiv.asi unistalled and it loaded the original files just fine . .opening the openiv text file overwhelms me and I cant see anything through the many lines that indicate a error??? 
what can the problem be? 
 
All help will be great.
 
Since now I've been running mods with the offline mode command which just loads the game straight into story mode but this means I can't update the game, with the lowrider DLC coming I need to try get this method working

Could the problem be that I'm using a older update folder then the one in my main gta v folder? Basically I backed up all my mods before i updated gta v then made my mods folder and just copied all my modded files over

GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#58

Posted 16 October 2015 - 03:09 PM

Could the problem be that I'm using a older update folder then the one in my main gta v folder? Basically I backed up all my mods before i updated gta v then made my mods folder and just copied all my modded files over

Yes, you need to have same version of update.rpf in both game and "mods" folder.
This is mean you need to copy new version of update.rpf into "mods" after each GTA V update.

ILS_Supernova
  • ILS_Supernova

    All! Of! You! Are! Going! To! Die!

  • Members
  • Joined: 26 Oct 2011
  • None

#59

Posted 16 October 2015 - 03:22 PM

Could the problem be that I'm using a older update folder then the one in my main gta v folder? Basically I backed up all my mods before i updated gta v then made my mods folder and just copied all my modded files over

Yes, you need to have same version of update.rpf in both game and "mods" folder.
This is mean you need to copy new version of update.rpf into "mods" after each GTA V update.

Thank you so much! Would that mean my vehicles mods in the other folders be fine?

GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#60

Posted 16 October 2015 - 07:55 PM

Would that mean my vehicles mods in the other folders be fine?

You mean in other archives besides update.rpf? Yes, they fine.




3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users