Quantcast

Jump to content

» «
Photo

[SA|TUT|TOO] Add Really New Vehicles

157 replies to this topic
mpPako
  • mpPako

    Player Hater

  • New Members
  • Joined: 22 Jan 2015
  • Poland

#61

Posted 19 March 2015 - 02:04 PM Edited by mpPako, 19 March 2015 - 02:11 PM.

This is only lights, but what with viligante and other missions? I added taxi, but how i can add Taxi mission to this car?

And what with the amphicars like ATV. I added it too and i can't drive in water. :/


Automan
  • Automan

    Grandfather Modder

  • Members
  • Joined: 13 Dec 2008
  • Italy

#62

Posted 20 March 2015 - 08:44 AM

These mods allow you to intervene on the cars and their parts,

but the management of their use for the missions and for special functions

require the mod much more complex.

I do not know if exist any other type of this mod. :)


NYXIdT
  • NYXIdT

    Player Hater

  • Members
  • Joined: 07 Nov 2014
  • Russia

#63

Posted 05 April 2015 - 09:56 AM

Ok, after five years on the east coast over 80 added cars and bikes, something finally went wrong.

 

54691cdf7446db9d259ff488bf4fecb7.jpeg

 

As you can see, this bug affected not only the new cars but some of the vanilla ones that I never touched.

 

I thought maybe this had something to do with IDs, so I moved the newest vehicles' IDs to 19000+ - didn't help.

Then I tried undoing latest changes, including: removing last 10 cars, last 10 additional handling lines, all additional bike lines, disabling bike handling line limit itself, removing .dff and .txd's, rebuilding my modded .img and even gta3.img, removing extra audio lines, increasing "count of killable models IDs" limit. Nothing helped.

In fact, after I had done all of the above, this bug actually affected even more cars than it did initially.

 

I know this is very random and the game is probably not supposed to handle this many vehicles, but still. Has anybody else encountered this bug? Maybe a wild guess how to fix it?

Thank you very much


fastman92
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009
  • Poland
  • Best Conversion 2016 [GTA: Underground] [Contribution]
    Contribution Award [Mods]

#64

Posted 05 April 2015 - 11:05 AM Edited by fastman92, 05 April 2015 - 11:09 AM.

Ok, after five years on the east coast over 80 added cars and bikes, something finally went wrong.
 
54691cdf7446db9d259ff488bf4fecb7.jpeg
 
As you can see, this bug affected not only the new cars but some of the vanilla ones that I never touched.
 
I thought maybe this had something to do with IDs, so I moved the newest vehicles' IDs to 19000+ - didn't help.
Then I tried undoing latest changes, including: removing last 10 cars, last 10 additional handling lines, all additional bike lines, disabling bike handling line limit itself, removing .dff and .txd's, rebuilding my modded .img and even gta3.img, removing extra audio lines, increasing "count of killable models IDs" limit. Nothing helped.
In fact, after I had done all of the above, this bug actually affected even more cars than it did initially.
 
I know this is very random and the game is probably not supposed to handle this many vehicles, but still. Has anybody else encountered this bug? Maybe a wild guess how to fix it?
Thank you very much

Looks like vehicles.ide line would be loaded wrong.

Make sure you don't use Handling ID adder by Alexander Blade.

"disabling bike handling line limit itself"
Actually, handling.cfg limits are enabled or not.
If you commented "Number of bike lines", it will simply have a default value.

Show me your .log file.

Fenton
  • Fenton

    Ponytail Lover

  • Facade Corporation
  • Joined: 18 Nov 2012
  • Indonesia

#65

Posted 05 April 2015 - 11:13 AM

Those white wheels are on it's vehicle bug, It's UV Channel is sets to 1, If you want the wheels black, Change the UV channel to 2, Tested on Zmodeler and working good.


NYXIdT
  • NYXIdT

    Player Hater

  • Members
  • Joined: 07 Nov 2014
  • Russia

#66

Posted 05 April 2015 - 11:22 AM Edited by NYXIdT, 05 April 2015 - 11:29 AM.

@fastman92

Can you please elaborate how exactly this relates to vehicles.ide? I fail to identify the problem

 

Furthermore, as I said, I tried to revert vehicles.ide to the state it was in before I noticed the bug, but the bug remained.

 

I'm not using Handling ID adder by Alexander Blade, I'm using your limit adjuster and so far new handling lines work fine.

 

 

If you commented "Number of bike lines", it will simply have a default value.

Yes, that's what I meant I did.

 

 


Show me your .log file.

 

Spoiler

 


fastman92
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009
  • Poland
  • Best Conversion 2016 [GTA: Underground] [Contribution]
    Contribution Award [Mods]

#67

Posted 05 April 2015 - 12:30 PM

Use 'fastman92 limit adjuster 1.5'

NYXIdT
  • NYXIdT

    Player Hater

  • Members
  • Joined: 07 Nov 2014
  • Russia

#68

Posted 05 April 2015 - 01:35 PM

Use 'fastman92 limit adjuster 1.5'

 

Installed that. No changes

 

90a00883c8280ed029f3a58dd5d2c288.jpeg


Fenton
  • Fenton

    Ponytail Lover

  • Facade Corporation
  • Joined: 18 Nov 2012
  • Indonesia

#69

Posted 05 April 2015 - 01:45 PM

I think there is some problems with those vehicles not handling or vehicle.IDE, As I see that white circle on the wheels is one of annoying vehicle bugs but This thing can be fixed by Zmodeler or something similar to Zmodeler


Automan
  • Automan

    Grandfather Modder

  • Members
  • Joined: 13 Dec 2008
  • Italy

#70

Posted 05 April 2015 - 02:23 PM Edited by Automan, 05 April 2015 - 02:24 PM.

The height of ground of the wheels is managed only by vehicles.ide:
400, landstal,  landstal,  car,   LANDSTAL,  LANDSTK,  null, normal,  10, 0, 0,  -1, 0.83, 0.83,  0
something has ruined this file...


M4k3
  • M4k3

    ...

  • Members
  • Joined: 18 May 2011
  • Russia

#71

Posted 05 April 2015 - 03:15 PM Edited by M4k3, 05 April 2015 - 03:16 PM.

@Automan, he talks about these weird polygons not about wheels size.

 

I think the problem is in models. Vanilla vehicles have these black polygons actually (not all though). The only problem I see here is these polygons are white on modded vehicles and (as Fenton said already) you need to fix models in Zmodeler or something else.


Automan
  • Automan

    Grandfather Modder

  • Members
  • Joined: 13 Dec 2008
  • Italy

#72

Posted 05 April 2015 - 04:56 PM Edited by Automan, 06 April 2015 - 08:12 AM.

Certainly, it is the only possible problem I saw in vehicle, that might affect the tool. :D

 

EDIT: I do not know if this fixes this problem:

http://gtaforums.com...nilla-vehicles/


DJCraig34
  • DJCraig34

    Crackhead

  • Members
  • Joined: 16 Apr 2012

#73

Posted 09 April 2015 - 03:44 AM

http://i.imgur.com/ECZSklO.png

 

I'm trying to add this jeep in

everytime I tried to start the game it always give this error


Automan
  • Automan

    Grandfather Modder

  • Members
  • Joined: 13 Dec 2008
  • Italy

#74

Posted 09 April 2015 - 08:05 AM

Was used the first free ID of the file "Free IDs.txt"?...


WickedSick.1337
  • WickedSick.1337

    Wicked.ak

  • Members
  • Joined: 03 Apr 2015
  • Iran

#75

Posted 09 April 2015 - 10:15 AM

Hi
It looks cool!
Just a question
Has it got any bugs?
Cuz auto adder apps have bugs like ACA in GTA IV

Automan
  • Automan

    Grandfather Modder

  • Members
  • Joined: 13 Dec 2008
  • Italy

#76

Posted 09 April 2015 - 01:12 PM

We found no bugs, so far; only errors SA version, installation, or bad use with other mods...

  • WickedSick.1337 likes this

fastman92
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009
  • Poland
  • Best Conversion 2016 [GTA: Underground] [Contribution]
    Contribution Award [Mods]

#77

Posted 09 April 2015 - 01:17 PM

http://i.imgur.com/ECZSklO.png

 

I'm trying to add this jeep in

everytime I tried to start the game it always give this error

'IDE: cars' limit needs to be increased.


DJCraig34
  • DJCraig34

    Crackhead

  • Members
  • Joined: 16 Apr 2012

#78

Posted 09 April 2015 - 05:36 PM Edited by DJCraig34, 09 April 2015 - 05:36 PM.

 

http://i.imgur.com/ECZSklO.png

 

I'm trying to add this jeep in

everytime I tried to start the game it always give this error

'IDE: cars' limit needs to be increased.

 

 

Is there a away to increase the limit within the vehicles.ide file?

I done it with the limit adjuster but I'm getting the same results

 

Was used the first free ID of the file "Free IDs.txt"?...

Yes I used 612 to be extact


fastman92
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009
  • Poland
  • Best Conversion 2016 [GTA: Underground] [Contribution]
    Contribution Award [Mods]

#79

Posted 09 April 2015 - 05:40 PM

 

 

http://i.imgur.com/ECZSklO.png

 

I'm trying to add this jeep in

everytime I tried to start the game it always give this error

'IDE: cars' limit needs to be increased.

 

 

Is there a away to increase the limit within the vehicles.ide file?

I done it with the limit adjuster but I'm getting the same results

 

Was used the first free ID of the file "Free IDs.txt"?...

Yes I used 612 to be extact

 

 

No way to adjust the limit from IDE file.

 

If you can't install the limit adjuster or edit .ini file properly, then adding vehicles is not for you. Leave it.


Automan
  • Automan

    Grandfather Modder

  • Members
  • Joined: 13 Dec 2008
  • Italy

#80

Posted 10 April 2015 - 05:47 AM Edited by Automan, 10 April 2015 - 05:48 AM.

Open the file fastman92limitAdjuster.ini, and modify as well:

 

(1)

[IDE LIMITS]
; IDE: objs section type 1 (14000)
#IDE Objects Type 1 = 14000
; IDE: objs type section 2 (70)
#IDE Objects Type 2 = 70
; IDE: tobj section (169)
#Timed Objects = 169
; IDE: hier (92)
#Hier Objects = 100
; IDE: cars section (212)
#Vehicle Models = 212 <<<-----

to this:

[IDE LIMITS]
; IDE: objs section type 1 (14000)
#IDE Objects Type 1 = 14000
; IDE: objs type section 2 (70)
#IDE Objects Type 2 = 70
; IDE: tobj section (169)
#Timed Objects = 169
; IDE: hier (92)
#Hier Objects = 100
; IDE: cars section (212) << ----- no need to increase this line
Vehicle Models = 213 <<<-----

Pay attention here to remove the '#'!

 

(2)

[HANDLING.CFG LIMITS]
#Apply Handling.cfg patch = 0 <<<-----
# Number of standard lines = 210 <<<-----
# Number of bike lines = 13
# Number of flying lines = 24
# Number of boat lines = 12

to this:

[HANDLING.CFG LIMITS]
Apply patch handling.cfg = 1 <<<-----
Number of standard lines = 211 <<<-----
# Number of bike lines = 13
# Number of flying lines = 24
# Number of boat lines = 12

Pay attention here to remove the '#'!

 

If it does not work, the problem is more...


DJCraig34
  • DJCraig34

    Crackhead

  • Members
  • Joined: 16 Apr 2012

#81

Posted 10 April 2015 - 10:20 PM Edited by DJCraig34, 10 April 2015 - 10:23 PM.

Open the file fastman92limitAdjuster.ini, and modify as well:
 
(1)

[IDE LIMITS]
; IDE: objs section type 1 (14000)
#IDE Objects Type 1 = 14000
; IDE: objs type section 2 (70)
#IDE Objects Type 2 = 70
; IDE: tobj section (169)
#Timed Objects = 169
; IDE: hier (92)
#Hier Objects = 100
; IDE: cars section (212)
#Vehicle Models = 212 <<<-----
to this:
[IDE LIMITS]
; IDE: objs section type 1 (14000)
#IDE Objects Type 1 = 14000
; IDE: objs type section 2 (70)
#IDE Objects Type 2 = 70
; IDE: tobj section (169)
#Timed Objects = 169
; IDE: hier (92)
#Hier Objects = 100
; IDE: cars section (212) << ----- no need to increase this line
Vehicle Models = 213 <<<-----
Pay attention here to remove the '#'!
 
(2)
[HANDLING.CFG LIMITS]
#Apply Handling.cfg patch = 0 <<<-----
# Number of standard lines = 210 <<<-----
# Number of bike lines = 13
# Number of flying lines = 24
# Number of boat lines = 12
to this:
[HANDLING.CFG LIMITS]
Apply patch handling.cfg = 1 <<<-----
Number of standard lines = 211 <<<-----
# Number of bike lines = 13
# Number of flying lines = 24
# Number of boat lines = 12
Pay attention here to remove the '#'!
 
If it does not work, the problem is more...



here's my attempt so far


[IDE LIMITS]

; IDE : objs section type 1 (14000)
#IDE Objects Type 1 = 14000

; IDE : objs section type 2 (70)
#IDE Objects Type 2 = 70

; IDE : tobj section (169)
#Timed Objects = 169

; IDE : hier (92)
#Hier Objects = 100

; IDE : cars section (212)
Vehicle Models=213

; IDE : peds section ( 278 )
#Ped Models = 278

# IDE : weap section ( 51 )
#Weapon Models = 51

[HANDLING.CFG LIMITS]
Apply handling.cfg patch = 1
Number of standard lines = 211
#Number of bike lines = 13
#Number of flying lines = 24
#Number of boat lines = 12
 

http://i.imgur.com/ECZSklO.png
 
I'm trying to add this jeep in
everytime I tried to start the game it always give this error

'IDE: cars' limit needs to be increased.

Is there a away to increase the limit within the vehicles.ide file?
I done it with the limit adjuster but I'm getting the same results
 

Was used the first free ID of the file "Free IDs.txt"?...

Yes I used 612 to be extact

 
No way to adjust the limit from IDE file.
 
If you can't install the limit adjuster or edit .ini file properly, then adding vehicles is not for you. Leave it.


The limit adjuster is already installed , I followed the tutorial

Automan
  • Automan

    Grandfather Modder

  • Members
  • Joined: 13 Dec 2008
  • Italy

#82

Posted 11 April 2015 - 08:41 AM

Well.

1) GTA-SA is version 1.0 (US) HOODLUM noCD 14,383.616 bytes (14,047 KB)?

2) There are other tools, such as IVF211 (and so ASI12), Dashboard321, ELM91, etc?

3) Limit Adjuster is version 1.3 or later?


fastman92
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009
  • Poland
  • Best Conversion 2016 [GTA: Underground] [Contribution]
    Contribution Award [Mods]

#83

Posted 11 April 2015 - 08:46 AM

If you added more than one vehicle

; IDE : cars section (212)
Vehicle Models=213

Increase it properly. Make it 220 for example.

You should also post the contents of log file.


DJCraig34
  • DJCraig34

    Crackhead

  • Members
  • Joined: 16 Apr 2012

#84

Posted 11 April 2015 - 05:27 PM Edited by DJCraig34, 11 April 2015 - 05:29 PM.

Well.
1) GTA-SA is version 1.0 (US) HOODLUM noCD 14,383.616 bytes (14,047 KB)?
2) There are other tools, such as IVF211 (and so ASI12), Dashboard321, ELM91, etc?
3) Limit Adjuster is version 1.3 or later?


1. Yes It should in a log that I'm about to post
2. besides the GTA Garage Mod Manager just the tools that downloaded to add in the cars
3. I just updated towards 1.4 few days ago

I just found out the problem, It turns out that I didn't configure the SA Limit adjuster with thoses I mange to fix the ploblem however I found another one which il post soon
 

If you added more than one vehicle
 

; IDE : cars section (212)
Vehicle Models=213
Increase it properly. Make it 220 for example.
You should also post the contents of log file.


I only added one one and here the log


Game crashed unfortunately, here's a crash log:
Current process ID: 34456
Last file to be loaded: MODELS\GTA3ORI.IMG
Last library loaded: NOT SET
Exception address: 0x015632B0 ("gta_sa.exe"+0x11632B0)
Exception code: 0xC0000005
Exception name: EXCEPTION_ACCESS_VIOLATION
Inaccessible memory address: 0x28

General registers:
EAX: 0x00000000 (0)
EBX: 0x00000000 (0)
ECX: 0xC9742400 (-915135488)
EDX: 0x000000FF (255)
ESI: 0x00000000 (0)
EDI: 0x0028F9E0 (2685408)
EBP: 0x000062A6 (25254)
ESP: 0x0028F994 (2685332)
EIP: 0x015632B0 (22426288)
EFL: 0x00210246 (2163270)

Segment registers:
CS: 0023
DS: 002B
ES: 002B
FS: 0053
GS: 002B
SS: 002B

FPU registers:
ST0: 108.226669 bytes: 00 00 00 00 00 0E 74 D8 05 40
ST1: 107.226669 bytes: 00 00 00 00 00 0E 74 D6 05 40
ST2: 1.000000 bytes: 00 00 00 00 00 00 00 80 FF 3F
ST3: -40.959999 bytes: 00 00 00 00 00 0A D7 A3 04 C0
ST4: 1.000000 bytes: 00 00 00 00 00 00 00 80 FF 3F
ST5: 0.000000 bytes: 00 00 00 00 00 00 00 00 00 00
ST6: 0.000000 bytes: 00 00 00 00 00 00 00 00 00 00
ST7: 2777.034180 bytes: 00 00 00 00 00 8C 90 AD 0A 40
CTRL: 007F
STAT: 0030
TAGS: FFFF

MMX registers, 8 bytes:
MM0: 00 00 00 00 00 0E 74 D8
MM1: 00 00 00 00 00 0E 74 D6
MM2: 00 00 00 00 00 00 00 80
MM3: 00 00 00 00 00 0A D7 A3
MM4: 00 00 00 00 00 00 00 80
MM5: 00 00 00 00 00 00 00 00
MM6: 00 00 00 00 00 00 00 00
MM7: 00 00 00 00 00 8C 90 AD

XMM registers, 16 bytes:
XMM0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM1: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM2: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM3: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM4: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM5: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM6: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM7: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

Automan
  • Automan

    Grandfather Modder

  • Members
  • Joined: 13 Dec 2008
  • Italy

#85

Posted 12 April 2015 - 08:28 AM

Expect the analysis of the log by fastman92. :)

(I suppose you have used the method of 2 gta3, however, since the file gta3ori.img does not exist. :) )


fastman92
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009
  • Poland
  • Best Conversion 2016 [GTA: Underground] [Contribution]
    Contribution Award [Mods]

#86

Posted 12 April 2015 - 08:30 AM Edited by fastman92, 12 April 2015 - 08:50 AM.

You selected a part of log, you didn't post a full log.

Why?

 

You should post a full log.

 

Well.
1) GTA-SA is version 1.0 (US) HOODLUM noCD 14,383.616 bytes (14,047 KB)?
2) There are other tools, such as IVF211 (and so ASI12), Dashboard321, ELM91, etc?
3) Limit Adjuster is version 1.3 or later?


1. Yes It should in a log that I'm about to post
2. besides the GTA Garage Mod Manager just the tools that downloaded to add in the cars
3. I just updated towards 1.4 few days ago

I just found out the problem, It turns out that I didn't configure the SA Limit adjuster with thoses I mange to fix the ploblem however I found another one which il post soon
 

If you added more than one vehicle
 



; IDE : cars section (212)
Vehicle Models=213
Increase it properly. Make it 220 for example.
You should also post the contents of log file.

 


I only added one one and here the log


Game crashed unfortunately, here's a crash log:
Current process ID: 34456
Last file to be loaded: MODELS\GTA3ORI.IMG
Last library loaded: NOT SET
Exception address: 0x015632B0 ("gta_sa.exe"+0x11632B0)
Exception code: 0xC0000005
Exception name: EXCEPTION_ACCESS_VIOLATION
Inaccessible memory address: 0x28

General registers:
EAX: 0x00000000 (0)
EBX: 0x00000000 (0)
ECX: 0xC9742400 (-915135488)
EDX: 0x000000FF (255)
ESI: 0x00000000 (0)
EDI: 0x0028F9E0 (2685408)
EBP: 0x000062A6 (25254)
ESP: 0x0028F994 (2685332)
EIP: 0x015632B0 (22426288)
EFL: 0x00210246 (2163270)

Segment registers:
CS: 0023
DS: 002B
ES: 002B
FS: 0053
GS: 002B
SS: 002B

FPU registers:
ST0: 108.226669 bytes: 00 00 00 00 00 0E 74 D8 05 40
ST1: 107.226669 bytes: 00 00 00 00 00 0E 74 D6 05 40
ST2: 1.000000 bytes: 00 00 00 00 00 00 00 80 FF 3F
ST3: -40.959999 bytes: 00 00 00 00 00 0A D7 A3 04 C0
ST4: 1.000000 bytes: 00 00 00 00 00 00 00 80 FF 3F
ST5: 0.000000 bytes: 00 00 00 00 00 00 00 00 00 00
ST6: 0.000000 bytes: 00 00 00 00 00 00 00 00 00 00
ST7: 2777.034180 bytes: 00 00 00 00 00 8C 90 AD 0A 40
CTRL: 007F
STAT: 0030
TAGS: FFFF

MMX registers, 8 bytes:
MM0: 00 00 00 00 00 0E 74 D8
MM1: 00 00 00 00 00 0E 74 D6
MM2: 00 00 00 00 00 00 00 80
MM3: 00 00 00 00 00 0A D7 A3
MM4: 00 00 00 00 00 00 00 80
MM5: 00 00 00 00 00 00 00 00
MM6: 00 00 00 00 00 00 00 00
MM7: 00 00 00 00 00 8C 90 AD

XMM registers, 16 bytes:
XMM0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM1: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM2: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM3: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM4: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM5: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM6: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM7: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

 

You've put too many .col files, exceeding the limit.

 

Read this post.

http://gtaforums.com...r/?p=1067265310


DJCraig34
  • DJCraig34

    Crackhead

  • Members
  • Joined: 16 Apr 2012

#87

Posted 12 April 2015 - 05:29 PM Edited by DJCraig34, 12 April 2015 - 05:29 PM.

You've put too many .col files, exceeding the limit.
 
Read this post.
http://gtaforums.com...r/?p=1067265310
[/quote]

Sorry I thought you mean the crash log here's the full log


Enabling handling.cfg limit adjuster.
New limits:
Number of standard lines = 211
Number of bike lines = 13
Number of flying lines = 24
Number of boat lines = 12
Number of animation group lines = 30

&mod_HandlingManager = 0x3B64A40, sizeof(mod_HandlingManager) = 0xE1B8
sizeof_cHandlingDataMgr_header = 0x68
sizeof(tHandlingData_extended) = 0x100
---------------------------------------------
Modified limit of IDE:cars section to 220
---------------------------------------------
Modified limit of cargrp.dat, number of groups: 34 number of members per group to: 24
---------------------------------------------
Error reporting going to be applied.
GTA_ERROR_ATTEMPT_TO_LOAD_OBJET_INSTANCE_WITH_UNDEFINED_ID enabled.
GTA_ERROR_MODEL_DOES_NOT_HAVE_COLLISION_LOADED enabled.
Error reporting is applied now.
---------------------------------------------
Number of memory changes made: 293
---------------------------------------------

Game crashed unfortunately, here's a crash log:
Current process ID: 34004
Last file to be loaded: MODELS\GTA3ORI.IMG
Last library loaded: NOT SET
Exception address: 0x015632B0 ("gta_sa.exe"+0x11632B0)
Exception code: 0xC0000005
Exception name: EXCEPTION_ACCESS_VIOLATION
Inaccessible memory address: 0x28

General registers:
EAX: 0x00000000 (0)
EBX: 0x00000000 (0)
ECX: 0xC9742400 (-915135488)
EDX: 0x000000FF (255)
ESI: 0x00000000 (0)
EDI: 0x0028F9E0 (2685408)
EBP: 0x000062A6 (25254)
ESP: 0x0028F994 (2685332)
EIP: 0x015632B0 (22426288)
EFL: 0x00210246 (2163270)

Segment registers:
CS: 0023
DS: 002B
ES: 002B
FS: 0053
GS: 002B
SS: 002B

FPU registers:
ST0: 108.226669 bytes: 00 00 00 00 00 0E 74 D8 05 40
ST1: 107.226669 bytes: 00 00 00 00 00 0E 74 D6 05 40
ST2: 1.000000 bytes: 00 00 00 00 00 00 00 80 FF 3F
ST3: -40.959999 bytes: 00 00 00 00 00 0A D7 A3 04 C0
ST4: 1.000000 bytes: 00 00 00 00 00 00 00 80 FF 3F
ST5: 0.000000 bytes: 00 00 00 00 00 00 00 00 00 00
ST6: 0.000000 bytes: 00 00 00 00 00 00 00 00 00 00
ST7: 5122.228027 bytes: 00 00 00 00 00 D3 11 A0 0B 40
CTRL: 007F
STAT: 0030
TAGS: FFFF

MMX registers, 8 bytes:
MM0: 00 00 00 00 00 0E 74 D8
MM1: 00 00 00 00 00 0E 74 D6
MM2: 00 00 00 00 00 00 00 80
MM3: 00 00 00 00 00 0A D7 A3
MM4: 00 00 00 00 00 00 00 80
MM5: 00 00 00 00 00 00 00 00
MM6: 00 00 00 00 00 00 00 00
MM7: 00 00 00 00 00 D3 11 A0

XMM registers, 16 bytes:
XMM0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM1: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM2: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM3: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM4: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM5: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM6: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
XMM7: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

Module list
; Path Module file size Base Size of image Entry point
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\gta_sa.exe 14383616 0x00400000 0x01177000 0x00824570
C:\Windows\SysWOW64\ntdll.dll 1292192 0x77300000 0x00180000 0x00000000
C:\Windows\syswow64\kernel32.dll 1114112 0x75640000 0x00110000 0x75653293
C:\Windows\syswow64\KERNELBASE.dll 274944 0x76AF0000 0x00047000 0x76AF74C1
C:\Windows\system32\WINMM.dll 194048 0x71E00000 0x00032000 0x71E037F1
C:\Windows\syswow64\msvcrt.dll 690688 0x76BE0000 0x000AC000 0x76BEA472
C:\Windows\syswow64\USER32.dll 833024 0x75500000 0x00100000 0x7551B6ED
C:\Windows\syswow64\GDI32.dll 311808 0x76A50000 0x00090000 0x76A66343
C:\Windows\syswow64\LPK.dll 25600 0x75A00000 0x0000A000 0x75A036A0
C:\Windows\syswow64\USP10.dll 626688 0x74F40000 0x0009D000 0x74F740EA
C:\Windows\syswow64\ADVAPI32.dll 640512 0x76910000 0x000A0000 0x76924965
C:\Windows\SysWOW64\sechost.dll 92160 0x768C0000 0x00019000 0x768C4975
C:\Windows\syswow64\RPCRT4.dll 664064 0x74CF0000 0x000F0000 0x74D00569
C:\Windows\syswow64\SspiCli.dll 96768 0x74C90000 0x00060000 0x74CAA3B3
C:\Windows\syswow64\CRYPTBASE.dll 36864 0x74C80000 0x0000C000 0x74C810E1
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\vorbisfile.dll 53760 0x671B0000 0x00011000 0x671B197B
C:\Windows\syswow64\WS2_32.dll 206848 0x76A10000 0x00035000 0x76A1145D
C:\Windows\syswow64\NSI.dll 8704 0x75A10000 0x00006000 0x75A11782
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\EAX.DLL 188416 0x10000000 0x00030000 0x1001A472
C:\Windows\syswow64\ole32.dll 1414144 0x75890000 0x0015C000 0x758DBA3D
C:\Windows\system32\apphelp.dll 295936 0x720E0000 0x0004C000 0x720E2C14
C:\Windows\AppPatch\AcGenral.DLL 2176512 0x71EC0000 0x00218000 0x71EC220F
C:\Windows\syswow64\SHLWAPI.dll 350208 0x76B80000 0x00057000 0x76B99BA6
C:\Windows\system32\UxTheme.dll 245760 0x71E40000 0x00080000 0x71E537C9
C:\Windows\system32\samcli.dll 51200 0x71DF0000 0x0000F000 0x71DF125E
C:\Windows\syswow64\OLEAUT32.dll 571904 0x75470000 0x0008F000 0x75473FB1
C:\Windows\system32\MSACM32.dll 72192 0x71DD0000 0x00014000 0x71DD1340
C:\Windows\system32\VERSION.dll 21504 0x71DC0000 0x00009000 0x71DC1220
C:\Windows\syswow64\SHELL32.dll 12875264 0x75C70000 0x00C4B000 0x75CF1551
C:\Windows\system32\sfc.dll 2560 0x72FA0000 0x00003000 0x00000000
C:\Windows\system32\sfc_os.DLL 40960 0x72F90000 0x0000D000 0x72F91392
C:\Windows\syswow64\USERENV.dll 81920 0x757E0000 0x00017000 0x757E1C9D
C:\Windows\syswow64\profapi.dll 31744 0x75750000 0x0000B000 0x75751992
C:\Windows\system32\dwmapi.dll 67072 0x71DA0000 0x00013000 0x71DA1D3F
C:\Windows\syswow64\SETUPAPI.dll 1667584 0x76C90000 0x0019D000 0x76C917E7
C:\Windows\syswow64\CFGMGR32.dll 145920 0x75760000 0x00027000 0x757658B9
C:\Windows\syswow64\DEVOBJ.dll 64512 0x768F0000 0x00012000 0x768F1441
C:\Windows\syswow64\urlmon.dll 1311232 0x74DF0000 0x0014B000 0x74DF2B30
C:\Windows\syswow64\api-ms-win-downlevel-ole32-l1-1-0.dll 5632 0x76B70000 0x00004000 0x00000000
C:\Windows\syswow64\api-ms-win-downlevel-shlwapi-l1-1-0.dll 9728 0x759F0000 0x00004000 0x00000000
C:\Windows\syswow64\api-ms-win-downlevel-advapi32-l1-1-0.dll 10752 0x768E0000 0x00005000 0x00000000
C:\Windows\syswow64\api-ms-win-downlevel-user32-l1-1-0.dll 4096 0x75600000 0x00004000 0x00000000
C:\Windows\syswow64\api-ms-win-downlevel-version-l1-1-0.dll 3072 0x75C60000 0x00004000 0x00000000
C:\Windows\syswow64\api-ms-win-downlevel-normaliz-l1-1-0.dll 2560 0x74DE0000 0x00003000 0x00000000
C:\Windows\syswow64\normaliz.DLL 2048 0x76AE0000 0x00003000 0x00000000
C:\Windows\syswow64\iertutil.dll 2278400 0x75A20000 0x00232000 0x75A23B60
C:\Windows\syswow64\WININET.dll 1888256 0x75290000 0x001D5000 0x75292A30
C:\Windows\system32\MPR.dll 64000 0x71D80000 0x00012000 0x71D81200
C:\Windows\system32\IMM32.DLL 119808 0x769B0000 0x00060000 0x769C158F
C:\Windows\syswow64\MSCTF.dll 828928 0x76E30000 0x000CC000 0x76E3168B
C:\Program Files (x86)\AVG\AVG2015\avghookx.dll 507632 0x70D50000 0x0007D000 0x70D78CAD
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\vorbishooked.DLL 65536 0x01590000 0x00011000 0x01594C98
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\ogg.dll 36864 0x015B0000 0x00009000 0x015B302E
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\vorbis.dll 1060864 0x03260000 0x00108000 0x03273F7C
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\$fastman92limitAdjuster.asi 454144 0x66D40000 0x0007B000 0x66D81AEE
C:\Windows\syswow64\PSAPI.DLL 6144 0x772D0000 0x00005000 0x772D1438
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\DllTricks.dll 7680 0x6C530000 0x00006000 0x6C531593
C:\Windows\system32\MSVCR100.dll 773968 0x72A90000 0x000BF000 0x72AA1DFC
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\CLEO.asi 264192 0x66CD0000 0x0006B000 0x66CDE3E4
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\BASS.dll 107584 0x11000000 0x0004D000 0x1104C036
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\cleo\FileSystemOperations.cleo 65024 0x67190000 0x00014000 0x67191203
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\cleo\IniFiles.cleo 81920 0x66BB0000 0x00018000 0x66BB13AC
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\cleo\IntOperations.cleo 58368 0x66B70000 0x00013000 0x66B71181
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\modloader.asi 606208 0x66A60000 0x0009A000 0x66AADD13
C:\Windows\system32\dbghelp.dll 854016 0x72960000 0x000EB000 0x729613CE
C:\Users\Owner\Desktop\Backups\Sa Backup\GTA San Andreas Project pet\GTA San Andreas\VehicleAudioLoader.asi 10240 0x5F600000 0x000B5000 0x5F60178D
C:\Windows\system32\atiu9pag.dll 32256 0x69B40000 0x0000B000 0x69B471E0
C:\Windows\system32\DDRAW.dll 531968 0x74780000 0x000E7000 0x74781771
C:\Windows\system32\DCIMAN32.dll 10240 0x74770000 0x00006000 0x74771250
C:\Windows\system32\DSOUND.dll 453632 0x5F580000 0x00072000 0x5F581576
C:\Windows\system32\POWRPROF.dll 145408 0x71C10000 0x00025000 0x71C12B71
C:\Windows\syswow64\CLBCatQ.DLL 522240 0x75040000 0x00083000 0x750423D2
C:\Windows\System32\MMDevApi.dll 213504 0x69800000 0x00039000 0x6980E2DE
C:\Windows\System32\PROPSYS.dll 988160 0x74670000 0x000F5000 0x74680D9E
C:\Windows\system32\AUDIOSES.DLL 195584 0x682F0000 0x00036000 0x682F9DBE
C:\Windows\system32\DINPUT8.dll 145408 0x63000000 0x00030000 0x6301EC5C
C:\Windows\system32\HID.DLL 22016 0x66F50000 0x00009000 0x66F51120
C:\Windows\syswow64\WINTRUST.dll 179200 0x76B40000 0x0002F000 0x76B42A35
C:\Windows\syswow64\CRYPT32.dll 1174528 0x75150000 0x00121000 0x7515158E
C:\Windows\syswow64\MSASN1.dll 34304 0x75280000 0x0000C000 0x7528238E
C:\Windows\system32\d3d9.dll 1828352 0x6FE30000 0x001C3000 0x6FE31A45
C:\Windows\system32\d3d8thk.dll 11264 0x73F80000 0x00006000 0x73F811F0
C:\Windows\system32\aticfx32.dll 909312 0x695E0000 0x000E4000 0x69652A7D
C:\Windows\system32\atiumdag.dll 6203392 0x689E0000 0x005F2000 0x689E1000
C:\Windows\system32\atiumdva.dll 4795904 0x69140000 0x0049D000 0x69141000
C:\Windows\SysWOW64\quartz.dll 1329664 0x5F400000 0x00177000 0x5F4042CA
C:\Windows\SysWOW64\devenum.dll 66560 0x69B90000 0x00014000 0x69B9CE73
C:\Windows\system32\ntmarta.dll 121856 0x72130000 0x00021000 0x7213145E
C:\Windows\syswow64\WLDAP32.dll 269824 0x75790000 0x00045000 0x757911E1
C:\Windows\system32\msdmo.dll 30720 0x69B80000 0x0000B000 0x69B839AB
C:\Windows\system32\DShowRdpFilter.dll 252928 0x62F20000 0x00042000 0x62F3DD94
C:\Windows\system32\WTSAPI32.dll 40448 0x71D50000 0x0000D000 0x71D511E0
C:\Windows\system32\WINSTA.dll 157696 0x71220000 0x00029000 0x71226B59
C:\Windows\system32\slc.dll 27136 0x70FD0000 0x0000A000 0x70FD4D20
C:\Windows\system32\D3DIM700.DLL 817664 0x5F330000 0x000CC000 0x5F33136A
C:\Windows\system32\wdmaud.drv 172032 0x5F300000 0x00030000 0x5F303C6B
C:\Windows\system32\ksuser.dll 4608 0x67290000 0x00004000 0x67291030
C:\Windows\system32\AVRT.dll 14336 0x6BC70000 0x00007000 0x6BC710C0
C:\Windows\system32\msacm32.drv 20992 0x66CC0000 0x00008000 0x66CC4119
C:\Windows\system32\midimap.dll 16896 0x62F10000 0x00007000 0x62F111D0
C:\Windows\system32\wmvcore.dll 2504192 0x5E990000 0x00267000 0x5E9AF2C2
C:\Windows\system32\WMASF.DLL 237568 0x5F2C0000 0x0003D000 0x5F2C11E5
C:\Windows\WinSxS\x86_microsoft.windows.gdiplus_6595b64144ccf1df_1.1.7601.18455_none_72d576ad8665e853\gdiplus.dll 1625600 0x73910000 0x00190000 0x739AD0A0
C:\Windows\system32\mlang.dll 177664 0x702C0000 0x0002E000 0x702C16ED
Game terminated.
 

Expect the analysis of the log by fastman92. :)
(I suppose you have used the method of 2 gta3, however, since the file gta3ori.img does not exist. :) )
[/quote]

Well I added the car model in there I had to put it there


Automan
  • Automan

    Grandfather Modder

  • Members
  • Joined: 13 Dec 2008
  • Italy

#88

Posted 12 April 2015 - 05:58 PM

Change this:

[ID LIMITS]
#Apply ID limit patch = 0
#I want to increase the IPL limit and I know it may cause bugs = 0
; DFF (20000)
#FILE_TYPE_DFF = 20000
; TXD (5000)
#FILE_TYPE_TXD = 5000
; COL (255)
#FILE_TYPE_COL = 255
with this:
[ID LIMITS]
Apply ID limit patch = 1
#I want to increase the IPL limit and I know it may cause bugs = 0
; DFF (20000)
#FILE_TYPE_DFF = 20000
; TXD (5000)
#FILE_TYPE_TXD = 5000
; COL (255)
FILE_TYPE_COL = 300

DJCraig34
  • DJCraig34

    Crackhead

  • Members
  • Joined: 16 Apr 2012

#89

Posted 13 April 2015 - 08:32 PM

Change this:

[ID LIMITS]
#Apply ID limit patch = 0
#I want to increase the IPL limit and I know it may cause bugs = 0
; DFF (20000)
#FILE_TYPE_DFF = 20000
; TXD (5000)
#FILE_TYPE_TXD = 5000
; COL (255)
#FILE_TYPE_COL = 255
with this:
[ID LIMITS]
Apply ID limit patch = 1
#I want to increase the IPL limit and I know it may cause bugs = 0
; DFF (20000)
#FILE_TYPE_DFF = 20000
; TXD (5000)
#FILE_TYPE_TXD = 5000
; COL (255)
FILE_TYPE_COL = 300


still getting the same error :/

DJCraig34
  • DJCraig34

    Crackhead

  • Members
  • Joined: 16 Apr 2012

#90

Posted 13 April 2015 - 11:20 PM

Ok so I started the all thing over and did what you saided, so far it worked but now it claims something wrong with the player.img desipe the fact I haven't even touched it and when I try to start a new game it claims the ambience is error even though the file is there...




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users