Quantcast

Jump to content

» «
Photo

GTA 3 Android very laggy and unplayable

2 replies to this topic
fastman95
  • fastman95

    Player Hater

  • Members
  • Joined: 19 Apr 2014
  • None

#1

Posted 06 August 2014 - 11:59 AM

I've recently bought a Samsung Galaxy Ace 3,then I bought GTA 3 to test it on my phone but I found that it lags very much even on the lowest settings. However, other games which have much better graphics work great on my phone without any lag.
I need help please.

Kristian.
  • Kristian.

    Supralux (ΣΓ)

  • $outh $ide Hoodz
  • Joined: 26 Nov 2011
  • None

#2

Posted 07 August 2014 - 11:25 AM

I have a phone with similar specs (Samsung GT-I9100 Galaxy S II) and it runs OK most of the time. It could be a compatibility issue with your phone's GPU. I also think this game wasn't ported very well because I can run Vice City on pretty much maximum settings and it works better that III does on low. You should also try and close applications that are running in the background before you play the game. I think you can see what apps are runing on your phone by pressing and holding the "home" button.

 

The other games that you played which had better graphics probably weren't as big or as complex as this game.


Spuds725
  • Spuds725

    Party Animal

  • Moderator
  • Joined: 27 Sep 2003
  • United-States
  • Contribution Award [GTAF]

#3

Posted 28 August 2014 - 02:53 PM

(I pretty much copied and pasted this from a post of mine in the VC section--this "fix/workaround" should help with freeing up system resources.

 

See if you can enter developer options-- this was in the settings on my Galaxy S3... in there you want to "Limit Background Processes"-- I normally set this to 2 or 3.

 

I am hoping you have the "limit background processes" feature that Samsung devices have under Settings>Developer options (I had this on my Galaxy S3 and currently have this on my S4) as this will likely help your situation the most.

 

I do wish you luck

 

//edit// I was just checking my S4 for this and could not find it-- so googled it and this enabled it on my S4

 

https://muffinresear...eloper-options/

 

This may enable it on your device too... http://www.phonetips...per-options-15/

 

Here is a screen shot from my device.. 

 

2014-06-14%2014.14.23.jpg

 

 

 

 

 

 

@City-- I'm not sure that advice (going back to gingerbread) is very doable without rooting the device and I don't know how increasing the visual resolution will help the game run better.

@hhamzah99--

First-- try reinstalling the game-- perhaps it got boogered up on the install

Have you tried doing a few things to free up system resources??

Turn off ALL wireless communication-- bluetooth, wifi, data (if applicable)-- what this does will prevent your email/facebook/twitter/etc from checking for updates/notifications

Restart the device-- when it restarts make sure none of the wireless communication turns back on-- turn it off immediately if it does.

Close ALL running processes and apps that you can-- if your device has an onboard "killer" use that one, otherwise use a good 3rd party one.

If you are running any security software (virus/malware etc)-- force close those.

On my device (Samsung Galaxy S3)-- if you go into the settings-- way down at the bottom is a thing called "developer options"-- in there, I have a setting called-- limit running processes-- I can set this to 1, 2, 3, or 4 processes at most-- I can also set it to "No background processes", it defaults to "standard"-- and if you restart the device, it will return this to "standard"-- what I have done to make this game run better is to limit it to 2 or 3.... by doing this it will automatically kill processes if you switch to another program or what not.... so say if I set it for 3, the 3 most recently used apps will be left running. If I open a new app, the one I used longest ago will be closed.... the only downside of this is that if you do switch out of a running game and open too many apps, it can kill your game without you saving,

So anyway-- try the above-- if game works ok then great if not-- read on...

In game-- go into display settings and reduce draw distance, screen resolution, turn visual effects to LOW, turn dyanmic shadows to OFF-- only after you have gotten the game functional would I start messing with these settings (raising them back up).... you can slowly start increasing these and testing the game afterwards to make sure that increasing your visual setting doesn't hinder your game.

HTH...

Spuds

 

 

Please post back if any of this helps you.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users