Quantcast

Jump to content

» «
Photo

The windows 7 lag problem

8 replies to this topic
shos
  • shos

    Player Hater

  • New Members
  • Joined: 16 Jul 2014
  • Israel

#1

Posted 16 July 2014 - 04:52 PM

Hi everybody,

 

I'm new to this forum and have searched it for other people who asked this but didn't find anything, so I'll post a new thread about it.

 

I have recently got my computer back from fixing, and installed GTA IV. Now, the computer is Windows 7, and the well known lag problem in GTA IV in win 7 exists. I've done what youtube says to do and it doesn't help...

 

So any help at all will be appreciated!!

 

My computer specs:

Windows 7 Home Premium 

4 CPUs, ~3.1 GHz, Intel core i5-4440

8GB of RAM

NVIDIA GeForce GT 610

 

 

thank you very much,

Shos


KBG
  • KBG

    8-bit.

  • Members
  • Joined: 05 Mar 2013
  • India

#2

Posted 17 July 2014 - 09:29 AM Edited by KBG, 17 July 2014 - 02:23 PM.

Man, don't blame Windows 7. I don't have any problems with lag running GTA IV on it. The real problem is your GPU. GT 610 is not for gaming. Its only for watching HD Videos and other stuff but not decent gaming. Go buy atleast a low end GPU like GT 620 or HD5570. GTA IV is a GPU intensive game. So you do need a decent GPU. Or else, you have your results.

EDIT// Corrected typos.

shos
  • shos

    Player Hater

  • New Members
  • Joined: 16 Jul 2014
  • Israel

#3

Posted 17 July 2014 - 02:17 PM

Man, don't blame Windows 7. I don't have any problems with lag running GTA IV on it. The real problem is your GPU. GTA 610 is not for gaming. Its only for watching HD Videos and other stuff but not decent gaming. Go buy atleast a low end GPU like GT 620 or HD5570. GTA IV is a GPU intensive game. So you do need a decent GPU. Or else, you have your results.

Are you sure? When I bought this it was considered a really high-end GPU and it should be able to run games very smoothly. GTA IV is the only game I'm having troubles with.


KBG
  • KBG

    8-bit.

  • Members
  • Joined: 05 Mar 2013
  • India

#4

Posted 17 July 2014 - 02:22 PM

Which other games do you exactly run in High settings?

RyanBurnsRed
  • RyanBurnsRed

    We're born with nothing and we die alone

  • Zaibatsu
  • Joined: 16 Jun 2010
  • United-States

#5

Posted 17 July 2014 - 11:53 PM

Hi everybody,

 

I'm new to this forum and have searched it for other people who asked this but didn't find anything, so I'll post a new thread about it.

 

I have recently got my computer back from fixing, and installed GTA IV. Now, the computer is Windows 7, and the well known lag problem in GTA IV in win 7 exists. I've done what youtube says to do and it doesn't help...

 

So any help at all will be appreciated!!

 

My computer specs:

Windows 7 Home Premium 

4 CPUs, ~3.1 GHz, Intel core i5-4440

8GB of RAM

NVIDIA GeForce GT 610

 

 

thank you very much,

Shos

 

Do you mean the bug that makes the game lag when you use the keyboard? 


KBG
  • KBG

    8-bit.

  • Members
  • Joined: 05 Mar 2013
  • India

#6

Posted 18 July 2014 - 08:44 AM

He has GT 610. That is his problem. Go do some research on GT 610 with GTA IV. Everyone will only reply to get a new GPU. Sorry, but that is the solution.

shos
  • shos

    Player Hater

  • New Members
  • Joined: 16 Jul 2014
  • Israel

#7

Posted 18 July 2014 - 06:05 PM

That sucks :/

 

Well, what settings do you think I should use so that the game runs OK.? perhaps some graphics card accelerator can help or somehting?


KBG
  • KBG

    8-bit.

  • Members
  • Joined: 05 Mar 2013
  • India

#8

Posted 19 July 2014 - 03:06 AM

Try to play on the Lowest Settings avilable. And turn off Shadows too. GTA IV is considered both CPU and GPU hungry game. Even users with Ultra rigs have problem running it.

marmoo
  • marmoo

    Hustler

  • Members
  • Joined: 02 Apr 2010

#9

Posted 19 July 2014 - 08:25 AM

Yep. GPU is the problem. With that Quad Core processor & GPU combination you are just bottlenecking

  • KBG likes this




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users