Quantcast

Jump to content

» «
Photo

Game keeps crashing after GFWL sign-in

3 replies to this topic
Heyitspeggy
  • Heyitspeggy

    MAGNETS

  • Members
  • Joined: 13 Oct 2013

#1

Posted 2 weeks ago

I bought the GTA IV complete edition on Steam a few days ago and have not been able to get this game to work. I have a multitude of problems, starting with the RGSC sign-in. The first time I signed in, worked fine, no problems. I've since tried to sign in about two dozen times and it always give me a message saying that it failed to sign me in, and NOT because of wrong username/password. So when I start it up, I just go to play offline, figured I'd hold off this problem for now since I don't want to play online just yet.

 

Now the game starts as normal, brings me to the main menu and I select GTA IV. It asks me to sign in to GFWL, so I do. I created a GFWL account just for this and every time I attempt to sign in, it tells me that GFWL needs to update, so I "update" it. It still does the same damn thing. I've "updated it" probably ten times already. Because of this, I can't sign in, and it keeps telling me that I can start the game but I can not make any saves.

 

And now the biggest problem, the game crashes after the GFWL prompt. Sometimes the prompt stays on screen, sometimes the screen goes black, but either way, the screen freezes and I hear the loading music but it keeps going until it stops, and then nothing, the game just never starts.

 

I've tried uninstalling and downloading the alternate, updated GFWL, same results. I've tried uninstalling and reinstalling GTA IV, same results. I don't know what to do and it's pissing me off that a six year old game could still be sold in such a state.

 

The only conclusion I can come to is that maybe my hardware is causing it to simply not start. My specs are as follows:

 

Intel HD Graphics w/32mb Dedicated VRAM (1.7GB usable)

Intel Pentium 2020M Dual core

4GB RAM

500GB HDD

Windows 8 64-bit

 

Now, unless you know for sure that GTA IV simply doesnt start when running on hardware that doesn't meet the minimum requirements, I don't want to hear any criticisms, I don't want anyone to tell me I need to upgrade, I KNOW this. I bought GTA IV knowing full well that it wouldn't run great, I know it's a poorly optimized game. However, I can run games like Skyrim at playable framerates with low-medium graphics. I figure since GTA IV came out in 2008, I should expect performance in that ballpark.

 

So, is my hardware simply causing this game to not start? Does this game just not like Windows 8? I'm really hoping someone here can give me a solution because I've tried so many different "solutions" for four days now and nothing has worked. I'm frustrated, I'm tired, I just want to hop in a sports car and kill some prostitutes for points. Help plz.


Heyitspeggy
  • Heyitspeggy

    MAGNETS

  • Members
  • Joined: 13 Oct 2013

#2

Posted 2 weeks ago

Anyone?


Deadly Target
  • Deadly Target

    Rat

  • Members
  • Joined: 12 Apr 2010

#3

Posted 2 weeks ago Edited by Deadly Target, 2 weeks ago.

I've found that launching directly from LaunchGTAIV as administrator helped with my social club issues. Did you completely uninstall GFWL and get the most up-to-date version? If so, I guess all you can really do is use the mod xliveless, which disables GFWL while allowing you to save.

 

Is your game actually freezing up after the start menu, or is it just an infinite loading screen?   


Krawk
  • Krawk

    Peon

  • Members
  • Joined: 23 Sep 2009

#4

Posted 2 weeks ago

I have also seen that GFWL is trying to update in the background and you can never switch to it, it is stuck on a "needs to be updated" dialog.. My suggestion is that as soon as permittable, press your HOME button which will bring GFWL to the foreground, and it will update as it should. The "up to date" link is outdated.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users