Quantcast

Jump to content

» «
Photo

Massive stuttering playing GTA IV

13 replies to this topic
Wijkert
  • Wijkert

    Player Hater

  • New Members
  • Joined: 29 Jun 2014
  • Netherlands

#1

Posted 29 June 2014 - 09:00 AM Edited by Wijkert, 29 June 2014 - 09:00 AM.

Hi all, new to these forums and I hope you guys can help me.

 

Yesterday I felt an urge to replay gta IV. I heard about the ICEnhancer mod and wanted to use that for the replay. Within a minute of playing the game I get massive stuttering and lag. All is fine before this happens. Fraps shows a framedrop from 55(vsync) to 40-50, but it feels more like 5fps. In afterburner the gpu usage spikes up and down like crazy when this problem occurs. Alt-tabbing returns the game to normal, but within a minute the above happens again, making the game unplayable. The problem also occurs with vsync off.

 

The above doesn't seem to have to do with ICEnhancer at all, since it is present with 1.0.0.4 vanilla, 1.0.0.4 ICEnhancer, 1.0.0.7 vanilla and 1.0.0.7 ICEnhancer (although I get the red sky bug among other things...). I tried all these suggestions http://forums.steamp...d.php?t=1269228, but non of them worked. Also checked the pcgaming wiki page, but found no solution there (tried both  -norestrictions -nomemrestrict and -memrestrict 629145600).

 

My specs: U2913WM (2560x1080); GeForce Titan 1032mhz/1500mhz; 2500K 4.4ghz; 8GB Ripjaws 1600mhz; Z68X-UD3H-B3; AX860; 750GB 840 EVO; Xonar DSX; Windows 7

 

Thanks in advance for your input.


FulValBot
  • FulValBot

    Rat

  • Members
  • Joined: 09 Mar 2007

#2

Posted 29 June 2014 - 09:17 AM

don't use -memrestrict when you are using also -nomemrestrict and -norestrictions

 

 

 

if is steam version of game try to launch launchgtaIV.exe from game folder instead from steam client

 

 

 

with nvidia card most recent forceware reale have stuttering problems... (from 332.23 to latest beta...)


Wijkert
  • Wijkert

    Player Hater

  • New Members
  • Joined: 29 Jun 2014
  • Netherlands

#3

Posted 29 June 2014 - 09:29 AM Edited by Wijkert, 29 June 2014 - 09:29 AM.

don't use -memrestrict when you are using also -nomemrestrict and -norestrictions

 

I meant that I used both separately.

 

if is steam version of game try to launch launchgtaIV.exe from game folder instead from steam client

 

Just played 5 min and no stuttering. Need to play longer to make sure. Will report back later today. Would be great if such a simple thing fixes this for me!


FulValBot
  • FulValBot

    Rat

  • Members
  • Joined: 09 Mar 2007

#4

Posted 29 June 2014 - 09:43 AM

that workaround was reported more times also on steam forums... (not the old steam forums)

 

i think that is a bug of steam client...

 

 

try also to add a shortcut on steam client for launchgtaIV.exe as a non-steam game and try it

 

 

 

remember to use all comands on commandline.txt (on game folder where there are all exe files), not into steam client


Wijkert
  • Wijkert

    Player Hater

  • New Members
  • Joined: 29 Jun 2014
  • Netherlands

#5

Posted 29 June 2014 - 10:33 AM

Played for a while longer and no stuttering as of yet. Thanks a bunch for the help! Sadly though only in the vanilla version of the game I can get to the start menu. When starting the moded version, I get a black screen after the gta IV logo.


FulValBot
  • FulValBot

    Rat

  • Members
  • Joined: 09 Mar 2007

#6

Posted 29 June 2014 - 10:36 AM

we have to contact steam support for an official fix on a next beta release of steam client...


Chuck Finley
  • Chuck Finley

    E34 FANATIC!

  • Members
  • Joined: 10 Jun 2013
  • Jamaica

#7

Posted 30 June 2014 - 12:34 PM Edited by Chuck Finley, 30 June 2014 - 12:35 PM.

hey man try lowering the view distance n detail distance to like 3-5 thats wat i set to n my game runs much much much much better im able to have 100% traffic n a 3 -4 times ped mod   which is soooooo awesome. no commandline too

 

 

dude ur specs are similar to mine 

i got 

 

i5-2500 non K

gtx570

8 gb ram


Wijkert
  • Wijkert

    Player Hater

  • New Members
  • Joined: 29 Jun 2014
  • Netherlands

#8

Posted 01 July 2014 - 04:22 PM

 

 

hey man try lowering the view distance n detail distance to like 3-5

 

Thanks for the advice. Tried your suggestion, but it did't change how much microstuttering the game has.


FulValBot
  • FulValBot

    Rat

  • Members
  • Joined: 09 Mar 2007

#9

Posted 01 July 2014 - 06:43 PM

so that problem now is back?...


Wijkert
  • Wijkert

    Player Hater

  • New Members
  • Joined: 29 Jun 2014
  • Netherlands

#10

Posted 02 July 2014 - 05:05 PM Edited by Wijkert, 02 July 2014 - 05:07 PM.

so that problem now is back?...

 

No, my original problem was so much stuttering that the game was literally unplayable. That is gone now. Am used to a healthy dose of microstuttering that this game has by default, so didn't mention it in the OP. The weird thing is the microstuttering can be more or less present. Yesterday for example it went almost away after playing for a while. Now it is back. Kind of unpredictable.


Marc79
  • Marc79

    Marecki

  • Members
  • Joined: 03 Nov 2011

#11

Posted 04 July 2014 - 04:40 PM Edited by Marc79, 04 July 2014 - 04:42 PM.

I know what you're talking about, I had the exact problem with steam version, but my retail worked perfectly fine.  Here is what you do, like mentioned above you launch the steam version with the "LaunchGTAIV.exe" in the game folder, and here's the important part, WITHOUT steam running, steam can't be running!

 

There is also another thing I found that works if you want steam running in the background while playing.  Make sure that steam overlay in settings is ticked or enabled, if I untick it it will stutter like crazy after about 30s. with even fps over 60+.  Like you said, if I Alt+Tab out of the game, for about a minute it will play fine before it starts to stutter.  Make sure you have steam overlay running.

 

Capture_zpsf75ff154.png


Wijkert
  • Wijkert

    Player Hater

  • New Members
  • Joined: 29 Jun 2014
  • Netherlands

#12

Posted 07 July 2014 - 08:30 PM

@Marc79 I experience no massive stuttering when I launch the game using "LaunchGTAIV.exe" when steam is running in the background (no difference with the overlay activated or deactivated either).

 

Do you guys know if the Episodes of Liberty City need to be launched directly via the .exe as well to prevent stuttering? Or are those not as buggy as gta 4 proper.


unc13bud
  • unc13bud

    Weekend Answerer

  • Members
  • Joined: 05 Dec 2010
  • None

#13

Posted 14 July 2014 - 03:55 AM

original poster, this thread needs to be in the modded gta iv game forum, plenty of ice enhancer information in there... please ask a moderator to move it for you?


Wijkert
  • Wijkert

    Player Hater

  • New Members
  • Joined: 29 Jun 2014
  • Netherlands

#14

Posted 14 July 2014 - 07:46 AM

original poster, this thread needs to be in the modded gta iv game forum, plenty of ice enhancer information in there... please ask a moderator to move it for you?

 

I don't think this thread should be moved, since the main topic doesn't have anything to do with mods.





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users