Quantcast

Jump to content

» «
Photo

Another GTA IV on PC framerate help request!

8 replies to this topic
bluetrooth
  • bluetrooth

    Player Hater

  • Members
  • Joined: 19 Mar 2014
  • Belgium

#1

Posted 19 March 2014 - 10:57 AM Edited by bluetrooth, 19 March 2014 - 10:59 AM.

I've decided to embark on the ludicrous quest of trying to make GTAIV run tolerably on my laptop, but since I'm a complete newbie at this stuff, I'm in desperate need of some advice. At this point I'm even willing to pay whoever can make this game run properly on my laptop, cause I'm at a total loss here.

These are my specs:
5bycxw.jpg

 

 

I have tried just about every command line I found online or on this forum (from things like windowed mode to "-refreshrate 30  -framelimit 1" to "reservedApp 0 -memrestrict 1073741824" for my specific vram), played around with the in-game settings (lowering the resolutions, turning off the clip capture thing, setting everything on normal or low, etc.) made sure my disk was defragmented, the whole shebang.

The game runs choppy without any tampering, and usually runs even worse with. I paid for this game, and all I really want is for it to run smoothly, on whatever graphics settings, in whatever way I can.

Is there anyone here who might have any advice? I'd greatly appreciate it!

 


Mr. Boredom 1603
  • Mr. Boredom 1603

    Ehh, I'm tired.

  • Members
  • Joined: 28 Apr 2012
  • United-States

#2

Posted 19 March 2014 - 11:55 AM

Well I have AMD Radeon HD 6310 in my laptop (a really crappy GPU) and I set everything to low and it works fine. Some people, however, experience better FPS with some settings on high, so mess around a bit. Also, there are really good graphics mods out there as well to help. Also, Draw Distance and everything below it at their lowest or off. Resolution for me is good at 800x600. Other than that, I got no more to say other than: Good luck!!


bluetrooth
  • bluetrooth

    Player Hater

  • Members
  • Joined: 19 Mar 2014
  • Belgium

#3

Posted 19 March 2014 - 12:24 PM

Thanks! I found that the only thing that significantly improves the framerate for me is a commandline.txt in the game folder with these commands:

-norestriction
-nomemrestrict
-availablevidmem "1.1"
-percentvidmem "100"
-windowed

This makes it almost playable, but still a bit too choppy to enjoy. :(
 


Mr. Boredom 1603
  • Mr. Boredom 1603

    Ehh, I'm tired.

  • Members
  • Joined: 28 Apr 2012
  • United-States

#4

Posted 19 March 2014 - 01:49 PM

Ahh, sorry about your luck, man. Hopefully you can get it working! Maybe you can get a desktop (or laptop, but desktop would be better) with a decent GPU that can run it.


Andreas
  • Andreas

  • Leone Family Mafia
  • Joined: 27 May 2012
  • Austria
  • Most Helpful [GTA] 2014
    Best Avatar 2013
    Best New Member 2012
    Contribution Award [GTA V]

#5

Posted 20 March 2014 - 02:35 PM Edited by Andreas, 20 March 2014 - 02:36 PM.

One of the problems here could be that you are using commandlines that contradict each other.

Firstly, the first line should be norestrictions, you missed the s at the end of it. Secondly, -norestrictions turns the memory restrictions on the graphic settings off while -nomemrestrict turns all memory restrictions off. When using either of these commands, the commands -availablevidmem and -percentvidmem become futile because there is no limitation in place anyway. Not to forget that these two commands have both something to do with increasing/decreasing the VRAM limit; and using both at the same time is anything but efficient, since they just contradict each other, especially in this case. Here is why:
 

-availablevidmem "1.1"

For one, do not use quotations marks when entering the number. It should be -availablevidmem 1.1 and not -availablevidmem "1.1". The line you attempt to use basically tells the game to use 1.1 times the video RAM that is actually available on your GPU.
 

-percentvidmem "100"

Same as above, do not use quotation marks, or it will not work. This line tells your game to use 100% of the VRAM that is available. But, why? The game uses all the memory which the graphic-card provides by default, which makes the command pretty much useless.

Try to only use the command lines -nomemrestrict and -windowed and tell us what the result is.

bluetrooth
  • bluetrooth

    Player Hater

  • Members
  • Joined: 19 Mar 2014
  • Belgium

#6

Posted 22 March 2014 - 10:05 AM

Thanks! I didn't know most of that stuff, I just kind of copy/paste what other people put online.

It seems to work okay with those two commands on 800x600 resolution so far, might play around with it a bit more and see if I can get a non-choppy fullscreen, higher rest setting to work. :)


FlashUnit
  • FlashUnit

    Player Hater

  • Members
  • Joined: 07 Nov 2012

#7

Posted 04 April 2014 - 02:42 PM


Same as above, do not use quotation marks, or it will not work. This line tells your game to use 100% of the VRAM that is available. But, why? The game uses all the memory which the graphic-card provides by default, which makes the command pretty much useless.

Try to only use the command lines -nomemrestrict and -windowed and tell us what the result is.

 

This is exactly what I tried but my game crashes when I start a new game and I see 'Art Director Aaron Garbut' (in the intro with the ship arriving) and then the game just closes. I start the game at absolute minimal settings and I get like 2-4 FPS until 30 seconds in.

 

I hate this so much because I loved GTA IV and I was able to play it some time ago and I almost finished the story. 

Does anybody have a solution for this particular situation? 3FPS and quitting game after 30 seconds? It's insane.


SlaveZer0
  • SlaveZer0

    Perveyor of Destruction

  • Members
  • Joined: 05 Aug 2011
  • United-States

#8

Posted 05 April 2014 - 12:07 PM

Solution:  play it on a console so you cant complain it wont run right


oh and even by laptop standards, OP, your system sucks for most gaming, especially this one

  • Hx1349 likes this

unc13bud
  • unc13bud

    I stay mad @ Rockstar

  • Members
  • Joined: 05 Dec 2010
  • None

#9

Posted 20 April 2014 - 02:07 AM Edited by unc13bud, 20 April 2014 - 02:07 AM.

naw, you full of sht on this one. that video card has amd/ati 400 sp according to notebook check.

i ran gta iv on llano with a8-3870k (after using commandlines - one line saying memrestrict 384xxxxxxx). he can run it, he needs to clean his cpu fan and learn how to properly tweak the game; i.e. trun down shadows, turn off reflections, set vehicle slider to 1. man, i can't go on vacation from these forums for a minute... the bad advice just flows





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users