Quantcast

Jump to content

» «
Photo

HQ objects not loading when flying. (Lods deleted)

4 replies to this topic
nWo51289
  • nWo51289

    Outcast

  • Members
  • Joined: 26 Apr 2008

#1

Posted 24 January 2014 - 07:28 PM Edited by nWo51289, 25 January 2014 - 03:28 PM.

I require some help with something that has been puzzling me lately. You might have seen a few posts of mine regarding LODS.

The majority of the map is now lodless and works relatively fine (with a few problems that needs fixing) but there is one annoying problem that someone hopefully can help me out with...

First of all why am I stupid & deleted the lods? Well do we really need lods these days with pcs becoming more powerful than what they were years ago? My plan is to free up ids as hopefully one day would like to try and add VC & LC beside SA. (At the moment there are enough ids to achieve this only if VC & LC are lodless as well)

lod3.jpglod4.jpg

Ok, to achieve the above the plugins I'm using are IDE_DD_Tweaker, limit_adjuster_gta3vcsa, limit_adjuster_sa_bonus_matrix, sa_draw_distance_changer & Render.cs. (Not using binaryipl.cs as that's not required...everything else is default). As you can see Los Santos has been loaded (thanks to Render.cs)

lod5.jpg

But this bit isn't (no it's not the flicker bug), the reason is I haven't walked/driven in this area unlike the other side of LA. This is my problem, the map is not loading if I'm flying around unless I get down really close to ground level, doing so will then make the game load the ipls.

lod6.jpg

Flying, map refuses to load... (Strange how vegetation & generic objects have loaded)

lod7.jpg

Bang!! It loads when I'm flying really close or like above, on foot.

Now the pics below are without render.cs & sa_draw_distance_changer. This might give you a better picture of the problem. The map will never load while I'm flying, it's only when I'm on the ground, or close to it will the map finally load.

lod11.jpglod13.jpgI've got 2 questions to ask:

1. Does anyone know how to fix the problem above? IDE Tweaker is set to 3000 but increasing it makes no difference. I might want to add that if I walk around LA to load everything up....flying away to some place else and returning to LA the objects will load normally when flying

2. If no one knows how to fix the above, there is another way to get the map to load when flying. Change all of the objects to lods (done simply by increasing the DD in the ides anything above 300) will make the map load properly (obviously as when flying the default game will always load the lods) but then the objects won't have their collisions. Bear in mind these are the HQ objects that already have their collisions when not lods etc. Could I by cleo or any means tell the game to force to load the collisions for lods?

 

Hope someone here could help me out. Thanks for reading.


_DK
  • _DK

    Call me 'The Bald Guy"

  • Members
  • Joined: 12 Apr 2009
  • Ukraine

#2

Posted 30 January 2014 - 01:08 AM Edited by _DK, 30 January 2014 - 01:08 AM.

Possibly they controlled it with parameter
CRenderer::ms_bInTheSky
:p
Try this one with CLEO ;)
0A8C: 0x5557CF 7 0x90 1
  • Methical, sharpie_eastern, LINK/2012 and 1 other like this

nWo51289
  • nWo51289

    Outcast

  • Members
  • Joined: 26 Apr 2008

#3

Posted 30 January 2014 - 12:58 PM

Thanks for the help _DK but sadly that crashes the game after loading.


_DK
  • _DK

    Call me 'The Bald Guy"

  • Members
  • Joined: 12 Apr 2009
  • Ukraine

#4

Posted 30 January 2014 - 02:41 PM

Are you sure you compiled it right?
{$CLEO}
0A8C: 0x5557CF 7 0x90 1
0A93:
If yes, do you use CLEO4 and 1.0 US exe?
  • nWo51289 and Methical like this

nWo51289
  • nWo51289

    Outcast

  • Members
  • Joined: 26 Apr 2008

#5

Posted 03 February 2014 - 08:45 PM

Sorry for late reply. Your right, I didn't compile it correctly  :facedesk: (I will never get the hang of cleo!!). On topic it works perfectly! Thanks for saving the day once again! :cookie:  :cookie:  :cookie:





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users