Quantcast

Jump to content

» «
Photo

[SA|REL] CLEO 4.3

SA Released SA WIP
215 replies to this topic
Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#121

Posted 22 February 2014 - 11:50 PM

Yes, me too but ths message doesn't encountered with single SDDWG itself. I think the problem caused by Ryosuke's plugin mixed with IMFX Explosion, plus... Ryosuke's CLEO like missile.
 
I've tried several tests and these are the cause of chinese message shown. But, if only used IMFX Explosion with Ryosuke's plugin, it doesn't show that message.


Don't use SDDWG with CLEO 4.3 at all, it doesn't support it. What's more, you don't need it. Problem solved.
  • Concavax likes this

Zera
  • Zera

    Mack Pimp

  • Members
  • Joined: 26 Feb 2005
  • Brazil

#122

Posted 23 February 2014 - 11:03 AM Edited by Zera, 23 February 2014 - 11:04 AM.

Deji, I'm having a game freezing problem when flying up high for a few minutes (freezes after 5 minutes or so). At first I thought it was modloader's fault, but I replaced CLEO with the old library and the freezing stopped. If you're unable to reproduce it, let me know so I'll send you the scripts I use.


Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#123

Posted 23 February 2014 - 01:02 PM Edited by Deji, 23 February 2014 - 01:03 PM.

Deji, I'm having a game freezing problem when flying up high for a few minutes (freezes after 5 minutes or so). At first I thought it was modloader's fault, but I replaced CLEO with the old library and the freezing stopped. If you're unable to reproduce it, let me know so I'll send you the scripts I use.


I'm unable to reproduce any crash without some sort of insight into what mod is causing it. To put it frankly, CLEO doesn't cause crashes, scripts do. And most of these scripts tend to be badly coded due to a lack of coding standards over the years (explained such scenario here - another example is the grossly mis-used find_next parameter in opcodes 0AE1-0AE3). Obviously though, I don't know these scripts or I would've tested and tried to add support for them already.

Zera
  • Zera

    Mack Pimp

  • Members
  • Joined: 26 Feb 2005
  • Brazil

#124

Posted 23 February 2014 - 02:10 PM

So, do you want me to send you the scripts I use? I was going to PM you, but it seems you have PMs disabled.


Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#125

Posted 23 February 2014 - 02:21 PM

So, do you want me to send you the scripts I use? I was going to PM you, but it seems you have PMs disabled.


If you can slim those scripts down to just one, sure :p It's kind of pointless to report a problem that only happens with a combination of scripts, though, as that means just an incompatibility with those two scripts. It shouldn't be hard to pinpoint the one script which causes the problem - and remember that if the problem is hard to reproduce - it probably existed before 4.3 as well.

Zera
  • Zera

    Mack Pimp

  • Members
  • Joined: 26 Feb 2005
  • Brazil

#126

Posted 23 February 2014 - 02:32 PM Edited by Zera, 23 February 2014 - 06:08 PM.

Could the plugin GxtHook.cleo be causing this? For some reason I still had this plugin on my CLEO folder, and removing it apparently fixed the problem.

 

EDIT: And now it's freezing again... *sigh*


Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#127

Posted 23 February 2014 - 04:39 PM

Could the plugin GxtHook.cleo be causing this? For some reason I still had this plugin on my CLEO folder, and removing it apparently fixed the problem.


Yes, you don't need it for any version of CLEO 4 at all.

Zera
  • Zera

    Mack Pimp

  • Members
  • Joined: 26 Feb 2005
  • Brazil

#128

Posted 24 February 2014 - 01:15 PM Edited by Zera, 24 February 2014 - 01:17 PM.

After some more testing, it seems the freeze is being caused by AutoTrafficFix.

 

Here: http://www.mediafire...toTrafficFix.cs


Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#129

Posted 24 February 2014 - 05:52 PM

After some more testing, it seems the freeze is being caused by AutoTrafficFix.


CLEO 4.3.15 released!

Fix:
4.3.15
* Improvemed compatibility fix for opcodes 0AE1, 0AE2 and 0AE3 with incorrect find_next usage

It was easy, but now the find_next parameter is pretty useless... you can use 1 where you would usually use 0, because now when a search is complete (where 'false' is returned to indicate no find) the pool index will automatically start again anyway. You can, however also still use 0 to reset the pool index mid-search, but there is no use in that whatsoever :p

Oh well, they should be compatible across all variations of their use now...
  • uokka likes this

Zera
  • Zera

    Mack Pimp

  • Members
  • Joined: 26 Feb 2005
  • Brazil

#130

Posted 24 February 2014 - 08:08 PM Edited by Zera, 24 February 2014 - 08:51 PM.

It's still the previous version on the first post (the zipped one, at least).

 

BTW, my game often crashes when User Radio attempts to load a track. A bass.dll related issue, maybe?


Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#131

Posted 24 February 2014 - 09:11 PM Edited by Deji, 24 February 2014 - 09:12 PM.

It's still the previous version on the first post (the zipped one, at least).
 
BTW, my game often crashes when User Radio attempts to load a track. A bass.dll related issue, maybe?

Only the ReadMe.txt wasn't updated, fixed now.

And if it often (not always) crashes when User Radio attempts to load a track, I'd assume something was just wrong with a certain track or a few tracks that are being randomly selected. Logical. Plus the implementation of the BASS Library in no way touches the original audio system. They're as likely to conflict as two completely separate programs playing audio.

sidex15
  • sidex15

    Philippine Modder

  • Members
  • Joined: 02 Feb 2012
  • Philippines

#132

Posted 14 March 2014 - 06:40 AM Edited by sidex15, 14 March 2014 - 06:40 AM.

stinger.cs (man portable missile) it freezes when I try to switch to heat seeking missile.

even I rename to .cs3 still freezes please fix it.


Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#133

Posted 14 March 2014 - 02:35 PM

stinger.cs (man portable missile) it freezes when I try to switch to heat seeking missile.

even I rename to .cs3 still freezes please fix it.

 

It's not a CLEO 4.3 issue - stinger.cs is not needed when you have missile.cs/cs3 as the man portable missile is part of the missile mod.

 

See: http://gtaforums.com...entry1064504768


Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#134

Posted 15 March 2014 - 02:45 PM

CLEO 4.3.16 released!

 

Major bug fix:

-- 4.3.16 --

* Fixed bugs with CLEO saves when saved scripts ended

  • TJGM likes this

ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#135

Posted 16 March 2014 - 08:21 AM

Cleo4.3.16 cause a crashe by closing game, i have to press Strg+alt+del to reach the desktop

This happens on my winXP machine but not on win7

 

I tested Cleo4.3.15 on several game installations, with eu exe and with american exe

it was always the same, no problem with cleo3 but crash by closing game with Cleo4.3.15

I came here an saw the update and tested Cleo4.3.16 two times on my unmodded installation

I ran the the setup.exe, full installation, started new game, tested a simple script, closed game, same problem

I tested again with a savegame, done on unmodded game, tested a simple script, closed game, same problem

cleo.log says: Loading cleo safe ./cleo/cleo_saves/cs0.sav but there isn't any cleo save file in cleo_saves

 

Spoiler


Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#136

Posted 16 March 2014 - 10:38 AM

Cleo4.3.16 cause a crashe by closing game, i have to press Strg+alt+del to reach the desktop

This happens on my winXP machine but not on win7

 

I tested Cleo4.3.15 on several game installations, with eu exe and with american exe

it was always the same, no problem with cleo3 but crash by closing game with Cleo4.3.15

I came here an saw the update and tested Cleo4.3.16 two times on my unmodded installation

I ran the the setup.exe, full installation, started new game, tested a simple script, closed game, same problem

I tested again with a savegame, done on unmodded game, tested a simple script, closed game, same problem

cleo.log says: Loading cleo safe ./cleo/cleo_saves/cs0.sav but there isn't any cleo save file in cleo_saves

 

 

Something must be wrong with your audio drivers or hardware configuration and causing bass.dll to error out when it tries to de-initialise on that machine. One thing you can try is to disable/lower hardware acceleration though CLEO forces software buffering for streams that are loaded anyway. Either Windows XP has some weird problem here or the BASS library does, but I can't duplicate the problem using compatibility modes. Do you have the latest service packs installed?


ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#137

Posted 16 March 2014 - 05:02 PM

yes, my poor soundsystem could be the reason


RinkashimE
  • RinkashimE

    GAMER

  • Members
  • Joined: 25 Dec 2013
  • Philippines

#138

Posted 31 March 2014 - 06:24 AM

When I use srt3 and weapon pack Ryosuke's missile mod wont work no crash but in game u can only use the rpg and other wont fire a projectile.


Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#139

Posted 31 March 2014 - 11:44 AM Edited by Silent, 08 April 2014 - 02:10 PM.

When I use srt3 and weapon pack Ryosuke's missile mod wont work no crash but in game u can only use the rpg and other wont fire a projectile.

 
Then replace missile.dff and missile.txd with the game defaults. 'SRT3' has bugs (as do 90% of graphical mods).

65536
  • 65536

    Trick

  • Members
  • Joined: 07 Sep 2012
  • Bulgaria

#140

Posted 15 April 2014 - 08:57 PM Edited by 65536, 15 April 2014 - 08:58 PM.

I have a suggestion for you: @Deji...

 

You can continue developing ScriptHook (CLEO equivalent for GTA IV and GTA EFLC)? I ask because it's discontinued and all versions of ScriptHook compatible with latest patches - GTA IV 1.0.7.0 and GTA EFLC 1.1.2.0 are all only a Beta versions that have an annoying bug - they make GTA IV to crash sometimes when loading end and GTA IV 1.0.7.0 going to load Niko Bellic on map. Problem is, there are no updates and there isn't any stable version available, only a few Beta versions for latest patch. I want only one thing: version for GTA IV 1.0.7.0 and GTA EFLC 1.1.2.0 that: 1. Don't cause the game to crash in end of loading with no reason anymore; 2. Is stable and is not neither Alpha or Beta version.  :catspider:  :dozing:  :(  Because I'm bothered to start GTA IV every time and I to pray it do load map without an crash report popup on screen... Actually, many users reported here in GTAForums this their GTA IV crashes accidentally with ScriptHook, but the game always loads with no crash after removing these Beta versions... 

 

I think other users might be thankful to you too if you make a stable version of ScriptHook.  :cool:


Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#141

Posted 16 April 2014 - 08:33 PM

I have a suggestion for you: @Deji...
 
You can continue developing ScriptHook (CLEO equivalent for GTA IV and GTA EFLC)? I ask because it's discontinued and all versions of ScriptHook compatible with latest patches - GTA IV 1.0.7.0 and GTA EFLC 1.1.2.0 are all only a Beta versions that have an annoying bug - they make GTA IV to crash sometimes when loading end and GTA IV 1.0.7.0 going to load Niko Bellic on map. Problem is, there are no updates and there isn't any stable version available, only a few Beta versions for latest patch. I want only one thing: version for GTA IV 1.0.7.0 and GTA EFLC 1.1.2.0 that: 1. Don't cause the game to crash in end of loading with no reason anymore; 2. Is stable and is not neither Alpha or Beta version.  :catspider:  :dozing:  :(  Because I'm bothered to start GTA IV every time and I to pray it do load map without an crash report popup on screen... Actually, many users reported here in GTAForums this their GTA IV crashes accidentally with ScriptHook, but the game always loads with no crash after removing these Beta versions... 
 
I think other users might be thankful to you too if you make a stable version of ScriptHook.  :cool:


Well, I don't really "do" IV. I've no modding experience or inspiration for it. Oh yeah, and I uninstalled it for space for other games because EFLC was too big to install then anyway :p

But there are already a lot of plans for the next generation of CLEO scripts, and I'm sure that if the new engine goes open source, there will be a lot of room for people more experienced with IV to work on something script-based for IV. However, that's the most I'm saying on that for now...

Note, that CLEO is fundamentally different to a script hook, as a script hook is just emulation of script code from a program executed by the CPU, whilst SCM/CLEO is a very basic script format, which is executed by a program which is running on the CPU. So that's SCM->EXE->CPU - it's way less efficient and is incomparable to the power of an actual program (ASI/DLL/EXE). There are clever ways to bring the power of scripts up to something near-equivalent (or in some cases, even more powerful) level, though. CLEO currently only uses the power already within each game, which is limited to game-specific purposes.
  • 65536 likes this

GaryRoachSanderson
  • GaryRoachSanderson

    Task Force 141

  • Members
  • Joined: 06 Aug 2005
  • Taiwan

#142

Posted 21 April 2014 - 04:18 PM Edited by Grove Street Boy, 22 April 2014 - 01:09 PM.

Hi Deji,

 

The mod below works in Cleo4 but textures fail to load in Cleo4.3 (textures are white squares), It is the Crawler mod by anmz (Ariel NMz).

 

I tried to contact the author but it seems he has closed his blog and quit modding, so I uploaded it here for help. Any way you can help? :(

 

Thank you.

 

P.S. I am using the latest version on a clean SA with no other mods just Cleo4.3 and this script.

 

Edit 2:

 

It's ok Deji, I have figured it out and recoded the file myself, the logic is that even though it is 1 file, but doesn't mean its the same thread, now that each individual thread loads its own txd dictionaries individually, the traditional method of loading textures wont work anymore, so I reprogrammed the script to load the txd files every time it creates a new thread, because this file calls itself multiple times and creates a new thread every time it does, so I figured it out.

 

Thanks anyway and good job on making Cleo 4.3 :D


Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#143

Posted 22 April 2014 - 02:04 PM Edited by Deji, 22 April 2014 - 02:06 PM.

Hi Deji,
 
The mod below works in Cleo4 but textures fail to load in Cleo4.3 (textures are white squares), It is the Crawler mod by anmz (Ariel NMz).
 
I tried to contact the author but it seems he has closed his blog and quit modding, so I uploaded it here for help. Any way you can help? :(
 
Thank you.
 
P.S. I am using the latest version on a clean SA with no other mods just Cleo4.3 and this script.
 
Edit 2:
 
It's ok Deji, I have figured it out and recoded the file myself, the logic is that even though it is 1 file, but doesn't mean its the same thread, now that each individual thread loads its own txd dictionaries individually, the traditional method of loading textures wont work anymore, so I reprogrammed the script to load the txd files every time it creates a new thread, because this file calls itself multiple times and creates a new thread every time it does, so I figured it out.
 
Thanks anyway and good job on making Cleo 4.3 :D


Ah, that's very interesting. I've always had a problem with that method of multiple-execution for extra vars... However, it would be really weird behaviour for CLEO to associate script-specifics by file and that could lead to unexpected consequences as well, so I'll need to tread carefully if I try to 'fix' it. Then again, adding it to the .cs3 compatibility mode effects might be more considerable.

The simple GTA script engine is showing its signs of stress :p

Maryo_Nicle7
  • Maryo_Nicle7

    Formerly known as Rizqan7

  • Members
  • Joined: 25 Jul 2013
  • Indonesia

#144

Posted 07 May 2014 - 09:58 AM

I've been tested this version and then I got my GTA SA crashed after the loading reaches in middle :blink:

Deji
  • Deji

    Coding like a Rockstar!

  • Feroci
  • Joined: 24 Dec 2007
  • None
  • Contribution Award [Mods]

#145

Posted 07 May 2014 - 02:08 PM

I've been tested this version and then I got my GTA SA crashed after the loading reaches in middle :blink:

 

Which version of GTASA are you running? Is it a clean (unmodded) copy?


Fantomax
  • Fantomax

    X-Force Rulez

  • Members
  • Joined: 20 May 2011
  • Indonesia

#146

Posted 24 May 2014 - 12:20 AM

um, why is Drift Smoke from PMC not working anymore?


franklingalaxy
  • franklingalaxy

    Player Hater

  • Members
  • Joined: 04 Jul 2014
  • Germany

#147

Posted 31 July 2014 - 08:47 AM

Can i rename every CLEO Skript to .cs3? Because i think there mods that Crash my game !


65536
  • 65536

    Trick

  • Members
  • Joined: 07 Sep 2012
  • Bulgaria

#148

Posted 03 August 2014 - 08:03 AM Edited by 65536, 03 August 2014 - 08:07 AM.

Deji, I now migrated to your CLEO 4.3.16 (last version), and I found most of mods I'm using works fine with it. BUT I found a CLEO mod that I want to use but it make my SA 1.0 crashing - First Person Mod http://www.gamemoddi...son-mod-v2.html

 

When I put the First_Person.cs in my CLEO folder and start the game, it crashes on loading screen when the bar hits its end - more exactly, this happens even before loading screen dissappears! If I remove that script (with all other CLEO mods active), game loads just fine! Here is the log made by CLEO 4.3.16 when the game didn't want to load CJ on map with this First Person Mod at all:

03/08/2014 10:41:58.147 Log started.
03/08/2014 10:41:58.147 Unprotecting memory region '.text': 0x00001000 (size: 0x00456000)
03/08/2014 10:41:58.148 Unprotecting memory region '.rdata': 0x00458000 (size: 0x0004C000)
03/08/2014 10:41:58.148 Unprotecting memory region '.text': 0x008B1000 (size: 0x0064A000)
03/08/2014 10:41:58.148 Parsing FXT file 1.fxt
03/08/2014 10:41:58.149 Added FXT[STROIM]
03/08/2014 10:41:58.149 Added FXT[BUIL0]
03/08/2014 10:41:58.149 Added FXT[BUIL1]
03/08/2014 10:41:58.149 Added FXT[BUIL2]
03/08/2014 10:41:58.149 Added FXT[BUIL3]
03/08/2014 10:41:58.149 Added FXT[BUIL4]
03/08/2014 10:41:58.149 Added FXT[BUIL5]
03/08/2014 10:41:58.149 Added FXT[BUIL6]
03/08/2014 10:41:58.149 Added FXT[BUIL7]
03/08/2014 10:41:58.149 Added FXT[BUIL8]
03/08/2014 10:41:58.149 Added FXT[BUIL9]
03/08/2014 10:41:58.149 Added FXT[BUIL10]
03/08/2014 10:41:58.149 Added FXT[BUINEX]
03/08/2014 10:41:58.149 Parsing FXT file JumpRampStunting.fxt
03/08/2014 10:41:58.150 Added FXT[JRAMP01]
03/08/2014 10:41:58.150 Added FXT[JRAMP02]
03/08/2014 10:41:58.150 Added FXT[JRAMP03]
03/08/2014 10:41:58.150 Parsing FXT file zonetext.fxt
03/08/2014 10:41:58.150 Added FXT[CT]
03/08/2014 10:41:58.150 Added FXT[CN]
03/08/2014 10:41:58.150 Added FXT[CS]
03/08/2014 10:41:58.151 Unloading plugins...
03/08/2014 10:41:58.151 Loading plugin cleo/FileSystemOperations.cleo
03/08/2014 10:41:58.157 Loading plugin cleo/IniFiles.cleo
03/08/2014 10:41:58.164 Loading plugin cleo/IntOperations.cleo
03/08/2014 10:41:58.170 Started on game of version: SA 1.0 us
03/08/2014 10:41:58.170 Injecting MenuStatusNotifier...
03/08/2014 10:41:58.170 Replacing call: 0x0057B9FD
03/08/2014 10:41:58.170 Injecting DmaFix...
03/08/2014 10:41:58.170 Replacing call: 0x0053E981
03/08/2014 10:41:58.170 Injecting TextManager...
03/08/2014 10:41:58.170 Injecting function at: 0x006A0050
03/08/2014 10:41:58.170 Injecting SoundSystem...
03/08/2014 10:41:58.170 Replacing call: 0x007487A8
03/08/2014 10:41:58.170 Injecting CustomOpcodeSystem...
03/08/2014 10:41:58.170 Injecting ScriptEngine...
03/08/2014 10:41:58.170 Replacing call: 0x0046A21B
03/08/2014 10:41:58.170 Replacing call: 0x0058D552
03/08/2014 10:41:58.170 Replacing call: 0x0058FCE4
03/08/2014 10:41:58.171 Replacing call: 0x0053BDD7
03/08/2014 10:41:58.171 Replacing call: 0x005BA340
03/08/2014 10:41:58.171 Replacing call: 0x005D4FD7
03/08/2014 10:41:58.171 Replacing call: 0x005D18F0
03/08/2014 10:41:58.171 Replacing call: 0x005D14D5
03/08/2014 10:41:58.171 Injecting function at: 0x004667DB
03/08/2014 10:41:58.738 Creating main window...
03/08/2014 10:41:58.741 Found sound device 0: No sound
03/08/2014 10:41:58.741 Found sound device 1 (default): Speakers (SoundMAX Integrated Digital HD Audio Driver)
03/08/2014 10:41:58.741 On system found 2 devices, 2 enabled devices, assuming device to use: 1 (Speakers (SoundMAX Integrated Digital HD Audio Driver))
03/08/2014 10:41:58.764 SoundSystem initialized
03/08/2014 10:41:58.766 Floating-point audio supported!
03/08/2014 10:41:58.767 Audio hardware acceleration disabled (no EAX)
03/08/2014 10:42:20.855 Scripts exclusively initialized
03/08/2014 10:42:20.864 Deleting dynamic fxts...
03/08/2014 10:42:20.864 Cleaning up script data... 0 files, 0 libs, 0 file scans, 0 allocations...
03/08/2014 10:42:20.865 Searching for cleo scripts
03/08/2014 10:42:20.865 Loading custom script autotraffix0.1.cs...
03/08/2014 10:42:20.873 Registering custom script named autotra
03/08/2014 10:42:20.874 Loading custom script builder.cs...
03/08/2014 10:42:20.882 Registering custom script named builder
03/08/2014 10:42:20.882 Loading custom script double_megajump.cs...
03/08/2014 10:42:20.892 Registering custom script named double_
03/08/2014 10:42:20.892 Loading custom script first_person.cs...
03/08/2014 10:42:20.893 Registering custom script named first_p
03/08/2014 10:42:20.893 Loading custom script health.cs...
03/08/2014 10:42:20.899 Registering custom script named health.
03/08/2014 10:42:20.899 Loading custom script JumpRampStunting.cs...
03/08/2014 10:42:20.908 Registering custom script named JumpRam
03/08/2014 10:42:20.908 Loading custom script KPI.cs...
03/08/2014 10:42:20.914 Registering custom script named KPI.cs
03/08/2014 10:42:20.914 Loading custom script MarkAndExecute.cs...
03/08/2014 10:42:20.921 Registering custom script named MarkAnd
03/08/2014 10:42:20.921 Loading custom script MaxWeapskills.cs...
03/08/2014 10:42:20.922 Registering custom script named MaxWeap
03/08/2014 10:42:20.923 Loading custom script mspark.cs...
03/08/2014 10:42:20.936 Registering custom script named mspark.
03/08/2014 10:42:20.936 Loading custom script never wanted.cs...
03/08/2014 10:42:20.942 Registering custom script named never w
03/08/2014 10:42:20.942 Loading custom script night-thermal vision mod.cs...
03/08/2014 10:42:20.942 Registering custom script named night-t
03/08/2014 10:42:20.942 Loading custom script No armed gangs.cs...
03/08/2014 10:42:20.943 Registering custom script named No arme
03/08/2014 10:42:20.943 Loading custom script Regeneration.cs...
03/08/2014 10:42:20.943 Registering custom script named Regener
03/08/2014 10:42:20.943 Loading custom script spawn sports cars.cs...
03/08/2014 10:42:20.944 Registering custom script named spawn s
03/08/2014 10:42:20.944 Loading custom script stroimdoma.cs...
03/08/2014 10:42:20.944 Registering custom script named stroimd
03/08/2014 10:42:20.944 Loading custom script TIMEFIX.cs...
03/08/2014 10:42:20.944 Registering custom script named TIMEFIX
03/08/2014 10:42:20.944 Loading custom script Vehicle Auto Repair and Flipper.cs...
03/08/2014 10:42:20.945 Registering custom script named Vehicle
03/08/2014 10:42:20.945 Loading custom script velocidad turbo           byalbeiro.cs...
03/08/2014 10:42:20.945 Registering custom script named velocid
03/08/2014 10:42:20.945 Loading custom script weapons at jefferson hospital V2.cs...
03/08/2014 10:42:20.946 Registering custom script named weapons
03/08/2014 10:42:20.946 Loading custom script zonetexts.cs...
03/08/2014 10:42:20.946 Registering custom script named zonetex
03/08/2014 10:42:21.095 Unregistering custom script named $professиq^r
03/08/2014 10:42:47.575 Closing SoundSystem...
03/08/2014 10:42:47.576 Freeing BASS library
03/08/2014 10:42:47.576 SoundSystem closed!
03/08/2014 10:42:47.576 Deleting fxts...
03/08/2014 10:42:47.576 Unloading scripts...
03/08/2014 10:42:47.576 Unregistering custom script named autotra
03/08/2014 10:42:47.576 Unregistering custom script named builder
03/08/2014 10:42:47.576 Unregistering custom script named double_
03/08/2014 10:42:47.576 Unregistering custom script named first_p
03/08/2014 10:42:47.576 Unregistering custom script named health
03/08/2014 10:42:47.576 Unregistering custom script named jpr
03/08/2014 10:42:47.577 Unregistering custom script named KPI.cs
03/08/2014 10:42:47.577 Unregistering custom script named mrkaexc
03/08/2014 10:42:47.577 Unregistering custom script named mspark
03/08/2014 10:42:47.577 Unregistering custom script named wanted
03/08/2014 10:42:47.577 Unregistering custom script named noname
03/08/2014 10:42:47.577 Unregistering custom script named unarm
03/08/2014 10:42:47.577 Unregistering custom script named regen
03/08/2014 10:42:47.577 Unregistering custom script named carspawn8ш Oш 
03/08/2014 10:42:47.577 Unregistering custom script named stroimd
03/08/2014 10:42:47.577 Unregistering custom script named main
03/08/2014 10:42:47.577 Unregistering custom script named varu
03/08/2014 10:42:47.577 Unregistering custom script named anmztrb
03/08/2014 10:42:47.577 Unregistering custom script named gunsgunsLm"am"
03/08/2014 10:42:47.577 Unregistering custom script named zonetex
03/08/2014 10:42:47.578 Deleting inactive script named $professиq^r
03/08/2014 10:42:47.578 Log finished.

Someone else to got this mod working with CLEO 4.3? There was a few additional opcode files provided with mod, but I've didn't install them because I'm not sure where to place them and whether they will not messes up my working CLEO 4.3.16 library or corrupt the way how any of other mods working...
 

Also, if this is a bug and you're going to fix it, one suggestion - make the log write multiple instances in CLEO.txt - aka. when people are starting SA again, CLEO to add new logs WITHOUT DELETING the previous logs...


uokka
  • uokka

    Actually living entity

  • Members
  • Joined: 17 Jun 2011
  • Red-Cross

#149

Posted 03 August 2014 - 12:39 PM

[...] There was a few additional opcode files provided with mod, but I've didn't install them because I'm not sure where to place them and whether they will not messes up my working CLEO 4.3.16 library or corrupt the way how any of other mods working... [...]

 

 

Apart from...

..\GTASA\CLEO\first_person.cs

 

...I'm pretty sure you'll need those files as well.

..\GTASA\msvcr100d.dll
..\GTASA\CLEO\memopcodes.cleo
..\GTASA\CLEO\newopcodes.cleo

 

Otherwise it's obvious why it doesn't work.


krloxxx
  • krloxxx

    i love GTA SA

  • Members
  • Joined: 20 Sep 2014
  • Argentina

#150

Posted 23 September 2014 - 12:50 AM

How can i install it?

That dont have a setup :cry:





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users