Quantcast

Jump to content

» «
Photo

Problem while adapting a car to ImVehFt

7 replies to this topic
silentkiller44
  • silentkiller44

    KITT Lover

  • Members
  • Joined: 06 Aug 2013

#1

Posted 03 November 2013 - 12:49 PM Edited by silentkiller44, 03 November 2013 - 12:54 PM.

Hi everyone! This is my first topic here so if this is not under the correct category, feel free to move it but don't delete it because I need help.

 

I am sure that most of you have heard of this mod and have even successfully adapted cars to work with this mod. This is my first time adapting an original car which is an Infernus. I have three problems now.

 

The first problem is this: I have added two front indicators, foglights and brakelights. The dummies are in place and the game doesn't crash. But when I brake, only the dummies light up without any textures e.t.c. and this is the same with all of the lights.

 

The second problem is this: When the car's lights are on, the foglights and indicators both come on automatically (because they are a part of the headlights) and at the back, the car's whole taillights light up, not separately like half is for regular taillights and half for brake lights. So, for that, I need to know how to separate the indicators and foglights from the front lights so that they don't light up with the car's lights and how to "divide" the tailights so that half is for braking lights and half for regular lights.

 

The third problem is this: When I press z for for the left indicator, both of the indicator dummies light up and when I press x, the same thing happens. But when I press c, nothing happens.

 

Here are links to some screenshots:

 

1) http://g38i.img-up.n...allery4c654.jpg (The original rear lights)

2) http://a58i.img-up.n...allery3aa8e.jpg (The original head lights)

3)http://l13i.img-up.n...allery10965.jpg (The brake light dummies)

4)http://o56i.img-up.n...allery20299.jpg (The indicator and foglight dummies)

 

Please help me.

 Sorry for making such a big post. :p

 

-silentkiller44


JohnPro
  • JohnPro

    GTAHalo.com

  • Members
  • Joined: 12 Apr 2007

#2

Posted 04 November 2013 - 04:36 AM Edited by JohnPro, 04 November 2013 - 04:41 AM.

Game only has 4 light materials which swaps light off with light on texture found in vehicle.txd. These are left headlight, right headlight, left tailight, right tailight.

So its not possible to have half the light come on during tailight and the other half on during braking.

You also cant separate foglights with headlights, unless you use a script that adds colored coronas at these dummy locations then its not possible.

I dont know about this mod but if its how I think it works, its using the original dummy locations to add a colored corona texture.

So place headlight dummy at headlights, then headlights2 at fog lights, then the script does the rest

For tailights do the same for tailights and tailights2.

You need a script that does it in this way

silentkiller44
  • silentkiller44

    KITT Lover

  • Members
  • Joined: 06 Aug 2013

#3

Posted 04 November 2013 - 01:48 PM Edited by silentkiller44, 05 November 2013 - 03:44 PM.

Actually, a script has been made, which I mentioned in the OP. It's known as ImVehFt.

 

EDIT: I found out how to solve those two problems.....or at least I think I have :p. But I need to know another thing. How to change materials in car parts? like if I want to change the light material used on the bump_front_ok, how do I do it? 

 

One thing I forgot to mention, I have Zmodeler 2 not 1.


JohnPro
  • JohnPro

    GTAHalo.com

  • Members
  • Joined: 12 Apr 2007

#4

Posted 05 November 2013 - 07:08 PM Edited by JohnPro, 05 November 2013 - 07:11 PM.

In 3ds max material editor you can choose under gta material what you want the texture to be (primary, secondary or lights). Perhaps zmod the same? It should be similar. I think its done by the color of the material.

Here a tut, instead of primary choose the light you want.
http://gtaforums.com...for-zmodeler-1/

silentkiller44
  • silentkiller44

    KITT Lover

  • Members
  • Joined: 06 Aug 2013

#5

Posted 06 November 2013 - 02:27 PM

Hi there!

 

Thanks for replying and for the tut, but there is no FACES button on the top in Zmod :/


JohnPro
  • JohnPro

    GTAHalo.com

  • Members
  • Joined: 12 Apr 2007

#6

Posted 06 November 2013 - 05:42 PM Edited by JohnPro, 06 November 2013 - 05:43 PM.

Not sure but I think its the third button on the image below.

 

zm_05.jpg

               ^

 

:)


silentkiller44
  • silentkiller44

    KITT Lover

  • Members
  • Joined: 06 Aug 2013

#7

Posted 07 November 2013 - 03:44 PM Edited by silentkiller44, 08 November 2013 - 12:58 PM.

I already figured that out yesterday, but Thanks. You're the only one who helped me. My problems are solved now. I shouldn't even have started this topic :p.

 

Anyways, I just had to change the colours of the lights, those are the colours which makes the script see them as (for example) foglights, so it lights them accordingly, not with the headlights.

 

Again man, Thanks. I got what I needed. No need for more questions and answers.

 

Bye  :colgate:

 

Don't know why, But I find this post of mine offensive :/. If you are offended, then I am sorry and I didn't mean any offense :D

 

-silentkiller44


JohnPro
  • JohnPro

    GTAHalo.com

  • Members
  • Joined: 12 Apr 2007

#8

Posted 07 November 2013 - 05:28 PM

Hehe thats good man, glad you got it solved. Yes its based on the material colors for the game to detect which light is which. :-)




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users