Quantcast

Jump to content

» «
Photo

IV runs slow or crashes w/o error

6 replies to this topic
Raptor5dino
  • Raptor5dino

    Player Hater

  • Members
  • Joined: 23 Oct 2013

#1

Posted 23 October 2013 - 02:59 AM Edited by Raptor5dino, 23 October 2013 - 03:04 AM.

I am having a similar problem.

 

I have a high end gaming computer that ran 4 at maximum graphics without lag.

 

When I first installed GTA 4, a small console popped up when I opened 4. And then it would open.

Then I got EFLC, and when I opened 4, it would open 4, no console, and have the option to play 4 or EFLC.

After a while, I did some car modding, and then the game glitched or something and nothing would render.

So I had to re-install GTA 4, and I'm back with the console which now opens social club so I can launch the game, and EFLC is separate from 4.

However, when I open 4, sometimes the console just stays, and nothing happens. When I do get through to the game, it takes a much much longer time to get into game-play, and that now has a lag spike every 30 seconds to 1 minute. Then, after maybe 5-10 minutes the game freezes, and a window pops up saying that GTA 4 has stopped working. No error message pops up with a code like some other people get. I am still running the game at max graphics.

 

I would really appreciate any help.

 

Thanks.

 

Computer specs:

 

Processor: Intel i5 quadcore

Ram: 8GB

64-bit operating system

Windows 7 ultimate

 

The Graphics card is a Nvidia.

I have 2 fans,

A Corsair Vengeance headset,

A Roccat Kone pure mouse,

And A Razor keyboard.

The computer was custom built, ordering parts from PC case gear.


Girish
  • Girish

    Leone Family Mafia

  • Moderator
  • Joined: 20 Apr 2006
  • India
  • Best Moderator 2011

#2

Posted 23 October 2013 - 08:01 AM

Please do not post in someone else's topic. I have split your post into a new topic.

 

First up, since you had modded the game, try deleting all files from the Settings folder located at C:\Users\<user>\AppData\Local\Rockstar Games\GTA IV\Settings

 

Your PC could be overheating if the game crashes after a while. Have you checked this out?

Can you try running the game at lower settings to see if it makes a difference?


Raptor5dino
  • Raptor5dino

    Player Hater

  • Members
  • Joined: 23 Oct 2013

#3

Posted 24 October 2013 - 12:33 AM Edited by Raptor5dino, 24 October 2013 - 12:42 AM.

I ran it on lower settings, it crashed again. And after it crashed the computer was cool, so overheating is not the issue. After deleting the settings, I cannot get past the section where it plays a segment of the theme, shows rockstar's logo, rockstar north's logo, and then says grand theft auto 4. After that, I am left with a blank screen.

 

The thing I want to happen though, would be for 4 to update like it did before, and join up to EFLC again. That I think may be the problem, but I have no idea how to get that to happen.

 

By it being the problem, I mean that I think the problem is that 4 is separate from EFLC, and The Lost and Damned and The Ballad of Gay Tony run perfectly fine at max settings.


Girish
  • Girish

    Leone Family Mafia

  • Moderator
  • Joined: 20 Apr 2006
  • India
  • Best Moderator 2011

#4

Posted 25 October 2013 - 07:52 AM

Try reinstalling GTA IV.

Don't update the game from within GFWL. Download the updates separately and then install them when the game is not running.


Raptor5dino
  • Raptor5dino

    Player Hater

  • Members
  • Joined: 23 Oct 2013

#5

Posted 02 November 2013 - 07:25 AM Edited by Raptor5dino, 05 November 2013 - 05:19 AM.

Ok. I re-installed game, so far, it's exactly the same, but doesn't crash. Just the frequent lag is getting on my nerves. Also, I don't know how to update it.

 

Oops, spoke too soon, it crashed.


lolleroz
  • lolleroz

    Homeboy

  • Members
  • Joined: 29 Jul 2010
  • None

#6

Posted 02 November 2013 - 09:10 AM

lol, the console means you have unpatched game, it was removed afterwards. Get 1.0.7.0 patch, it will help the game's performance as well

Raptor5dino
  • Raptor5dino

    Player Hater

  • Members
  • Joined: 23 Oct 2013

#7

Posted 05 November 2013 - 05:55 AM

Thankyou so much guys!!! It runs like a dream! Screw GTA 5, I love you Niko!!!!!





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users