Quantcast

Jump to content

» «
Photo

Gta IV Lag

5 replies to this topic
RPJX4
  • RPJX4

    Player Hater

  • Members
  • Joined: 11 Oct 2013

#1

Posted 16 October 2013 - 03:06 PM

When i play GTA IV it lags like hell (14-15 FPS). It's not from my laptop, because i pass the recomended requirements. How can i fix it?


Girish
  • Girish

    Leone Family Mafia

  • Moderator
  • Joined: 20 Apr 2006
  • India
  • Best Moderator 2011

#2

Posted 17 October 2013 - 05:26 AM

We still need to know your laptop's specifications.

What settings are you running the game at?

Have you updated the game?

Are you using any mods?


RPJX4
  • RPJX4

    Player Hater

  • Members
  • Joined: 11 Oct 2013

#3

Posted 17 October 2013 - 12:31 PM

The specifications are: 8 GB RAM, Intel Core i7 2.20 GHz, Nvidia Geforce 520MX 1GB. I am running the game at normal settings. I have not update the game and i don't have any mods.


RPJX4
  • RPJX4

    Player Hater

  • Members
  • Joined: 11 Oct 2013

#4

Posted 20 October 2013 - 03:04 PM

Hello?


Girish
  • Girish

    Leone Family Mafia

  • Moderator
  • Joined: 20 Apr 2006
  • India
  • Best Moderator 2011

#5

Posted 22 October 2013 - 05:05 PM

I'd recommend that you update the game.

Make sure that you close all running applications before starting the game. Also, try lowering the resolution to see if it makes any difference.


RPJX4
  • RPJX4

    Player Hater

  • Members
  • Joined: 11 Oct 2013

#6

Posted 23 October 2013 - 12:09 PM

I will try.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users