Quantcast

Jump to content

» «
Photo

Latest GTA4 patch kills performance

6 replies to this topic
Arvis
  • Arvis

    Li'l G Loc

  • Members
  • Joined: 28 Jul 2006

#1

Posted 03 October 2013 - 08:45 PM

Today I installed GTA4 (not EFLC) and it ran perfectly on max, 50-70fps according to fraps.

Now I installed latest patch and it's like 34-40fps average, a huge drop.

Is there any way I can fix this without downgrading? I tried to disable the shadows at all (as it is the graphics improvement I can see), but it makes no difference, still 35-40fps.

 

Here's benchmark (which shows FPS which I actually had before patch, but is taken after patching):


Statistics
Average FPS: 65.13
Duration: 37.06 sec
CPU Usage: 51%
System memory usage: 43%
Video memory usage: 69%
 
Graphics Settings
Video Mode: 1280 x 1024 (75 Hz)
Texture Quality: High
Shadow Quality: Very High
Reflection Resolution: Very High
Water Quality: Very High
Texture Filter Quality: Anisotropic x16
Night Shadows: Very High
View Distance: 100
Detail Distance: 100
 
Hardware
Microsoft Windows 7 Ultimate 
Service Pack 1
Video Adapter: NVIDIA GeForce GTX 660 
Video Driver version: 331.40
Audio Adapter: Speakers (Realtek High Definition Audio)
Intel® Core™ i5-4570 CPU @ 3.20GHz
 
File ID: Benchmark.cli

jpm1
  • jpm1

    Vice city citizen

  • Members
  • Joined: 26 Sep 2005
  • European-Union

#2

Posted 07 October 2013 - 01:36 PM

day shadows : medium

night shadows : off

try to reduce a bit viewing distance and distance details

reduce a bit traffic density

turn off auto capture and auto save things

 

but 30-40 fps is pretty descent for a vanilla install


Arvis
  • Arvis

    Li'l G Loc

  • Members
  • Joined: 28 Jul 2006

#3

Posted 08 October 2013 - 05:04 PM

I already said that even disabling shadows gave no visible performance improvement.

Will try to turn off auto capture.


Preet_GTA
  • Preet_GTA

    GTA Gamer

  • Members
  • Joined: 11 Oct 2013

#4

Posted 12 October 2013 - 07:58 AM

Hi i have some problem related to this topic,i have 1.0.7.0 patch installed for GTA IV,but night shadows options greyed out in settings options & i can't select it,any ideas ??


lol232
  • lol232

    We stealin' all da gold!

  • Members
  • Joined: 26 Mar 2010
  • Serbia

#5

Posted 13 October 2013 - 12:21 PM

Thats because Patch 7 has better shadows, therefore more processing, just drop the shadow quality from very high to high and it'll be alright.

I don't see the problem with 40-50 FPS though, even 30 FPS wouldn't be a problem.


Arvis
  • Arvis

    Li'l G Loc

  • Members
  • Joined: 28 Jul 2006

#6

Posted 13 October 2013 - 06:15 PM

And third time I'm saying:

I already said that even disabling shadows gave no visible performance improvement.

 

 

35-40fps is acceptable, but I'm pretty sure I can have more.


radioman
  • radioman

    Big Homie

  • Members
  • Joined: 19 Apr 2006

#7

Posted 15 October 2013 - 09:56 PM

I guess it depends on system specs and in-game settings used, as I have used both Patch 4 (Retail DVD version) AND Patch 7 (Steam version)-both on the same PC, and have not really noticed a difference performance wise? For me, both Patches yield pretty much the same performance and fps..

 

OT-Lowering your in-game settings-mostly the shadows WILL yield better fps. Also, IF you have mods or trainers, that can impact fps as mods use more resources from the system than the un-modded game does-I have proven that with III and VC for PC. 





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users