Jump to content

» «

GTA4 gets detected by Intel Hd instead of Nvidia

2 replies to this topic
  • fahadhum

    Player Hater

  • Members
  • Joined: 02 Sep 2013


Posted 02 September 2013 - 11:45 AM

cryani.gif I have an Acer 5750g Laptop and it has the Optimus Technology.Which unfortunately won't let GTA 4 run on Nvidia Dedicated Memory Graphics but Intel HD graphics.Now,somebody has suggested me a unique solution which i haven't found in tons and tons of forums.It is as follow..

"Try booting up, hitting F2/Del and go into BIOS, then head for the Advanced tab, and look up the order of the video cards. At this moment, it might be Onboard->PCI->PCI-E, change that to PCI-E->PCI->Onboard
Then press F10 to save and exit, you don't have to change anything else, this will force the signal on the external card rather than the internal"

I just want anyone's opinion here at GTA forums regarding if i should try it or not.As i am very cautious and i do not want to crash my laptop...I have tried many other solutions like USING COMMAND LINES,USING NVIDIA CONTROL PANEL & USING NVIDIA INSPECTOR (which usually solve the problem with other games that were running on intel hd rather then my dedicated card).But GTA 4 just wouldn't run on Nvidia..So this is like a last resort for me...

  • TonyResta

    Tony Resta

  • Members
  • Joined: 01 Mar 2006


Posted 07 September 2013 - 06:27 AM

Yes that should work, what that does is simply change the priority list and give first priority to the GFX card you want to use. 

If for some reason that doesn't work, you can always change the settings back. Just make sure to remember what you change.

  • bongo88

    Player Hater

  • Members
  • Joined: 13 Sep 2013


Posted 13 September 2013 - 05:21 PM

You should be able to go to the Nividia Settings and set the gta4 to High-Performance Nividia Processor.


Of course, if you are trying to use an ENB, then this mod fixes the problem.

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users