Quantcast

Jump to content

» «
Photo

GTA IV Crashing with no error

9 replies to this topic
MarkingSoup
  • MarkingSoup

    Player Hater

  • Members
  • Joined: 14 Jul 2013

#1

Posted 31 July 2013 - 01:29 PM

My GTA had a load of mods and it worked fine, but after a while when i started the game up after the loading photos it just closes with no error.

I have re-installed it about 3 times, re-installed steam and removed all the Mods.

Ive been trying alot of stuff to get it working But it just keeps crashing with no error.

============================================

Pc Specs:

Windows 7

Processor: AMD FX™-8350 Eight-core Processor 4.00 GHz

Installed memory (RAM): 8.00 GB

System type: 64-bit operating System


============================================

If anyone knows how I can fix this please tell me!


(GTA IV Steam)

miromiro
  • miromiro

    Time Killa™

  • Zaibatsu
  • Joined: 26 Nov 2009
  • None

#2

Posted 31 July 2013 - 01:33 PM

Mods are known for messing up your game. Even if it doesn't happen right away, sooner or later they will make the game crash, and an outcome like yours turns out to be no wonder. Here's what I suggest you to do: remove every single mod / modded file, deleting your game settings, and completely un-install GTA IV (preferably using Revo Uninstaller to make sure there is no sign of GTA IV on your PC anymore), and then do a fresh installation of GTA IV, without re-installing any of the mods you had, obviously.

Preferably, install it in a different location, a different Hard Drive if possible. That's all I can tell you. Good luck. icon14.gif

MarkingSoup
  • MarkingSoup

    Player Hater

  • Members
  • Joined: 14 Jul 2013

#3

Posted 31 July 2013 - 01:49 PM

Like i said, i removed all the mods and its still crashing with no error

miromiro
  • miromiro

    Time Killa™

  • Zaibatsu
  • Joined: 26 Nov 2009
  • None

#4

Posted 31 July 2013 - 02:37 PM

Have you tried to run the game in Windows XP SP3 Compatibility mode or as administrator?
Okay, try to install these: Games for Windows Live Update & .NET Framework 3.5. If nothing works, install xliveless, though it'll move your save files location to My Documents and will disable online play.

MarkingSoup
  • MarkingSoup

    Player Hater

  • Members
  • Joined: 14 Jul 2013

#5

Posted 31 July 2013 - 02:41 PM

I have tryed in administrator, i haven't tryed the others,

Ill download them

MarkingSoup
  • MarkingSoup

    Player Hater

  • Members
  • Joined: 14 Jul 2013

#6

Posted 31 July 2013 - 02:56 PM

Its working now thanks!

Do you know how to fix red sky aswell tounge.gif

It happens alot when i install realistic packs.

When i get a fix for it, it fixes it but there is never sun/blue sky, allways gray days and nights.


miromiro
  • miromiro

    Time Killa™

  • Zaibatsu
  • Joined: 26 Nov 2009
  • None

#7

Posted 31 July 2013 - 03:09 PM

Sorry, but I'm not good at helping you with modding stuff. You'd be better off asking about it in the IV Other forum. icon14.gif

QUOTE (MarkingSoup @ Jul 31 2013, 14:56)
Its working now thanks!


Glad to help. icon14.gif
Can you tell me which solution brought the fix? It'd be good to know for future similar cases. Thank you. smile.gif


MarkingSoup
  • MarkingSoup

    Player Hater

  • Members
  • Joined: 14 Jul 2013

#8

Posted 31 July 2013 - 03:14 PM

I only installed 3.5 xframework and some other thing with it, But it just said i could uninstall it or repair because i already got it, so i repaired it.

and added the xlive.

what does xlive do, and why does it stop online?

miromiro
  • miromiro

    Time Killa™

  • Zaibatsu
  • Joined: 26 Nov 2009
  • None

#9

Posted 31 July 2013 - 03:43 PM

So it was xliveless that fixed it. I'm not sure why online mode was disabled, but I believe it's to prevent cheating in Multiplayer or something alike. What is does is that it by-passes Games for Windows Live - a program that often bugs GTA IV and doesn't let it start, like in your case. So, with xliveless, Games for Windows Live is canceled, thus making your game work.

MarkingSoup
  • MarkingSoup

    Player Hater

  • Members
  • Joined: 14 Jul 2013

#10

Posted 31 July 2013 - 07:17 PM

i don't really care about online as long as GTA Works!

Thanks for your help!




4 user(s) are reading this topic

0 members, 4 guests, 0 anonymous users