Quantcast

Jump to content

» «
Photo

Parked car

5 replies to this topic
oleg_berezov
  • oleg_berezov

    Player Hater

  • Members
  • Joined: 15 Jul 2013

#1

Posted 21 July 2013 - 03:43 PM Edited by oleg_berezov, 21 July 2013 - 04:57 PM.

Hi! I'm trying to make cleo parking script for III.


CODE
{$CLEO .cs}
014B: $12345 = init_parked_car_generator #PATRIOT -1 -1 0 alarm 100 door_lock 0 0 10000 at 883.006 -219.3838 3.0281 angle 340.0
014C: set_parked_car_generator $12345 cars_to_generate_to 101
05DC: end_custom_thread


I'm newbie and i think it have few bugs with this script.
If i save game with this script and than delete script from CLEO folder, car still there after loading.
Could you show me good parked script example without bugs?

oleg_berezov
  • oleg_berezov

    Player Hater

  • Members
  • Joined: 15 Jul 2013

#2

Posted 22 July 2013 - 05:41 AM

Ok, i found it, i think:
CODE


{$CLEO .cs}

014B: 0@ = init_parked_car_generator #PATRIOT -1 -1 0 alarm 100 door_lock 0 0 10000 at -789.106 302.7411 49.0594 angle -30.0
014C: set_parked_car_generator 0@ cars_to_generate_to 101

05DC: end_custom_thread        

oleg_berezov
  • oleg_berezov

    Player Hater

  • Members
  • Joined: 15 Jul 2013

#3

Posted 23 July 2013 - 01:36 PM Edited by oleg_berezov, 23 July 2013 - 07:14 PM.

No, parked cars a still there after deleting script.
How prevent script not to wright information to savegame?

ZAZ
  • ZAZ

    Kernlochbohrer

  • Members
  • Joined: 10 Jan 2005
  • European-Union

#4

Posted 23 July 2013 - 05:55 PM

>look here<

oleg_berezov
  • oleg_berezov

    Player Hater

  • Members
  • Joined: 15 Jul 2013

#5

Posted 23 July 2013 - 07:14 PM

It is for SA, because III doesn't have 0A95: enable_thread_saving, so...

oleg_berezov
  • oleg_berezov

    Player Hater

  • Members
  • Joined: 15 Jul 2013

#6

Posted 25 July 2013 - 04:44 PM

Opcode 00A5 fix the problem. Solved




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users