Quantcast

Jump to content

» «
Photo

Bug/glitch on mission 'Ransom'

5 replies to this topic
starbeek
  • starbeek

    Player Hater

  • Members
  • Joined: 15 Feb 2011

#1

Posted 14 July 2013 - 06:06 PM

Hi,

I got a problem with the mission Ransom.
I know it's one of the easiest missions in the game, but the problem is that there is no sound/voices.

When you enter the building you should hear Grace already, but in my game you don't hear Grace at all.
I know Gordon will start talking about his shift, or someting like that, and that Grace will mumble behind her gag. (I saw it in a youtube video)
When you hit her in the face to get her to look at you Niko doesn't say anything to her and she won't make sound. (I saw in the youtube video that he will say something to her and that she'll reply with 'f*ck you')
After I send the picture to Packie, Niko will call him but he doesn't say anything to him and immediately ends the phonecall.


I'm on PC, does anyone know how to fix this? I've tried to reload the game and even restarted my pc but it still doesn't work.
Any other solutions?

Thanks!

Tycek
  • Tycek

    Being a bastard works.

  • Members
  • Joined: 20 Jul 2009
  • Poland

#2

Posted 14 July 2013 - 06:09 PM

Three questions:
Where did you get your game from?
Are you using any mods?
Are you using any No-CD cracks?

starbeek
  • starbeek

    Player Hater

  • Members
  • Joined: 15 Feb 2011

#3

Posted 14 July 2013 - 06:23 PM

I bought it in an online shop.
The game is completely new, it isn't second-hand
No mods
No No-CD cracks
No cheats

Miro
  • Miro

    Time Killa™

  • Zaibatsu
  • Joined: 26 Nov 2009
  • None
  • GTANet Contribution Award [Newbie Guide]
    Most Improved 2010

#4

Posted 14 July 2013 - 07:57 PM

Strange enough. This is one of the unknown bugs of the game. Umm, have you tried deleting your game settings? Besides, make sure you've got these installed: GTA IV Patch 1.0.7.0 & Games for Windows Live Update. Have you tried re-installing the game?

What about updating / re-installing your audio drivers?

starbeek
  • starbeek

    Player Hater

  • Members
  • Joined: 15 Feb 2011

#5

Posted 15 July 2013 - 06:19 PM

QUOTE (miromiro @ Sunday, Jul 14 2013, 19:57)
Strange enough. This is one of the unknown bugs of the game. Umm, have you tried deleting your game settings? Besides, make sure you've got these installed: GTA IV Patch 1.0.7.0 & Games for Windows Live Update. Have you tried re-installing the game?

What about updating / re-installing your audio drivers?

I deleted my game settings, installed the patch 1.0.7.0, reinstalled the game with the patch and it's still not working sad.gif

I can't find the update for games for windows windows live? I don't know where to find it on the site you gave.

I let my pc check my audio drivers and it said that they don't need updating.

Any other solutions?

Thanks in advance!

starbeek
  • starbeek

    Player Hater

  • Members
  • Joined: 15 Feb 2011

#6

Posted 15 July 2013 - 06:51 PM

Weirdest solution ever!!!

I got a bit pissed at the game that it still didn't work after reinstalling etc.

When I entered the building, again without sound, I killed Grace with a knife.
I 'failed' the mission and Niko calls Packie, again without saying anything he hangs up the Phone.

I'm trying to get the best stats I can, 0 deaths, 0 arrests, 0 mission fails etc.
So when I 'failed' mission and spawned outside again I checked my stats; still 0 mission fails.

I entered a car and immediately the Ransom mission icon spawned on the radar and it said: 'Go upstars to the safehouse' on screen.

So I entered the building and I could hear Grace mumbling and when I entered the room Gordon started to talk about fries.

After the mission Niko calls Packie and he talks to him .


I'm so happy biggrin.gif biggrin.gif biggrin.gif

Finally completed it with the sound biggrin.gif

I guess Ransom isn't considered a mission since you can't fail it, even if you fail it. tounge.gif
And when you fail the mission you don't get the replay message on your Phone.

Thanks Tycek and miromiro for helping me ! biggrin.gif icon14.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users