Quantcast

Jump to content

» «
Photo

Problem with Saves.

15 replies to this topic
Shoumic
  • Shoumic

  • The Yardies
  • Joined: 09 Jul 2012
  • None
  • Best Signature 2013
    Best Signature 2012

#1

Posted 13 July 2013 - 01:18 PM Edited by shoumic, 13 July 2013 - 02:29 PM.

Hey everyone.

Recently I've been having a problem with my Copy of GTA San Andreas. It cant detect any of the saves I plug into the User files folder.

Here's my User files Folder.

user posted image

And here's my game.

user posted image

Here's what I have tried so far.

• Re-install the game.
• Set compatibility mode to Windows 98 and all the other modes.
• Ran the game as an Administrator.

This is happening to both my store bought copy which is V1 and my V2 copy.

• None of them are pirated or cracked.

Now I have come to notice that whenever I save the game in either version the game does indeed save. Now I'm not sure where the save files are being placed. It's definitely not in the User files folder. They are being placed somewhere else or I wouldn't be able to save. If someone knows this location can they let me know? Because I can plug in my saves in that location then.

Does anyone know what is going on? Is there anything I can do to fix this problem?

Cheers.

lil weasel
  • lil weasel

    Shoot Looters, Hang Pirates!

  • Members
  • Joined: 25 Dec 2006
  • None
  • Contribution Award [San Andreas]

#2

Posted 13 July 2013 - 01:27 PM

Look in the PUBLIC files. (Or place the saves in the Public Files).

ThatSpecialSomeone
  • ThatSpecialSomeone

  • Members
  • Joined: 14 Mar 2012
  • Slovakia

#3

Posted 13 July 2013 - 01:33 PM

Save should be named "GTASAsfX" where X represents number from 1 to 8. I think that "b" shouldn't be there.

lil weasel
  • lil weasel

    Shoot Looters, Hang Pirates!

  • Members
  • Joined: 25 Dec 2006
  • None
  • Contribution Award [San Andreas]

#4

Posted 13 July 2013 - 01:38 PM

QUOTE (0909090 @ Saturday, Jul 13 2013, 13:33)
Save should be named "GTASAsfX" where X represents number from 1 to 8. I think that "b" shouldn't be there.

The San Andreas Save Files are All dot "B" files.

ThatSpecialSomeone
  • ThatSpecialSomeone

  • Members
  • Joined: 14 Mar 2012
  • Slovakia

#5

Posted 13 July 2013 - 01:40 PM

Actually if I add ".b" to my saves, game wouldn't register them. So I think that's the problem in Shoumic's case.

Shoumic
  • Shoumic

  • The Yardies
  • Joined: 09 Jul 2012
  • None
  • Best Signature 2013
    Best Signature 2012

#6

Posted 13 July 2013 - 01:41 PM Edited by shoumic, 13 July 2013 - 01:43 PM.

QUOTE (lil weasel @ Saturday, Jul 13 2013, 19:27)
Look in the PUBLIC files. (Or place the saves in the Public Files).

Which public files are we talking about here? There is a GTA San Andreas User files folder in my 'Public Documents' as well. It's for my V2 version. And if I place a save there it doesn't work. When ever I save a new game it saves it but the saves aren't placed in the userfiles folder. It must be placed somewhere else. So I'm wondering where the files are being saved so I can just place any save over there.

@0909090

That .b represents the file type. It was always there even when I wasn't having problems. If I remove the .b the file becomes unstable since I'm changing the file type.

ThatSpecialSomeone
  • ThatSpecialSomeone

  • Members
  • Joined: 14 Mar 2012
  • Slovakia

#7

Posted 13 July 2013 - 01:45 PM Edited by 0909090, 13 July 2013 - 01:49 PM.

My saves never had that ".b" thing, and they worked properly
user posted image
Everytime I add ".b" to the save, save wouldn't work. They are B File, so removing ".b" won't change file name.

lil weasel
  • lil weasel

    Shoot Looters, Hang Pirates!

  • Members
  • Joined: 25 Dec 2006
  • None
  • Contribution Award [San Andreas]

#8

Posted 13 July 2013 - 03:58 PM

0909090 that's because your file option is set to 'hide known file extension'.

shoumic try windows search for *.b (star dot b) files to see if that brings up the other location.
I was talking about the 'ALL USERS' public document files.




Shoumic
  • Shoumic

  • The Yardies
  • Joined: 09 Jul 2012
  • None
  • Best Signature 2013
    Best Signature 2012

#9

Posted 13 July 2013 - 05:08 PM

QUOTE (lil weasel @ Saturday, Jul 13 2013, 21:58)
shoumic try windows search for *.b (star dot b) files to see if that brings up the other location.
I was talking about the 'ALL USERS' public document files.

Thanks for the input guys. icon14.gif

This was actually a smart move weasel. As it will tell me where every .b file is in my PC. Well I should have a at least 2 saves since I have them saved in my game. Look at the screenshot below. I made these two saves right now by starting a new game.

user posted image

Clearly these saves are located somewhere in my Hard Drive but when I do what you suggested weasel all I get is:

user posted image


Clearly something is wrong. I think there's something wrong in the Registry. Not sure what I can do from this point. whatsthat.gif

radioman
  • radioman

    Big Homie

  • Members
  • Joined: 19 Apr 2006

#10

Posted 13 July 2013 - 07:27 PM

Do you use 98 compatibility mode? If so, your Documents folder will look like this picture, with 2 User Files folders for some reason and you have to figure out which one is the right one.

QUOTE
Actually if I add ".b" to my saves, game wouldn't register them. So I think that's the problem in Shoumic's case.


As Lil Weasal said, ALL SA Saves have the .b extension, As seen here in this screenshot.. the file extension is created automatically. Some systems may "hide" file extensions, in that case, it WILL NOT show when viewed, but it is there. IF you try to rename it with a .b extension, it will not recognize, as it is going to be read by the system as .b.b, which is incorrect. smile.gif

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#11

Posted 14 July 2013 - 06:00 AM

I don't know why San Andreas occasionally get a bug up it's bum and won't use the usual folder for saves. I've had this happen on XP, and then it mysteriously fixed itself. There was a topic for glitch but I suspect the info is too outdated to be of much use on the newer operating systems.

The two places I've found the lost saves have still been in a folder named GTA San Andreas User Files. They usually show up off the root directory of the hard disk (C:\GTA San Andreas User Files) or in the SA Program Folder.

A more specific search might help. Try looking for "gta_sa.set" (w/o quotes). See if you can make it search in hidden and system folders.

Shoumic
  • Shoumic

  • The Yardies
  • Joined: 09 Jul 2012
  • None
  • Best Signature 2013
    Best Signature 2012

#12

Posted 14 July 2013 - 01:29 PM

QUOTE (OrionSR @ Sunday, Jul 14 2013, 12:00)
or in the SA Program Folder.

This.

When I looked for *.b files in the San Andreas Directory they popped out of nowhere so I need to now place my saves in the 'Data' folder for whatever reason. I'm guessing the same applies for my V2 as well but I'll check that out later but it's good enough for me that I can load saves again. The saves should of just showed up when weasel suggested to search the entire computer for .b files.

Thanks for the help everyone. I appreciate it that you took time just to help solve a problem I had.

radioman
  • radioman

    Big Homie

  • Members
  • Joined: 19 Apr 2006

#13

Posted 14 July 2013 - 08:31 PM

To add, With Vista and 7, I think it depends on which version of Windows you have-ie. Basic, Home Premium, Pro, OR Ultimate?, as Basic and Home Premium usually keep the old Documents folder for the saves location and Pro and Ultimate tend to move them to the Install directory-except the difference with Vista is that using 98 compatibility mode moves the saves to the Public folder.

Frenzzy
  • Frenzzy

  • Members
  • Joined: 26 Jun 2013
  • None

#14

Posted 15 July 2013 - 08:01 AM

QUOTE (radioman @ Monday, Jul 15 2013, 02:01)
To add, With Vista and 7, I think it depends on which version of Windows you have-ie. Basic, Home Premium, Pro, OR Ultimate?, as Basic and Home Premium usually keep the old Documents folder for the saves location and Pro and Ultimate tend to move them to the Install directory-except the difference with Vista is that using 98 compatibility mode moves the saves to the Public folder.

I use Windows 7 ultimate 32-bit yet the saves are always stored in the user files directory.

lil weasel
  • lil weasel

    Shoot Looters, Hang Pirates!

  • Members
  • Joined: 25 Dec 2006
  • None
  • Contribution Award [San Andreas]

#15

Posted 15 July 2013 - 08:14 AM

I have Windows 7 Home Premium, and XP, both save in the Users Directory.

radioman
  • radioman

    Big Homie

  • Members
  • Joined: 19 Apr 2006

#16

Posted 15 July 2013 - 08:38 AM

QUOTE (lil weasel @ Monday, Jul 15 2013, 03:14)
I have Windows 7 Home Premium, and XP, both save in the Users Directory.

Me too, I have a Windows 7 Home Premium desktop and Windows 7 Home Premium laptop as well as an XP Pro laptop and all 3 saves are in the User Files folder. Even when I had Vista Home Premium, it still placed the saves in the User Files Folder in Documents(even though on that PC the saves(and User Files Folder) got transferred to the Public folder when I used 98 Compatibility mode for some reason?-this was only a Vista issue, as 7 simply makes a new folder in the Documents folder when 98 Compatibility mode is used(same on VC).. smile.gif

I came to that conclusion, as I have read topics on here in the past about how some people have saves that show up in the Install directory..however, I think this was mostly a Vista issue? confused.gif




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users