Quantcast

Jump to content

» «
Photo

Laggy GTA IV (High End PC)

6 replies to this topic
Skizor1337
  • Skizor1337

    Player Hater

  • Members
  • Joined: 17 Jun 2009

#1

Posted 05 July 2013 - 06:36 PM Edited by Skizor1337, 05 July 2013 - 07:19 PM.

So I have a legit copy of GTA IV.

I can run the game but for some reason its super laggy but doesnt crash.

I have the latest patch but im not sure if im missing an update or something. Oh and i just built this PC like 3 days ago so if someone could help me out i would HIGHLY appreciate it

Specs:

I7 3770

8 Gig RAM

EVGA GTX 660


No mods have been installed yet. But im damn sure its not a hardware problem. I have done research on this topic but can never find a concrete answer. I thought buying a new computer would solve the issue but no luck. Very frustrating. Any thoughts will be appreciated. I am looking to play online as well. So if i activate offline will i still be able to play online?

TehTacoGuy
  • TehTacoGuy

    Half taco, half human.

  • Members
  • Joined: 02 Nov 2011
  • Australia

#2

Posted 06 July 2013 - 11:49 AM

This is the same for me. It's not exactly laggy, but it is a little choppy.

Specs:
AMD FX™-8150 Eight-Core Processor (8 CPUs) 4.2GHz
16GB DDR3 RAM
AMD Radeon HD 7950 3GB GDDR5
Windows 7 Professional Service Pack 1

Benchmark:
Statistics
Average FPS: 59.60
Duration: 37.55 sec
CPU Usage: 33%
System memory usage: 30%
Video memory usage: 37%

Graphics Settings
Video Mode: 1920 x 1080 (60 Hz)
Texture Quality: High
Shadow Quality: Medium
Reflection Resolution: High
Water Quality: Low
Texture Filter Quality: Anisotropic x2
Night Shadows: Medium
View Distance: 50
Detail Distance: 50

Hardware
Microsoft Windows 7 Professional
Service Pack 1
Video Adapter: AMD Radeon HD 7900 Series
Video Driver version: 8.17.10.1172
Audio Adapter: Speakers (Realtek High Definition Audio)
AMD FX™-8150 Eight-Core Processor

Skizor1337
  • Skizor1337

    Player Hater

  • Members
  • Joined: 17 Jun 2009

#3

Posted 06 July 2013 - 12:12 PM Edited by Skizor1337, 06 July 2013 - 03:38 PM.

QUOTE (xXTacoGuyXx @ Saturday, Jul 6 2013, 11:49)
This is the same for me. It's not exactly laggy, but it is a little choppy.

Specs:
AMD FX™-8150 Eight-Core Processor (8 CPUs) 4.2GHz
16GB DDR3 RAM
AMD Radeon HD 7950 3GB GDDR5
Windows 7 Professional Service Pack 1

Benchmark:
Statistics
Average FPS: 59.60
Duration: 37.55 sec
CPU Usage: 33%
System memory usage: 30%
Video memory usage: 37%

Graphics Settings
Video Mode: 1920 x 1080 (60 Hz)
Texture Quality: High
Shadow Quality: Medium
Reflection Resolution: High
Water Quality: Low
Texture Filter Quality: Anisotropic x2
Night Shadows: Medium
View Distance: 50
Detail Distance: 50

Hardware
Microsoft Windows 7 Professional
Service Pack 1
Video Adapter: AMD Radeon HD 7900 Series
Video Driver version: 8.17.10.1172
Audio Adapter: Speakers (Realtek High Definition Audio)
AMD FX™-8150 Eight-Core Processor

I installed the 1.4.0 patch as everyone says its the best one. I also have the game activated offline. I just wanna be able to play online and offline. No mods have been installed. Someone please help we both have amazing computers and choppy graphics. Not cool. I have seen so many game play videos with people having computers half the speed of ours and the game runs just fine. So there is something that I am missing.


We also have about the same benchmark as well

TehTacoGuy
  • TehTacoGuy

    Half taco, half human.

  • Members
  • Joined: 02 Nov 2011
  • Australia

#4

Posted 06 July 2013 - 04:40 PM

Yes, i should add, i'm using the latest patch on mine (1.0.7.0 i believe), and with no mods.

CCPD
  • CCPD

    Boss

  • Members
  • Joined: 01 May 2006
  • None

#5

Posted 07 July 2013 - 10:13 AM

  1. Make new Notepad file.
  2. Name it "commandline" (without quotes). So the whole file should look like "commandline.txt" (without quotes).
  3. Open it and copy and paste the text below:
    CODE
    -noprecache
    -nomemrestrict
    -norestrictions

  4. You can also add the command line below.
    CODE
    -availablevidmem 2.0

    If that doesn't work, try increasing the number to one of the following.
    CODE
    -availablevidmem 3.0
    -availablevidmem 4.0
    -availablevidmem 5.0
    -availablevidmem 6.0

    etc.

  5. Save it and put it in a folder with your GTAIV.exe file.

TehTacoGuy
  • TehTacoGuy

    Half taco, half human.

  • Members
  • Joined: 02 Nov 2011
  • Australia

#6

Posted 08 July 2013 - 01:24 PM

QUOTE (CCPD @ Sunday, Jul 7 2013, 18:13)
  1. Make new Notepad file.
  2. Name it "commandline" (without quotes). So the whole file should look like "commandline.txt" (without quotes).
  3. Open it and copy and paste the text below:
    CODE
    -noprecache
    -nomemrestrict
    -norestrictions

  4. You can also add the command line below.
    CODE
    -availablevidmem 2.0

    If that doesn't work, try increasing the number to one of the following.
    CODE
    -availablevidmem 3.0
    -availablevidmem 4.0
    -availablevidmem 5.0
    -availablevidmem 6.0

    etc.

  5. Save it and put it in a folder with your GTAIV.exe file.

Thanks for this. It's much more playable, even with higher settings now. I had to use -availablevidmem 4.0. Still a little laggy here and there, but it is a bad port. Anyways, thanks again!

Skizor1337
  • Skizor1337

    Player Hater

  • Members
  • Joined: 17 Jun 2009

#7

Posted 09 July 2013 - 04:52 AM

QUOTE (CCPD @ Sunday, Jul 7 2013, 10:13)

  1. Make new Notepad file.
  2. Name it "commandline" (without quotes). So the whole file should look like "commandline.txt" (without quotes).
  3. Open it and copy and paste the text below:
    CODE
    -noprecache
    -nomemrestrict
    -norestrictions


  4. You can also add the command line below.
    CODE
    -availablevidmem 2.0

    If that doesn't work, try increasing the number to one of the following.
    CODE
    -availablevidmem 3.0
    -availablevidmem 4.0
    -availablevidmem 5.0
    -availablevidmem 6.0

    etc.


  5. Save it and put it in a folder with your GTAIV.exe file.

Hey man here are my benchmark stats from GTA IV

tistics
Average FPS: 3.37 devil.gif
Duration: 34.74 sec
CPU Usage: 45%
System memory usage: 36%
Video memory usage: 35%

Graphics Settings
Video Mode: 1680 x 1050 (59 Hz)
Texture Quality: Low
Shadow Quality: Off
Reflection Resolution: Off
Water Quality: Low
Texture Filter Quality: Anisotropic x4
Night Shadows: Off
View Distance: 25
Detail Distance: 31

Hardware
Microsoft Windows 7 Ultimate 64-Bit

Video Adapter: NVIDIA GeForce GTX 660
Video Driver version: 320.49
Audio Adapter: Speakers (Realtek High Definition Audio)
Intel® Core™ i7-3770 CPU @ 3.40GHz

File ID: Benchmark.cli




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users