Jump to content

» «

Problem deleting Lods

2 replies to this topic
  • nWo51289


  • Feroci
  • Joined: 26 Apr 2008
  • None


Posted 04 July 2013 - 10:39 PM

My plan is to delete lods to free up ids so I can add in more objects/vehicles etc. I've managed to delete all of the lods for Los Santos, which meant adding a -1 for every object in all of the stream ipls as well as deleting lods from their respective ipls and the game works perfectly with a lodless LS.

Now doing the same process for San Fierro causes the game to crash. The game will crash if I add a -1 at the end of one of the objects in SF, or delete the lod in the respective stream ipl. For some reason the process I was using to delete lods works for LS but will crash if I did the same for SF (for SF it is a single object, no matter which object I delete the lod from it will crash the game)

Below is the error I get if I put a -1 at the end of any object in SF, or if I delete the lod....or do both. Contrary to the error below, I haven't touched any collision file in gta3.img.

GTA:SA Crashed, Debug Info Follows:

GTA Info:

Version: US 1.0

Last File Loaded: DATA\MAPS\SF\SFe.IPL

Last Library Loaded:

Error: Failure loading collision file

Assembly Info:

Exception At Address: 0x00534134

Exception Code: 0xc0000005 (EXCEPTION_ACCESS_VIOLATION)


EAX: 0x00000000 EBX: 0x000001AA

ECX: 0x00ACE694 EDX: 0x1095E710

ESI: 0x1095E710 EDI: 0x00000000

EBP: 0x6B412DC0 ESP: 0x0028FCBC

Thanks for reading.

  • ZAZ


  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]


Posted 05 July 2013 - 09:56 AM

readd the crackfactory lod because it's used in main.scm
needs new link numbers

  • nWo51289


  • Feroci
  • Joined: 26 Apr 2008
  • None


Posted 26 July 2013 - 06:30 AM Edited by nWo51289, 25 January 2014 - 03:24 PM.

Thanks for the reply. I should have mentioned I'm using the main.scm file that comes with SA Map Cleaner and I think (I checked through it months ago) it doesn't have any of those objects used in it.


**EDIT** 25-1-2014

- Deleting lods via MEd doesn't delete ALL of the lods. You'll have to go through the ipls and delete every line that has a LOD in it including binary ipls.

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users