Quantcast

Jump to content

» «
Photo

Hotkey Issues

11 replies to this topic
breakfestbacon
  • breakfestbacon

    Player Hater

  • Members
  • Joined: 07 Jun 2013

#1

Posted 07 June 2013 - 11:25 PM

Hey, Im new here. But I could not find anyone with the same issue as me so I came here ask if anyone can help me.
For all script mods I've tried, mostly the Simple Native Trainer, I have key issues. My problem is that with most keys I have to hold down the button. For example, the menu keys (8-up 2-Down 4-right 6-left 5-enter) I can scroll up and down without issues, but when I try to select something, I have to hold it down for a second or sometimes instantly or after more than 1 second. scrolling through menus with 8,2,4,6 has no problems, but changing somthing with 8,2,4,6 i have a problem with. Also hotkeys such as [ to enable Never Wanted, I must hold down.

If ANYONE could help me with this problem, I would be appriciate it a lot.

Thank you.

julionib
  • julionib

    Coder

  • Feroci
  • Joined: 13 Sep 2012
  • Brazil

#2

Posted 07 June 2013 - 11:38 PM

i "created" this issue one time with the first version of Air Combat IV script, the behavior was related to too much key press checks in the script tick.

so, maybe you have one script doing this with you, what you can do is remove the scripts and leave only native trainer, then test the menu and see if the bug disappears, then you can add one script by one and test each one to see who is causing, maybe its the result of too much scripts running and checking keys too

obs.: i fixed this issue in AC-IV last version

breakfestbacon
  • breakfestbacon

    Player Hater

  • Members
  • Joined: 07 Jun 2013

#3

Posted 08 June 2013 - 12:17 AM

Hey, thanks for replying. But that didn't work, I currently deleted all mods except the trainer. But the problem persists

pedro2555
  • pedro2555

    Open Sourcer

  • Members
  • Joined: 02 Sep 2012
  • Portugal

#4

Posted 08 June 2013 - 04:57 AM

I think simle native trainer has a parameter for how long you need to press the keys, check the configs files.

breakfestbacon
  • breakfestbacon

    Player Hater

  • Members
  • Joined: 07 Jun 2013

#5

Posted 08 June 2013 - 08:54 AM

I don't have to hold the button down for all hotkeys. for some it is instant

breakfestbacon
  • breakfestbacon

    Player Hater

  • Members
  • Joined: 07 Jun 2013

#6

Posted 09 June 2013 - 11:43 PM

Anybody have any other ideas? I would really like to fix this.
PS
I did a fresh install on my laptop and it works perfectly. I uninstalled and re-installed on my desktop, and It didn't work.
Any Ideas?

julionib
  • julionib

    Coder

  • Feroci
  • Joined: 13 Sep 2012
  • Brazil

#7

Posted 10 June 2013 - 01:35 AM

thats odd man, you can switch the key that Enter the chosen item on menu? if you can, try another key to test, not an numpad key

breakfestbacon
  • breakfestbacon

    Player Hater

  • Members
  • Joined: 07 Jun 2013

#8

Posted 10 June 2013 - 01:45 AM Edited by breakfestbacon, 10 June 2013 - 01:49 AM.

I did, I tried for example the ";:" key which enables unlimited ammo, "[{' which enables never wanted, "del" which increases wanted level, and "]}" which is super car speedup. but "r" which is super speed up, backwards works every time.
Also any ctrl/alt+(enterkeyhere) works instantly.

Nevitro
  • Nevitro

    Modder

  • Members
  • Joined: 31 Mar 2009

#9

Posted 10 June 2013 - 10:46 AM Edited by Nevitro, 10 June 2013 - 11:48 AM.

ScrollTime=82 //Scroll time for menu in milliseconds


In my computer on default i just can't do anything, because menu was faster than my reaction ... I musted to set 82 - for me, perfectly.

pedro2555
  • pedro2555

    Open Sourcer

  • Members
  • Joined: 02 Sep 2012
  • Portugal

#10

Posted 10 June 2013 - 02:27 PM

have you tried a different keyboard ? just to make sure

pedro2555
  • pedro2555

    Open Sourcer

  • Members
  • Joined: 02 Sep 2012
  • Portugal

#11

Posted 10 June 2013 - 02:36 PM

QUOTE (Nevitro @ Monday, Jun 10 2013, 10:46)
ScrollTime=82 //Scroll time for menu in milliseconds


In my computer on default i just can't do anything, because menu was faster than my reaction ... I musted to set 82 - for me, perfectly.

that's the setting I was talking about

PacketOVerload_x64Bit
  • PacketOVerload_x64Bit

    Window Licker 4 Blondes

  • Members
  • Joined: 13 Mar 2010
  • Canada

#12

Posted 10 June 2013 - 06:33 PM

QUOTE (breakfestbacon @ Friday, Jun 7 2013, 16:25)
Hey, Im new here. But I could not find anyone with the same issue as me so I came here ask if anyone can help me.
For all script mods I've tried, mostly the Simple Native Trainer, I have key issues. My problem is that with most keys I have to hold down the button. For example, the menu keys (8-up 2-Down 4-right 6-left 5-enter) I can scroll up and down without issues, but when I try to select something, I have to hold it down for a second or sometimes instantly or after more than 1 second. scrolling through menus with 8,2,4,6 has no problems, but changing somthing with 8,2,4,6 i have a problem with. Also hotkeys such as [ to enable Never Wanted, I must hold down.

If ANYONE could help me with this problem, I would be appriciate it a lot.

Thank you.

Wrong scripthookdotnet.dll or scripthook.asi files in use with the trainer. I have had the same problem. Try a different scripthook or an older or newer version of the trainer which vice versa of the version you are using.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users