Quantcast

Jump to content

» «
Photo

Having issues with graphics.

11 replies to this topic
James2986
  • James2986

    Player Hater

  • Members
  • Joined: 16 May 2013

#1

Posted 16 May 2013 - 03:29 AM

So, i'm running a AMD Radeon HD 7850, 12GB of RAM, Intel Core i7 CPU, 950 @ 3.07GHz, 64bit OS. I should be able to run GTA IV with no problem whatsoever. However, i'm running it on 20 fps when moving at all. Here's a screenshot of my video settings. http://imgur.com/e7dGxHv . As you can see, i should be able to run this game at 60 FPS with no issue whatsoever. I've updated my 7850 to the latest drivers, yet nothing is changed. Any help would be greatly appreciated. I've spent 20$ on this game, and i'd like to be able to play it.

Brainsick
  • Brainsick

    Peon

  • Members
  • Joined: 10 Sep 2011

#2

Posted 16 May 2013 - 04:16 AM

Constant 60fps on this game is an unrealistic expectation unless we're talking about bare-minimum settings, I can tell you from experience I cannot achieve it either on my 680, 2500k @4.5ghz, the game is just ridiculously unoptimized, HOWEVER, 20 fps on those settings is just not normal; Something's up.

T-ru
  • T-ru

    kamikadze

  • Members
  • Joined: 02 Sep 2009

#3

Posted 16 May 2013 - 04:44 AM

There is a some rules and programs if you want smooth gameplay from this poorly optimazed game:

Update the games to the last patch 1.0.7.0 IV and 1.1.2.0 EFLC

Read about memrestrict command from Here.

You have ati card so you should mandatory to disable Catalyst A.I. from catalyst control center , about this game.

Clean up your windows registry.

Programs that you must have:
Updated GFWL (Games for windows Live).
Net Framework 4.5.
Microsoft visual C++ 2005, 2008, 2010, 2012 (You must install all of them!!!)
Updated DirectX.

You can find them easy from Google.

If you do all this things, I'm sure that you'll get the smooth gameplay.


jpm1
  • jpm1

    Vice city citizen

  • Members
  • Joined: 26 Sep 2005
  • None

#4

Posted 16 May 2013 - 05:48 PM

check your screen refresh rate is same than game one
turn auto-save and auto recording off . shadows and traffic density are huge fps eaters

cp1dell
  • cp1dell

    Ghetto Star

  • Members
  • Joined: 04 Jul 2008

#5

Posted 16 May 2013 - 06:51 PM

I've got an Intel i5-2310 @ 2.9Ghz, an AMD HD Radeon 6850 (which is basically like yours it terms of performance, but the 6 series) and 8GB of RAM. I made this post in another thread, you should try it out. I'm running the game on Max settings. Make sure you're using 1.0.7.0.
QUOTE (cp1dell @ Sunday, May 12 2013, 00:31)
Well I was just on Reddit earlier in a GTA IV topic, and the topic of optimization got brought up. Naturally I had to investigate because it's my goal to get this game running like it should. I finally got the game to run better thanks to the user Negaflux.

As you know GTA IV is a very CPU intensive game, and most people tend to have a graphics card specifically for games. Oddly enough, by jacking up your settings a bit you can offload some of game to your GPU instead of most of it being piled onto the CPU. It also helps to use the launch commands:
CODE
-norestrictions -noprecache -novblank -nomemrestrict -percentvidmem 100


QUOTE
Currently I run a AMD Phenom II Quad Core at 3.4ghz (tho any decent quad core that's above 3-3.2ghz should be be fine), 12 gb of ram (tho 4-8 is still plenty.. and I'd lean closer to at least 6-8 myself) and a Geforce 660Ti (tho I ran it fine with an AMD 5850 & 6870 previously as well).
The reason for those launch commands is due to how the game is coded. Since it was made for consoles, which at the time had pretty weak video cards, a lot of the processing was done on the CPU, and it's one of the reasons why GTA4 is such a CPU hog. It's also pretty conservative on your memory as well, something the current gen consoles are rather lacking in.
-norestrictions -noprecache -novblank -nomemrestrict -percentvidmem 100
These commands basically takes off the kiddy/safety gloves. It basically tells the game to quit acting like it's still restrained by a console with limited resources. norestrictions essentially enables the other options, no precache (preloading and storing stuff in buffer instead of closer to real time) novblank (don't empty the video buffer inbetween every frame) nomemrestict (don't limit the amount of ram you utilize) percentvideomemory100 (access all video memory - since on a pc, typically memory isn't shared)
Keep in mind I was also able to run this game back in the days on my laptop which was a Core 2 Duo at 1.8ghz and a geforce 8600GS (dx9 mobile card) and about 2 gigs of ram. It didn't run spectacularly but it did run... and as it was my only functioning computer at the time I put up with it because I enjoyed the game, but I'd definitely recommend something better if you can help it.


It's also recommended that you downgrade to 1.0.4.0, you can easily find instructions on how to do so here. Most of you probably have already considering that it's easier to mod.

This is a hit or miss, but you may also gain some performance (along with a less gray GTA IV, and depending on your settings, some nice effects) using this ENB mod.

My specs are:
Intel i5-2310 @ 2.9Ghz
AMD Radeon HD 6850
8GB RAM

The only mods I use are HD Trees, an edited Timecyc that extends the distance or whatever to I think 1500.00, More Liberty, an edited bloodfx that adds squirting blood to every gunshot just like in the newer Rockstar games, and an edited visualsettings and ragepostfx files that removes the blur and only leave the DOF and motion blur.

I used to be able to play the game with these settings and get a stable framerate of 30FPS. With the motion blur it looks great, and on the very rare occasion that it dips a teeny bit, it's barely noticeable.

But now, I can run that game on practically Very High settings, with the same performance. I still don't use Night Shadows considering it creates a lot of dynamic lights and shadows, which can cost a lot of performance. But the benefit of downgrading to 1.0.4.0 allows you to adjust how many dynamic lights and shadows there are at a time (which at 1 will just be Niko).

I have not downgraded yet to see what performance boosts I get, but when I do I will update you guys. But seriously, this worked out pretty well and it's great to be able to run the game a bit better.

If for whatever reason this doesn't help, try downgrading to 1.0.4.0. You won't have amazing quality, but the performance is great. If you want you can try that ENB Mod mentioned in the quoted post above, that's if you downgrade to 1.0.4.0 in case 1.0.7.0 doesn't work out doing what I described.

unc13bud
  • unc13bud

    Die Hoodrat DIE!!!

  • Members
  • Joined: 05 Dec 2010

#6

Posted 17 May 2013 - 03:26 PM

what is your power supply and case? how many case fans do you have?

nigelhere9901
  • nigelhere9901

    Gangsta

  • Members
  • Joined: 02 Feb 2013

#7

Posted 19 May 2013 - 08:54 PM

Turn Off V-Sync.

SlaveZer0
  • SlaveZer0

    Perveyor of Destruction

  • Members
  • Joined: 05 Aug 2011
  • United-States

#8

Posted 21 May 2013 - 02:07 AM

leave vsync alone!!! turn off catalyst AI.... it will make a world of difference, this game doesnt like radeon cards too much

unc13bud
  • unc13bud

    Die Hoodrat DIE!!!

  • Members
  • Joined: 05 Dec 2010

#9

Posted 21 May 2013 - 03:08 AM

on all my vista and w7/w8 installations, i bump up the THEME appearance settings to maximum. somebody posted it back when i was using my q6600 machine and it did seem to make a difference.

nigelhere9901
  • nigelhere9901

    Gangsta

  • Members
  • Joined: 02 Feb 2013

#10

Posted 24 May 2013 - 08:10 PM

QUOTE (SlaveZer0 @ Tuesday, May 21 2013, 02:07)
leave vsync alone!!! turn off catalyst AI.... it will make a world of difference, this game doesnt like radeon cards too much

Turning off V-Sync makes a HUGE difference.

radioman
  • radioman

    Big Homie

  • Members
  • Joined: 19 Apr 2006

#11

Posted 24 May 2013 - 09:11 PM

Lower the Resolution...it makes a huge difference in fps..lowering it to say 1024X768 will get way more fps than maxed out fps..

SlaveZer0
  • SlaveZer0

    Perveyor of Destruction

  • Members
  • Joined: 05 Aug 2011
  • United-States

#12

Posted 25 May 2013 - 12:22 PM

QUOTE (radioman @ Friday, May 24 2013, 21:11)
Lower the Resolution...it makes a huge difference in fps..lowering it to say 1024X768 will get way more fps than maxed out fps..

he shouldnt have to lower the resolution... please OP just try disabling catalyst ai.... turning of vsync leads to visual tearing when you swing the camera around.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users