Quantcast

Jump to content

» «
Photo

[already solved] Checkpoint Charlie-related bug

No replies to this topic
fluffyheretic
  • fluffyheretic

    Player Hater

  • Members
  • Joined: 02 Mar 2013

#1

Posted 20 April 2013 - 02:24 AM Edited by fluffyheretic, 20 April 2013 - 02:28 AM.

Making a new topic since I didn't see anything resembling what I experienced in the pinned buglist.

So I get an itch to do some joyriding in one of my speedboats over at the Boatyard. Important at this point for me to state that I always play with the frame limiter turned OFF (except when the game locks into the Unique Jump slowmo-camera and won't come out of it, then I'll toggle it just to get the camera loose; however it USUALLY comes out of the slowmo on its own, eventually). First I get in the Jetmax, which of course starts the Checkpoint Charlie mission. Then I immediately decide I'd rather take out the Squalo even if I'm ignoring the mission (but I do always have more time left on the clock when I do the mission with the Squalo whereas I can only barely complete it with the Jetmax, even though the Jetmax is allegedly the faster boat. dontgetit.gif ). I try to end the mission with the R3 function but of course that doesn't work, so I just exit the boat and go get in the Squalo.

However, here's the thing: the mission didn't end when I exited the Jetmax. I think nothing of it and set off, but I quickly start noticing something off with my camera where it's acting glitchy in the same way the Unique Jump cam often does. I try toggling the camera view and this helps jar it loose for every cam view but the default one, which is still stuck.

No big deal I think, maybe it'll fix itself when I restart the game, and soon after that I go save in my only save slot. Big mistake. When I reload the game later I start noticing cars freezing in place everywhere. I realize that the timer up in the corner is actually freezing when it happens. Not only that, but any time I use the Pay N' Spray the door stays closed for something like 5+ seconds. At some point I wonder if this has something to do with the Checkpoint Charlie phenomenon and go try to start that mission again. When I get in the boat, not only does the mission NOT start, but the camera stays frozen to my position on the dock before getting in. In addition, when I cast off I experienced the same camera issues as before.

Eventually it occurs to me to try toggling the frame limiter, and sure enough this fixes all the issues. Camera works, starting the Checkpoint Charlie mission works, timer doesn't stick and cars don't freeze. When I toggled it back off the issues returned. I tried resaving my game with the limiter turned on, but the issues still persisted upon loading. I could have kept playing the savefile like that, but if I wanted to play the game at 24fps (or whatever the framerate is) I'd play it on console.

I was pretty upset about all of this until I remembered that I had made a copy of my savefile only a couple of days prior. Copied it over and all was well again; crisis averted! All I lost was some garaged cars and money; no big deal.

So in summary, the 'solution' that I found to this issue was just to have a backup save, to keep backing it up regularly (or use multiple saveslots), and probably most importantly, to be very, very careful about screwing around with the boats at the Boatyard. lol.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users