Quantcast

Jump to content

» «
Photo

San Andreas stops

4 replies to this topic
smp-co
  • smp-co

    Player Hater

  • Members
  • Joined: 31 Mar 2013

#1

Posted 31 March 2013 - 07:42 PM

I had make a mod for sa. Starting the vgame is no problem, but when i come near the map, the game crashed and the limit adjouster shows me that advertisement:

GTA:SA Crashed, Debug Info Follows:



GTA Info:



Version: US 1.0

Last File Loaded: AUDIO\STREAMS\CR

Last Library Loaded:

Error: Unknown



Assembly Info:



Exception At Address: 0x00533606

Exception Code: 0xc0000005 (EXCEPTION_ACCESS_VIOLATION)



Registers:

EAX: 0x00000000 EBX: 0x0000005B

ECX: 0x01D6C430 EDX: 0x0B8E4C38

ESI: 0x00B8B0E0 EDI: 0x0000003B

EBP: 0x0BB669A8 ESP: 0x0028FC80





Does anyone knows why the game crash, when i come near the map?

fastman92
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009

#2

Posted 31 March 2013 - 07:57 PM Edited by fastman92, 31 March 2013 - 07:59 PM.

1. Comment this section
CODE
[MODELS]
# Models the game uses internally
; New models need to be loaded via the SCM before use
#CopCar 1=599
#CopCar 2=596
#CopCar 3=597
#CopCar 4=598
#CopCar 5=523
#CopPed 1=283
#CopPed 2=280
#CopPed 3=281
#CopPed 4=282
#CopPed 5=284
#Ambulance 1=416
#Ambulance 2=416
#Ambulance 3=416
#Medic 1=274
#Medic 2=276
#Medic 3=275
#Firetruck 1=407
#Firetruck 2=407
#Firetruck 3=407
#Fireman 1=277
#Fireman 2=279
#Fireman 3=278
#TaxiDriver 1=262
#TaxiDriver 2=261
#TaxiDriver 3=220
#TaxiDriver 4=234
#TaxiDriver 5=182
#TaxiDriver 6=206
#Enforcer Replacement=427
#SWAT Ped Replacement=285
#FBI Rancher Replacement=427
#FBI Ped Replacement=286
#Rhino Replacement=432
#Barracks Replacement=433
#Army Ped Replacement=287
#Police Maverick Replacement=497
#SAN Maverick Replacement=488
#Police Weapon 1=3
#Police Weapon 2=22
#SWAT Weapon=28
#FBI Weapon=29
#Army Weapon=31
; Siren Positions
#Siren 1=0.6999999881
#Siren 2=-0.1000000015
#Siren 3=1.200000048
#Siren 4=-0.6999999881
#Siren 5=-0.400000006
#Siren 6=1.0
#Siren 7=0.5500000119
#Siren 8=1.100000024
#Siren 9=1.399999976
#Siren 10=-0.5500000119
#Siren 11=0.6000000238
#Siren 12=0.8999999762
#Siren 13=-0.6000000238
#Siren 14=3.200000048
#Siren 15=1.299999952
#Siren 16=-0.8999999762
#Siren 17=0.9499999881
#Siren 18=0.8500000238
#Siren 19=1.200000048
#Siren 20=0.5

There's no guarantee that doing this step will solve a problem.

2. Disable CLEO, see if crash happens again.
If not: enable CLEO.
Use the divide and conquer technique - remove half of scripts, leave half. You'll know which half of scripts crashes a game. Later you'll narrow to the smaller half (half of half) of CLEO scripts. The complexity of this task is logarithmic.

smp-co
  • smp-co

    Player Hater

  • Members
  • Joined: 31 Mar 2013

#3

Posted 31 March 2013 - 08:28 PM

I have not Cleo installed never on this game. I had copy the things to the game, but now the limit adjouster shows this:

GTA:SA Crashed, Debug Info Follows:



GTA Info:



Version: US 1.0

Last File Loaded: gta_sa.set

Last Library Loaded:

Error: Unknown



Assembly Info:



Exception At Address: 0x42480000

Exception Code: 0xc0000005 (EXCEPTION_ACCESS_VIOLATION)



Registers:

EAX: 0x00863C40 EBX: 0x00000000

ECX: 0x0B9F4728 EDX: 0x00000BCF

ESI: 0x0B9F4728 EDI: 0x0B7CFD70

EBP: 0x00B87154 ESP: 0x0028FDA8



sad.gif


fastman92
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009

#4

Posted 31 March 2013 - 08:33 PM

When it shows? Can't you write clearly?

smp-co
  • smp-co

    Player Hater

  • Members
  • Joined: 31 Mar 2013

#5

Posted 01 April 2013 - 06:14 PM

Okay biggrin.gif I start the game normally.. all is ok no crash or something like this - then when i fly to my map with a helicopter or drive to the map, the game is black and crash. The sound i going on.
After I stop the game with the task manager of windows, i look at the errordump file, which is saved in the GTA San Andreas Directory. There I found the Informations i copyd here.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users