Quantcast

Jump to content

» «
Photo

GTA 3 Loads black screen on startup

10 replies to this topic
Manirule123
  • Manirule123

    Player Hater

  • Members
  • Joined: 01 Jan 2012

#1

Posted 26 February 2013 - 07:42 PM

Hello. I just got GTA 3 and unfourtanatly, there is a problem. When I run GTA3.exe, it loads a black screen with my mouse loading icon. I really need to fix this! sad.gif Im at Windows 7. Please provide a solution. I'm pretty sure I can run gta 3 on my pc

SPECS:

OS: Windows 7 Ultimate 32 bit

Processor: Intel Pentuim 4 3.4GHz

RAM: 3.25 gb

Display Adapter: Intel 82945g Express Chipset Family

Thanks!

MrMateczko
  • MrMateczko

    Simply divine!

  • Members
  • Joined: 10 Dec 2011
  • Poland

#2

Posted 26 February 2013 - 07:46 PM

Do you own a legal copy of the game?

GTAKid667
  • GTAKid667

    The Bad Fella™

  • Leone Family Mafia
  • Joined: 24 May 2010
  • United-Kingdom

#3

Posted 26 February 2013 - 08:06 PM

Have you tried running it in Compatibility mode?

Also you should be posting it in the Troubleshooting Section

Manirule123
  • Manirule123

    Player Hater

  • Members
  • Joined: 01 Jan 2012

#4

Posted 26 February 2013 - 09:11 PM

Yes, I do have a legal copy and yes, I did try running in Windows XP Service Pack 2 mode

miromiro
  • miromiro

    Time Killa™

  • Zaibatsu
  • Joined: 26 Nov 2009
  • None

#5

Posted 26 February 2013 - 09:17 PM

Are you using any mods? Have you tried removing the gta3.set file located in the GTA3 User Files folder? What about trying to run the game as administrator? You could also try to do a re-install of the game.

You might actually be having this problem, so maybe the following quote helps.

QUOTE
Problem #11:
GTAIII will not run after installation - instead, when clicking the icon to start, the Play CD spins and the pointer icon turns into a spinning-CD symbol, but the game never starts. (And the pointer may not go back to normal until restarting Windows.)

Solution: End all running non-essential processes - whether it be an anti-virus, Window Blinds, whatever. This fix has also been reported to work by closing Folding@Home and a startup program called "BigFix".

Alternatively: If you notice a new piece of hardware called "secdrv" attempting to install itself, Windows may be mistaking some software for hardware. Go to Device Manager and look for a big yellow question mark (indicating hardware with no driver). If one stands next to "secdrv", delete it.

Alternatively: Set the compatibility mode of the executable file to 'Windows 98'. Do so by: right-clicking gta3.exe (default: C:\Program Files\Rockstar Games\GTAIII\gta3.exe) -> Properties -> Compatibility tab -> check 'Run this program in compatibility mode for:', and select 'Windows 98 / Windows Me' from the drop-down menu. Apply, OK. And as pictures speak a thousand words, click here.

Alternatively: Instead of the original EXE, use a no CD crack. Note that providing links to any such cracks is strictly prohibited here at GTAForums.com.


Good luck. icon14.gif

Manirule123
  • Manirule123

    Player Hater

  • Members
  • Joined: 01 Jan 2012

#6

Posted 26 February 2013 - 09:23 PM

Yes I modded it and tried running it, it worked for about a week but now running as admin doesn't work ether. Re installed but still on the black screen. I removed the .set file and still sad.gif

miromiro
  • miromiro

    Time Killa™

  • Zaibatsu
  • Joined: 26 Nov 2009
  • None

#7

Posted 26 February 2013 - 09:25 PM

I suggest you get rid of the mods then. Most probably those are causing it. Try to completely delete them, then remove the gta3.set file and in case it still doesn't work, completely un-install GTA III and re-install it. Mods can cause all kind of strange bugs.

Manirule123
  • Manirule123

    Player Hater

  • Members
  • Joined: 01 Jan 2012

#8

Posted 26 February 2013 - 09:34 PM

Ill try to re install it one more time. I hope it works. I'll keep you updated. Thanks (I will reply on progress if it worked or not)

Filip454
  • Filip454

    TITS OR GTFO

  • Members
  • Joined: 19 Aug 2009
  • None

#9

Posted 26 February 2013 - 10:09 PM

Check your PM

Manirule123
  • Manirule123

    Player Hater

  • Members
  • Joined: 01 Jan 2012

#10

Posted 26 February 2013 - 10:47 PM

Thanks, check you PM. I replied

Filip454
  • Filip454

    TITS OR GTFO

  • Members
  • Joined: 19 Aug 2009
  • None

#11

Posted 27 February 2013 - 10:04 PM

Reinstall then.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users