Quantcast

Jump to content

» «
Photo

delete all LOD models

3 replies to this topic
zaauriel
  • zaauriel

    Player Hater

  • Members
  • Joined: 25 Apr 2011

#1

Posted 24 February 2013 - 06:00 PM

hi

Im tunning San Andreas so i can play without lag in an old Netbook.

Im using SAMP_FPS_Lag_Fix_Pack_v1_0 with some stuff that removes particles, lower texture resolution and gives me a extreme low draw distance.

The draw distance is so low in fact that i never see any LOD anymore.

Can i safely delete those models from the gta.img?

I will like to do that because i also need to reduce the San Andreas installation file size (small HDD)

Thanks

ZAZ
  • ZAZ

    Kernlochbohrer

  • Members
  • Joined: 10 Jan 2005
  • European-Union

#2

Posted 24 February 2013 - 07:04 PM

QUOTE (zaauriel @ Sunday, Feb 24 2013, 19:00)
hi

Im tunning San Andreas so i can play without lag in an old Netbook.

Im using SAMP_FPS_Lag_Fix_Pack_v1_0 with some stuff that removes particles, lower texture resolution and gives me a extreme low draw distance.

The draw distance is so low in fact that i never see any LOD anymore.

Can i safely delete those models from the gta.img?

I will like to do that because i also need to reduce the San Andreas installation file size (small HDD)

Thanks

No
1. you don't need to delete the models but the item placements
2. the item placements of LOD models have connections to the item placements of the base model
so the game crashes if you delete the item placements of LOD models as well if you delete the models

it needs to edit a lot of ipl files for your plan, especially stream ipl files
there you must remove the LOD connection
then you must delete the the item placements of the LOD models
then you can also delete the models

zaauriel
  • zaauriel

    Player Hater

  • Members
  • Joined: 25 Apr 2011

#3

Posted 24 February 2013 - 09:00 PM

lol, sounds like a lot of work indeed, more so if i do it in this tiny netbook.

Anyone knows of a cleo script to prevent lod loading? is that even possible?

And Thanks for the quick answer ZAZ

X-Seti
  • X-Seti

    Retro modding.

  • Feroci Racing
  • Joined: 28 Jun 2005
  • Mars

#4

Posted 25 February 2013 - 02:14 PM

Changing the IDE values.

This trick works on the VC engine and should work on SA, I use this because I just want the collisions to be felt and not the object to be seen.

Where you see for example 12000, townHous12, sometexture, 1700, 1

Simply change all the LOD lines to resemble 12000, townHous12, sometexture, 0.1, 1

1700 is set on most LOD's for the distance the object can be seen from the objects center pivot. changing this to 0.1 or 0.01 would mean that some and maybe not all LODs would not spawn. because it would be hard to see 0.1 and almost impossible to see 0.01 even when your stand right by the object.







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users