Quantcast

Jump to content

» «
Photo

[III/VC] Vehicle Camera Movement

43 replies to this topic
ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#1

Posted 11 October 2012 - 09:32 PM Edited by ThirteenAG, 20 October 2012 - 10:26 AM.

Well, i've finally fixed car twitching in gta 3, and version 1.0 of this mod was uploaded to gtagarage.
Fresh screens:
user posted image user posted image user posted image user posted image


Installation: Paste VehCameraMovement.cs to CLEO folder in GTA 3/VC directory.
Important note, gta3: If your game became slow, you should install Cleo Frame Limit Adjuster.

Controls:
Free camera activates when player in car(since v1.2 as a replacement of a furthest external view). When you using look left/right/behind and turret control buttons free camera will be temporary disabled.
In the helicopter, to activate free camera you need to hold the horn key.

Game version support:
gta3.exe/gta_vc.exe v. 1.0 and 1.1 are supported. I tested it with Snow City, Gang Wars and original game and didn't notice any issues. gta_vc.exe v. 1.1 was never tested, but i think it should work.

Changelog:
v1.1: fixed standart crosshair appearing in the middle of the screen.
v1.2: Free camera is now replacing default furthest external view camera mode(which means you can switch between other cameras). RC mode was also fixed.
  • SanAndreasIsTheGame likes this

LINK/2012
  • LINK/2012

    LIVIN' IN CODE

  • Feroci Racing
  • Joined: 30 Jan 2011
  • Brazil

#2

Posted 12 October 2012 - 02:19 AM

An, this enables you to control the camera with a mouse? If not, any possibility?

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#3

Posted 12 October 2012 - 03:14 AM

QUOTE (Link2012 @ Friday, Oct 12 2012, 02:19)
An, this enables you to control the camera with a mouse? If not, any possibility?

Yep.

LINK/2012
  • LINK/2012

    LIVIN' IN CODE

  • Feroci Racing
  • Joined: 30 Jan 2011
  • Brazil

#4

Posted 15 October 2012 - 07:54 PM

Tested, works well, but it seems more like IV camera than SA camera, and I like SA camera!!!!! (Not a critic at all tounge.gif )

Can you make a version for the player?
Hate that static camera from III\VC

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#5

Posted 15 October 2012 - 09:23 PM

QUOTE (Link2012 @ Monday, Oct 15 2012, 19:54)
Tested, works well, but it seems more like IV camera than SA camera, and I like SA camera!!!!! (Not a critic at all tounge.gif )

Can you make a version for the player?
Hate that static camera from III\VC

Well, i think IV camera is pretty cool, so... sigh.gif
I'm not sure about player camera, don't have any ideas how can i start. But manual aiming and SA-styled player cam would be awesome.

GamerShotgun
  • GamerShotgun

    The main protagonist.

  • Members
  • Joined: 03 Oct 2005

#6

Posted 24 November 2012 - 10:34 PM

Hey, this is a really nice mod, but is there a way to make the free camera restore to it's original position after the mouse not being touched for a given time? Like in San Andreas. smile.gif

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#7

Posted 24 November 2012 - 11:12 PM

QUOTE (MasterK @ Saturday, Nov 24 2012, 22:34)
Hey, this is a really nice mod, but is there a way to make the free camera restore to it's original position after the mouse not being touched for a given time? Like in San Andreas. smile.gif

I tried to make that, but i didn't like how it was in game. Maybe later i will do it.

VERSA
  • VERSA

    Flying Ped in Space

  • Members
  • Joined: 01 Aug 2012
  • None

#8

Posted 08 December 2012 - 03:31 AM

It's a really great mod I like it very much happy.gif But can you move camera to the center of the screen like in SA? IV style make no sense, because you cannot shoot from the car like in IV. Please make it like in SA, pleeeease cookie.gif cookie.gif cookie.gif

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#9

Posted 08 December 2012 - 12:00 PM

QUOTE (Sooner @ Saturday, Dec 8 2012, 03:31)
It's a really great mod I like it very much happy.gif But can you move camera to the center of the screen like in SA? IV style make no sense, because you cannot shoot from the car like in IV. Please make it like in SA, pleeeease cookie.gif cookie.gif cookie.gif

I don't, that's why i include the source code. Find
CODE
//distances

if or
8@ == 32
8@ == 40
then
05DF: write_memory 0x68ACAC size 4 value 1.5 virtual_protect 0
05DF: write_memory 0x68AC9C size 4 value 6.0 virtual_protect 0
else
05DF: write_memory 0x68ACAC size 4 value 3.0 virtual_protect 0
05DF: write_memory 0x68AC9C size 4 value 9.0 virtual_protect 0
end

And try to change this numbers.

VERSA
  • VERSA

    Flying Ped in Space

  • Members
  • Joined: 01 Aug 2012
  • None

#10

Posted 08 December 2012 - 12:51 PM

Well, okay, but unfortunately I have no idea what to do with this, cause I've never edited anything like this before. I'm more into graphical part of modding confused.gif

BLlTZ
  • BLlTZ

    Typical behaviour for someone with your condition.

  • Members
  • Joined: 04 Apr 2008
  • None

#11

Posted 06 January 2013 - 01:14 PM

This is a fenomenal work. You have a [manly] kiss from me for what you have done here blush.gif The camera distance and angle is magnificant with his very own unique feeling, nothing similar to SA.

I have no idea why for others are runing slow, but I no problem with that like heavily FPS drops, only maybe for very old PC.

I love using it and I feel so free from the cages of horror that R* did here for not having such option available. I even drive better. Only good words I can put there for you. Thank you good sir. cookie.gif icon14.gif

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#12

Posted 06 January 2013 - 02:11 PM

Well, i have this slow motion problem too, i think enb causing it. I tried to find another way to fix car twitching, but unfortunately i didn't. Very strange issue.

JustRob
  • JustRob

    Mack Pimp

  • Members
  • Joined: 25 Jul 2008

#13

Posted 08 January 2013 - 09:54 AM

Man, I have been waiting FOREVER for this. Once you're used to GTA SA's camera control, the camera in GTAIII / VC just feels awkward, not to mention you can never see what's around the corner etc.

Definitely gonna try this out today, thank you biggrin.gif

BLlTZ
  • BLlTZ

    Typical behaviour for someone with your condition.

  • Members
  • Joined: 04 Apr 2008
  • None

#14

Posted 10 January 2013 - 04:02 PM

QUOTE (ThirteenAG @ Sunday, Jan 6 2013, 16:11)
Well, i have this slow motion problem too, i think enb causing it. I tried to find another way to fix car twitching, but unfortunately i didn't. Very strange issue.

The config is the main problem. Is set to default of maxium settings. Also, while I drive with ENB, the entire game slowdowns like playing Max Payne x3 slower, not fps drops. confused.gif

Doesn't matter for me, cuz I don't use ENB to such classic game. It may look good, but it doesn't give me enough interest to play with. Maybe lowering the settings will make run better.

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#15

Posted 10 January 2013 - 04:28 PM

QUOTE (-BLITZ- @ Thursday, Jan 10 2013, 20:02)
QUOTE (ThirteenAG @ Sunday, Jan 6 2013, 16:11)
Well, i have this slow motion problem too, i think enb causing it. I tried to find another way to fix car twitching, but unfortunately i didn't. Very strange issue.

The config is the main problem. Is set to default of maxium settings. Also, while I drive with ENB, the entire game slowdowns like playing Max Payne x3 slower, not fps drops. confused.gif

Doesn't matter for me, cuz I don't use ENB to such classic game. It may look good, but it doesn't give me enough interest to play with. Maybe lowering the settings will make run better.

I figured realtime reflections causing this 100%. Maybe some other settings too. So i just left color correction and don't have that problem anymore.
Currently working on restoring camera position behind car if mouse was not active some time.

l911
  • l911

    ⒶⓌⒺⓈⓄⓂⒺ

  • Members
  • Joined: 02 Oct 2008

#16

Posted 10 January 2013 - 05:06 PM

dude awesome work.
I will be soooo happy if you will apply free camera also when player isnt in the car it will make VC and III gameplay 1000 times better/

krisztiancicus
  • krisztiancicus

    Player Hater

  • Members
  • Joined: 16 May 2013

#17

Posted 16 May 2013 - 11:35 PM

I can't belive it. Everyone was complaining about slow motion. I enabled this MOD, and any idea what happened? I got scenes, like in Benny Hill Show, the police chase scenes (sorry for my english, but maybe you can understand me). It is horrible fast. There was a first mod version 0.1 what had many glitches, but it worked in normal playtime, and coused no similar problems, but with it the game was unplayable. Can anybody help me? I was very satisfied with the camera controll, but I really want no walking in the city with 30 kilometers per hour, and drive with 160 km/h.

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#18

Posted 16 May 2013 - 11:58 PM

But this is the only way i can fix car twitching. It's playable with frame limiter.
You can also disable this part of the code and compile your own version of the script with car twitching and disabled speedhack.

krisztiancicus
  • krisztiancicus

    Player Hater

  • Members
  • Joined: 16 May 2013

#19

Posted 17 May 2013 - 07:51 AM

There isn't problem with framerate, and I enabled frame limiter too.
There are in the game many bugs, for example you dies, when rushin from a slope ground and Claude flies approximately 10 meters forwards, and lose the 50% of his health, it was really fixed, and the camera isn't really twitchig when driving. But I can't imagine, that it was planned to play the game in that speed, like in I have to.
I would disable it, if I would know what part in the code is it. Can you help me? And speedhack causes only for mee unbelivable fast speed, or is it normal?

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#20

Posted 17 May 2013 - 09:13 AM

QUOTE (krisztiancicus @ Friday, May 17 2013, 11:51)
There isn't problem with framerate, and I enabled frame limiter too.
There are in the game many bugs, for example you dies, when rushin from a slope ground and Claude flies approximately 10 meters forwards, and lose the 50% of his health, it was really fixed, and the camera isn't really twitchig when driving. But I can't imagine, that it was planned to play the game in that speed, like in I have to.
I would disable it, if I would know what part in the code is it. Can you help me? And speedhack causes only for mee unbelivable fast speed, or is it normal?

I just finished main storyline recently with this and other mods, without any major problems.
I don't really remember, maybe my script is a bit modified than the gtagarage version, so please try this one first: http://www.sendspace.com/file/xwhnh5
If you still having issues with it, then try the version without speedhack: http://www.sendspace.com/file/ysrf95

Let me know the results, if the first version works i should upload it to gtagarage.

krisztiancicus
  • krisztiancicus

    Player Hater

  • Members
  • Joined: 16 May 2013

#21

Posted 17 May 2013 - 09:44 AM Edited by krisztiancicus, 17 May 2013 - 09:54 AM.

The first still has the fast move problem. The game is still rushing with it.
The second one works good for me. Without speedhack the game has normal speed. It contains the option to enable the free camera mod, so I think there won't be any problem after cutscenes. Obviously it is surprise only for me. Twitching comes, and has again the bug I wrote before, but the camera works like it has to.
My question is, that is it the 1.4 version without speedhack, or other version? With your own mods and with speed hack enabled you hadn't the similar problems? Isn't any other solution for camera twitching?

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#22

Posted 17 May 2013 - 10:01 AM

QUOTE (krisztiancicus @ Friday, May 17 2013, 13:44)
My question is, that is it the 1.4 version without speedhack, or other version?

Yes, as far as i remember i changed the speedhack code during the experiments, but it should work the same way.
QUOTE
With your own mods and with speed hack enabled you hadn't the similar problems?

No. Maybe the game runs a little bit faster than it should, but i'm fine with that.
ENB makes it a little bit slower though at certain parts of the map, but it's not really a big deal.
QUOTE
Isn't any other solution for camera twitching?

I didn't found any other, and i really have no idea where to look.

krisztiancicus
  • krisztiancicus

    Player Hater

  • Members
  • Joined: 16 May 2013

#23

Posted 17 May 2013 - 11:07 AM

Thank you for helping me, I really appreciate your helps.

I tried before other things too, that didn't work for me. I hope, you could help in them too. Of course I don't want to be insatiate.
I tried for example the HQ Textures For GTAIII V.1.3 and ENB. The textures were really nice, but in cutscenes they disappeared (only the edited textures). I tried resizing the new textures to make them smaller, but it didn't help. However I liked the textures especially the trees, but didn't work normal.
ENB series makes the game unplayable. The DOF, motion blur light and shadow effects don't work fine. I would be satisfied with more reflection and a bit better lighting effects, but I have no idea why should all the effect in same time being. I edited the configuration file (dont remember its name) but didn helped a lot. Have you good working experiences with any of my problems? (rorry again for my english biggrin.gif )

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#24

Posted 17 May 2013 - 12:20 PM

QUOTE (krisztiancicus @ Friday, May 17 2013, 15:07)
Thank you for helping me, I really appreciate your helps.

I tried before other things too, that didn't work for me. I hope, you could help in them too. Of course I don't want to be insatiate.
I tried for example the HQ Textures For GTAIII V.1.3 and ENB. The textures were really nice, but in cutscenes they disappeared (only the edited textures). I tried resizing the new textures to make them smaller, but it didn't help. However I liked the textures especially the trees, but didn't work normal.
ENB series makes the game unplayable. The DOF, motion blur light and shadow effects don't work fine. I would be satisfied with more reflection and a bit better lighting effects, but I have no idea why should all the effect in same time being. I edited the configuration file (dont remember its name) but didn helped a lot. Have you good working experiences with any of my problems? (rorry again for my english biggrin.gif )

I'm currently seeding the torrent with my GTA3 files for a backup, i can send you a link, which can be also found on sannybuilder forums. PM me if you're interested.

Dock174
  • Dock174

    Player Hater

  • Members
  • Joined: 30 Dec 2010

#25

Posted 02 June 2013 - 02:42 PM

Извините за отхождение от темы, но не мог ли бы ты сделать camhack для свободного перемещения камеры вокруг героя. Для San Andreas их масса, а вот для 3 и Vice City...
-----------------
Sorry for the discharge of the topic, but could be if you do camhack for free movement of the camera around the character. San Andreas for their weight, but for 3 and Vice City ...

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#26

Posted 02 June 2013 - 02:55 PM

QUOTE (Dock174 @ Sunday, Jun 2 2013, 18:42)
Извините за отхождение от темы, но не мог ли бы ты сделать camhack для свободного перемещения камеры вокруг героя. Для San Andreas их масса, а вот для 3 и Vice City...
-----------------
Sorry for the discharge of the topic, but could be if you do camhack for free movement of the camera around the character. San Andreas for their weight, but for 3 and Vice City ...

No idea how.

hithere5
  • hithere5

    Trick

  • Members
  • Joined: 01 Dec 2011

#27

Posted 06 August 2013 - 07:11 PM

Doesn't work for me at all. sad.gif
I downloaded Sanny Builder 3 and installed it. Then I downloaded Cleo for Vice City. During the installation there was an error with the Sanny Builder 3 folder.
It said "error opening file for writing:
opcodes.txt
VICESCM.ini"
Than I pasted [VC]VehCameraMovement in the CLEO folder and started the game.
But unfortunately nothing happens when I'm in a car and moving the mouse around...
Anybody got a clue? smile.gif

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#28

Posted 06 August 2013 - 09:45 PM

QUOTE (hithere5 @ Tuesday, Aug 6 2013, 23:11)
Doesn't work for me at all. sad.gif
I downloaded Sanny Builder 3 and installed it. Then I downloaded Cleo for Vice City. During the installation there was an error with the Sanny Builder 3 folder.
It said "error opening file for writing:
opcodes.txt
VICESCM.ini"
Than I pasted [VC]VehCameraMovement in the CLEO folder and started the game.
But unfortunately nothing happens when I'm in a car and moving the mouse around...
Anybody got a clue? smile.gif

Have you tried to change the camera view?

hithere5
  • hithere5

    Trick

  • Members
  • Joined: 01 Dec 2011

#29

Posted 07 August 2013 - 12:02 PM

QUOTE (ThirteenAG @ Tuesday, Aug 6 2013, 22:45)
QUOTE (hithere5 @ Tuesday, Aug 6 2013, 23:11)
Doesn't work for me at all. sad.gif
I downloaded Sanny Builder 3 and installed it. Then I downloaded Cleo for Vice City. During the installation there was an error with the Sanny Builder 3 folder.
It said "error opening file for writing:
opcodes.txt
VICESCM.ini"
Than I pasted [VC]VehCameraMovement in the CLEO folder and started the game.
But unfortunately nothing happens when I'm in a car and moving the mouse around...
Anybody got a clue? smile.gif

Have you tried to change the camera view?

Yes, but the camera views are the same. Nothing happens when I turn the mouse in any of them..
Really don't know what I'm doing wrong... confused.gif

ThirteenAG
  • ThirteenAG

    Foot Soldier

  • Members
  • Joined: 29 Dec 2008
  • None

#30

Posted 07 August 2013 - 12:29 PM

QUOTE (hithere5 @ Wednesday, Aug 7 2013, 16:02)
Yes, but the camera views are the same. Nothing happens when I turn the mouse in any of them..
Really don't know what I'm doing wrong... confused.gif

Do you have cleo sign in left bottom corner in the main menu?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users