Quantcast

Jump to content

» «
Photo

GTA SA MED CRASH

8 replies to this topic
dicemasta98
  • dicemasta98

    Player Hater

  • Members
  • Joined: 29 Apr 2012

#1

Posted 30 June 2012 - 06:48 AM

Im not sure what the problem is but ever since i deleted ryders and the house were the party was at on grove street the game has been crashing but i wanna think its because i deleted the lod files also please help!!!!

GTASanAndreas12345
  • GTASanAndreas12345

    Square Civilian

  • Members
  • Joined: 07 Sep 2010

#2

Posted 17 July 2012 - 12:09 PM

You must not delete default map objects from the game's map; only adding objects is supported. Otherwise, the game will crash. There's no workaround for this, I'm afraid.

donuteater
  • donuteater

    Player Hater

  • Members
  • Joined: 22 Nov 2012

#3

Posted 03 December 2012 - 06:57 PM

I can delete tress all over the place and my games run.

I think the problem is deleting things that are refed in Main.scm.
For instance, I deleted all the trees from countryw (no problem).
I deleted some of the "side" houses and fences (no problem).
I deleted The Truth's and Combine Harvester farmhouses and barns (CRASH).

Takes some experimentation and probably editing of Main.scm (tho I'm
not 100% on that). Just be sure to back up each edit and watch for VirtualStore
versions if you've installed in Program Files (x86)...you can tell by the
date timestamp changes on the files.

Celestial Hyena
  • Celestial Hyena

    Requested ban

  • BUSTED!
  • Joined: 07 Dec 2012

#4

Posted 16 December 2012 - 06:50 PM

I know it's 13 days ago but i add this smile.gif

This is because the LOD object of Ryder's house is still present, once you delete the house go to View and click on Long Distance (LOD) to go into LOD mode here

user posted image

Remember to re-render the scene so the Long Distance objects can be visible and simply delete the LOD object of ryder's house

Save and Done icon14.gif

sxlxll
  • sxlxll

    SxL

  • Members
  • Joined: 06 Sep 2012

#5

Posted 16 December 2012 - 06:51 PM

reinstall your map folder in Gta San Andreas floder

sxlxll
  • sxlxll

    SxL

  • Members
  • Joined: 06 Sep 2012

#6

Posted 16 December 2012 - 06:54 PM

QUOTE (Celestial Hyena @ Sunday, Dec 16 2012, 18:50)
I know it's 13 days ago but i add this smile.gif

This is because the LOD object of Ryder's house is still present, once you delete the house go to View and click on Long Distance (LOD) to go into LOD mode here

user posted image

Remember to re-render the scene so the Long Distance objects can be visible and simply delete the LOD object of ryder's house

Save and Done icon14.gif

Celestial Hyena lets work together to mooding a elegy inlove.gif inlove.gif

Celestial Hyena
  • Celestial Hyena

    Requested ban

  • BUSTED!
  • Joined: 07 Dec 2012

#7

Posted 16 December 2012 - 06:55 PM

QUOTE (sxlxll)
Celestial Hyena lets work together to mooding a elegy  inlove.gif   inlove.gif

Okay but don't post this off topic stuff again in the future icon14.gif please use PM's smile.gif

ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union

#8

Posted 16 December 2012 - 11:03 PM Edited by ZAZ, 16 December 2012 - 11:30 PM.

QUOTE (dicemasta98 @ Saturday, Jun 30 2012, 07:48)
Im not sure what the problem is but ever since i deleted ryders and the house were the party was at on grove street the game has been crashing but i wanna think its because i deleted the lod files also please help!!!!

yes, you must first learn how the LOD-system work, then you can delete ipl lines

i recomand, restore the ipl modifications, then edit just the coords: place the building and the lod building 50.0 units more below


QUOTE (donuteater @ Monday, Dec 3 2012, 19:57)
I can delete tress all over the place and my games run.

I think the problem is deleting things that are refed in Main.scm.

you're wrong! the reson is the LOD system

QUOTE (Celestial Hyena @ Sunday, Dec 16 2012, 19:50)
I know it's 13 days ago but i add this smile.gif

This is because the LOD object of Ryder's house is still present, once you delete the house go to View and click on Long Distance (LOD) to go into LOD mode here

user posted image

Remember to re-render the scene so the Long Distance objects can be visible and simply delete the LOD object of ryder's house

Save and Done icon14.gif

you're also wrong


QUOTE (ZAZ @ Saturday, Apr 21 2012, 22:48)

objects which should link to a corresponding LOD object must have the line number of the corresponding LOD object at the end of the ipl line
the most part of ipl placement is done in the stream-ipl files, the are a lot of objects which links to corresponding LOD objects of the base ipl
Then the LOD-models don't need a collisions model (btw. 98% of the SA LOD models don't have a collisions model)


example to explain the stream ipl files:
base ipl: data\maps\LA\LAe2.ipl
connected stream-ipl inside of gta3.img: LAe2_stream0.ipl, LAe2_stream1.ipl, LAe2_stream2.ipl, LAe2_stream3.ipl, LAe2_stream4.ipl,

LOD objects must have -1 at the end
only objects which should link to a corresponding LOD object must not have -1 at the end, the others must have -1

example, 3 objects which links to their corresponding LOD object
mynice_home links to LODice_home at line 3, mynice_garage to LODice_garage at line 4 ad so on
CODE
inst
5001, mynice_home, 0, 190.6, -1425.8, 19.4, 0, 0, 0, 1, 3
5002, mynice_garage, 0, 190.6, -1425.8, 19.4, 0, 0, 0, 1, 4
5003, mynice_shop, 0, 190.6, -1425.8, 19.4, 0, 0, 0, 1, 5
5004, LODice_home, 0, 190.6, -1425.8, 19.4, 0, 0, 0, 1, -1
5005, LODice_garage, 0, 190.6, -1425.8, 19.4, 0, 0, 0, 1, -1
5006, LODice_shop, 0, 190.6, -1425.8, 19.4, 0, 0, 0, 1, -1
end


then you merged the 3 LOD objects into LODice_home
so only mynice_home needs to link to LODice_home at line 3
CODE
inst
5001, mynice_home, 0, 190.6, -1425.8, 19.4, 0, 0, 0, 1, 3
5002, mynice_garage, 0, 190.6, -1425.8, 19.4, 0, 0, 0, 1, -1
5003, mynice_shop, 0, 190.6, -1425.8, 19.4, 0, 0, 0, 1, -1
5004, LODice_home, 0, 190.6, -1425.8, 19.4, 0, 0, 0, 1, -1
end



Celestial Hyena
  • Celestial Hyena

    Requested ban

  • BUSTED!
  • Joined: 07 Dec 2012

#9

Posted 17 December 2012 - 03:31 PM Edited by Celestial Hyena, 17 December 2012 - 03:41 PM.

@ZAZ Well actually it works for me icon14.gif and like i say "if it works, go do it" smile.gif




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users