Quantcast

Jump to content

» «
Photo

Why wont scripts work?

3 replies to this topic
starfishswag
  • starfishswag

    Square Civilian

  • Members
  • Joined: 08 Apr 2012

#1

Posted 16 April 2012 - 11:47 PM

I am installed on GTA 1.7 and on a cd retail

I have placed

dsound.dll (asi loader)
xlive.dll
scripthook.dll (0.5.1 version for 1.7)
trafficload.asi
trafficload.ini

in C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV

and in C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV\scripts

trafficload.asi
trafficload.ini

I even tried the fuel mod v2.1 and it had no effect... GRRRRRRRRRRRRR please help.

Prof_Farnsworth
  • Prof_Farnsworth

    Ambient Modder

  • Members
  • Joined: 25 Feb 2011

#2

Posted 17 April 2012 - 07:32 PM

QUOTE (starfishswag @ Monday, Apr 16 2012, 23:47)
I am installed on GTA 1.7 and on a cd retail

I have placed

dsound.dll (asi loader)
xlive.dll
scripthook.dll (0.5.1 version for 1.7)
trafficload.asi
trafficload.ini

in C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV

and in C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV\scripts

trafficload.asi
trafficload.ini

I even tried the fuel mod v2.1 and it had no effect... GRRRRRRRRRRRRR please help.

I am pretty sure dsound and xlive are both asi loaders, so you can remove one of those. Also, trafficload should only be in the main folder, not scripts, as it is an asi mod. Only .net mods go in the scripts folder, I believe. Try that, see how it goes.

NaidRaida
  • NaidRaida

    Inactive user

  • Members
  • Joined: 14 Dec 2010

#3

Posted 18 April 2012 - 03:10 PM Edited by NaidRaida, 18 April 2012 - 03:54 PM.

The Prof is right. Do not use xlive.dll AND dsound.dll together. Only one of these is necessary. Keep in mind: With xlive all online functions of the game are disabled.
Also make sure the script loader fits to the rest of your system, there are some special requirements for some redistributables (Framework!). Carefully read the full readme delivered with the script mod.
I had some issues with script mods too, none of them worked or even crashed but then I spent attention to these "special requirements" and suddenly it worked. I just installed the correct NetFramework
and some other redistributable requested by the readme.

Requested to be moved to 'IV Coding'.

gtamodder1212
  • gtamodder1212

    Square Civilian

  • Members
  • Joined: 19 Jun 2012

#4

Posted 20 June 2012 - 03:16 AM

i have GTA 4 with patch 1.0.6.0 and have traffic load but does not work i have

dsound.dll
scripthook.0.5.1
and have scripthookdotnet.asi

am i missing anything thanks




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users