Quantcast

Jump to content

» «
Photo

GTA IV Shadows lag horribly.

6 replies to this topic
GTACrazyFan
  • GTACrazyFan

    Crackhead

  • BUSTED!
  • Joined: 09 Dec 2011

#1

Posted 06 April 2012 - 05:29 PM

Specs:
Laptop
Windows 7 64-bit
i7-2670QM @ 2.20GHz TurboBoost @ 2.9GHz
GT 525m 1GB
8GB Ram
Patch 1.0.7.0
ALL DRIVERS ARE UP TO DATE INCLUDING GT 525M AND HD 3000 (Intergrated)

I can play the game at 1600x900 with everything on High with bars both to 50 (Won't go to 100 because I'm afriad of burning my card) and with shadows OFF with no lag.

All of a sudden I turn shadows to low and it starts being choppy. I turn them to medium and the game is virtually unplayable.
I'm not going to OC my GPU since it already gets really hot when playing GTA IV for like 30 minutes.

Good lord, I've tried everything and nothing works. suicidal.gif

I heard something about turning Windows Event Log off but people say not to do it because it's part of windows and it needs to be on at all times.

I need help cryani.gif

OverTheBelow
  • OverTheBelow

    OTB "Oaty-Bee"

  • Zaibatsu
  • Joined: 30 Oct 2008

#2

Posted 06 April 2012 - 05:38 PM

Turn down the other settings first and then turn on shadows. Your GPU can only handle so much load at once before slowdowns occur. Keep the sliders at 30 or below, and night shadows completely off. Disabling Windows Event Logging won't do anything to help performance with shadows enabled because they rely almost soley on the GT 525m, which is being stretched far enough by you trying to run the game on high at that resolution.

So in summary - either turn down the settings first before enabling shadows, keep the shadows off or overclock your graphics card, because it isn't powerful to handle settings this high all at once and is the reason you are getting the slowdowns. Exactly how hot is your GPU getting? If you have the temperature headroom then you should definitely try and overclock it because you'll get much more out of it.

GTACrazyFan
  • GTACrazyFan

    Crackhead

  • BUSTED!
  • Joined: 09 Dec 2011

#3

Posted 06 April 2012 - 05:42 PM

QUOTE (OverTheBelow @ Friday, Apr 6 2012, 17:38)
Turn down the other settings first and then turn on shadows. Your GPU can only handle so much load at once before slowdowns occur. Keep the sliders at 30 or below, and night shadows completely off. Disabling Windows Event Logging won't do anything to help performance with shadows enabled because they rely almost soley on the GT 525m, which is being stretched far enough by you trying to run the game on high at that resolution.

So in summary - either turn down the settings first before enabling shadows, keep the shadows off or overclock your graphics card, because it isn't powerful to handle settings this high all at once and is the reason you are getting the slowdowns. Exactly how hot is your GPU getting? If you have the temperature headroom then you should definitely try and overclock it because you'll get much more out of it.

I've tried with everything on low and shadows on medium with same resolution and it still lags.

I've tried the same but with 800x600 resolution. Same lag and game looks like sh*t.


Idk if I should overclock. I'm afriad of burning it or damaging it :x

GTACrazyFan
  • GTACrazyFan

    Crackhead

  • BUSTED!
  • Joined: 09 Dec 2011

#4

Posted 06 April 2012 - 06:14 PM

Just Overclocked it at what people said was a stable overclock and GTA IV started having weird white seziures. Within 3 minutes of playing the game froze and I got a bunch of blue and purple sparkles on my screen. So my Laptop basicly crashed.

I'm not going to try anymore because I'm just going to damage it.

But GTA IV moved a little smoother wow.gif

YankeesPwnMets
  • YankeesPwnMets

    More Betterer

  • Members
  • Joined: 28 Sep 2010

#5

Posted 06 April 2012 - 06:56 PM Edited by YankeesPwnMets, 06 April 2012 - 07:00 PM.

You overclocked a laptop? Great job voiding your warranty. If it breaks, then you're gonna need to buy a new one without getting any sort of refund or replacement.

You cannot overclock a laptop. The only time a laptop should be overclocked is if the factory does it for you, since your warranty wouldn't be voided. Most laptops don't have a sufficient cooling system for overclocking. Your sparkles are called artifacts and those result from a graphics card malfunction.

You're lucky your parts didn't fry..... components like an HDD are very sensitive to high temperatures.

In the overclocking world, the rule of thumb is that if you don't know what you are doing, you don't do it. Since you seemed unsure about overclocking, you shouldn't have done it.... unless you can afford a new laptop after frying your current one. If your computer died, the company wouldn't have replaced a single thing for you. Instead, you would be digging deeper into your wallet and buying a brand new PC. Next time if you are unsure, waiting for a response would have been better then mindlessly going about something you had very little knowledge about.

mkey82
  • mkey82

    Keep riding hard, son

  • Members
  • Joined: 14 Feb 2008

#6

Posted 06 April 2012 - 08:06 PM

If you're unsure about something, you should get informed first, not just quit. You get nowhere if you just quit.

GTACrazyFan
  • GTACrazyFan

    Crackhead

  • BUSTED!
  • Joined: 09 Dec 2011

#7

Posted 06 April 2012 - 08:20 PM

Problem solved! Uninstalled GTA IV and installed it again and only patched it till 1.0.2.0. Now it works on max like a charm.

Good job Rockstar. You f*cked the game over with the patches.

Anyways my warranty expired already and yes it was stupid of me to overclock it without total background knowledge. I've read some things about overclocking the GT 525M and the overclock settings that was stable for everyone was the one I used but for me it didn't work. The laptop still works and nothing is broken or damaged.(Hopefully)
The program I used just overclocks it till you shut down the laptop. Then it changes the settings to the original.

Thanks guys anyways.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users