Quantcast

Jump to content

» «
Photo

Feel like I should be getting better performance

17 replies to this topic
Spacecraft
  • Spacecraft

    Player Hater

  • Members
  • Joined: 29 Mar 2012

#1

Posted 29 March 2012 - 03:52 PM

Here is my benchmark:

Statistics
Average FPS: 56.17
Duration: 36.87 sec
CPU Usage: 64%
System memory usage: 60%
Video memory usage: 27%

Graphics Settings
Video Mode: 1920 x 1080 (60 Hz)
Texture Quality: High
Shadow Quality: Very High
Reflection Resolution: Very High
Water Quality: Very High
Texture Filter Quality: Anisotropic x16
Night Shadows: Very High
View Distance: 100
Detail Distance: 100

Hardware
Microsoft Windows 7 Ultimate
Service Pack 1
Video Adapter: AMD Radeon HD 6900 Series
Video Driver version: 8.17.10.1119
Audio Adapter: Speakers (2- Logitech G930 Headset)
Intel® Core™ i5-2500K CPU @ 3.30GHz

File ID: Benchmark.cli


It looks fairly smooth in the benchmark. There is still tons hitching like load lag or something, and there really should not be. In a normal game it's actually far worse performance, with massive lag as I turn the camera quickly.

I'll expand upon my hardware:

i5 2500k @ 4.5 GHz
2x crossfire HiS Radeon HD 6950 2GB
8GB DDR3
Crucial m4 128GB SSD

Exxon
  • Exxon

    The Obvious Child

  • Members
  • Joined: 11 Oct 2010

#2

Posted 29 March 2012 - 04:04 PM

Disable one of the GPU's, IV hates Crossfire wink.gif
But your settings are just too high. Lower them, especially sliders to 50 or lower.

If you still want to play with sliders at 100, you should overclock your CPU even further turn.gif

Spacecraft
  • Spacecraft

    Player Hater

  • Members
  • Joined: 29 Mar 2012

#3

Posted 29 March 2012 - 04:11 PM Edited by Spacecraft, 29 March 2012 - 04:24 PM.

QUOTE (Exxon @ Thursday, Mar 29 2012, 16:04)
Disable one of the GPU's, IV hates Crossfire wink.gif
But your settings are just too high, lower them, and especially sliders to 50 or lower.

If you still want to use sliders at 100, you should OC your CPU even further turn.gif

You're serious? i5 2500k at 4.5 GHz still isn't enough for 100% in IV?

Anyways, I disabled one GPU and it made no difference. Lowered the sliders to 50 and I get maybe 5 FPS more. But now I have a really weird lag problem. Doesn't feel like FPS drop, it just kind of slows for a split second. I'm uploading a video and I'll edit this post when it's done.

Edit: Ah well, I can't recreate the problem. I'm still getting less than 40 FPS max with your recommendations. I mean I know this game is the epitome of a poor console port, but is there really nothing to be done about the insanely horrid performance? All I've found are solutions to get it running on lower end machines that involve lowering the graphics.

Brainsick
  • Brainsick

    Peon

  • Members
  • Joined: 10 Sep 2011

#4

Posted 29 March 2012 - 09:42 PM

I too have a 2500k at 4.5 and I still cannot max the game out, it's just too incredibly demanding, here's what you should do: Install Patch #4 since it's the most performance friendly. Leave shadows on 'high' and disable night shadows, and leave your car density to like 50. View and Detail Distance to around 30/40; Seriously, this game is just crazy how much hardware it requires, but if you follow those steps you'll be able to run it at 60 fps flat with enb and mods etc, I know I can, but you have to lower those settings.

Also, if you're still having performance issues, you could take a look to the -memrestrict commandline (look it up), it does help some people sometimes, good luck.

Spacecraft
  • Spacecraft

    Player Hater

  • Members
  • Joined: 29 Mar 2012

#5

Posted 30 March 2012 - 01:22 PM

QUOTE (Brainsick @ Thursday, Mar 29 2012, 21:42)
I too have a 2500k at 4.5 and I still cannot max the game out, it's just too incredibly demanding, here's what you should do: Install Patch #4 since it's the most performance friendly. Leave shadows on 'high' and disable night shadows, and leave your car density to like 50. View and Detail Distance to around 30/40; Seriously, this game is just crazy how much hardware it requires, but if you follow those steps you'll be able to run it at 60 fps flat with enb and mods etc, I know I can, but you have to lower those settings.

Also, if you're still having performance issues, you could take a look to the -memrestrict commandline (look it up), it does help some people sometimes, good luck.

I have the Steam version. Is it patched up already?

Exxon
  • Exxon

    The Obvious Child

  • Members
  • Joined: 11 Oct 2010

#6

Posted 30 March 2012 - 01:27 PM

QUOTE (Brainsick @ Thursday, Mar 29 2012, 21:42)
... here's what you should do: Install Patch #4 since it's the most performance friendly. Leave shadows on 'high' and disable night shadows, and leave your car density to like 50. View and Detail Distance to around 30/40; Seriously, this game is just crazy how much hardware it requires, but if you follow those steps you'll be able to run it at 60 fps flat with enb and mods etc, I know I can, but you have to lower those settings.

^ What the man says icon14.gif

There is a way to use patch 4 on the Steam version, use Google and you'll find it.
The view and detail distances and the car density should be at 50 or lower and the shadow density (night shadows) off wink.gif

friendly luggage
  • friendly luggage

    Catch a ride!

  • Members
  • Joined: 19 May 2011
  • United-Kingdom

#7

Posted 30 March 2012 - 04:17 PM

If you install a patch below 1.0.7.0 you won't be able to go online. Games from Steam are auto update to the latest patch which is 1.0.7.0 for normal GTA IV PC. On your settings I would turn down the shadows and have the view and detail distance below 50. GTA IV doesn't run the best with ATi cards as well and plus it was a shoddy console port.

fenderjaguar
  • fenderjaguar

    Player Hater

  • Members
  • Joined: 04 Sep 2011

#8

Posted 31 March 2012 - 11:00 AM Edited by fenderjaguar, 31 March 2012 - 11:06 AM.

I don't think the 1.7 very high shadows are CPU bound. I've noticed they thrash the GPU at any resolution, and CPU usage goes way down.

Just put everything on high, not very high. No night shadows. AF 16x. Then set view distance 25 (anything over this and you'll see flashing lights at night sometimes), detail distance 40, traffic 100. definition on, vsync off.

Most importantly, especially with an AMD card, cap the frame rate at 50 fps with dxtory.

unc13bud
  • unc13bud

    Weekend Answerer

  • Members
  • Joined: 05 Dec 2010
  • None

#9

Posted 01 April 2012 - 06:50 PM

QUOTE
If you install a patch below 1.0.7.0 you won't be able to go online.


i think that is only if you use steam, cause i distinctly remember no problems playing online with only 1.0.4.0 +GFWL+rockstar social club. but maybe something has changed, haven't tried it lately, because these OS (Windows 7) are not activated.

Brainsick
  • Brainsick

    Peon

  • Members
  • Joined: 10 Sep 2011

#10

Posted 01 April 2012 - 10:37 PM Edited by Brainsick, 01 April 2012 - 10:40 PM.

@fenderjaguar: You might be right about shadows being gpu dependent. I realized I get even more stable fps if I set the shadows to 'very high' so I don't know anymore, this game is counter-intuitive sometimes, I think it's because im playing on 1280x1024 since my old lcd is broken and very high shadows alleviated the cpu bottleneck (I know), cause contrary to what a lot of people say, 'shadow quality' seems to actually be gpu dependent. at least that's what it says in the graphics menu.

Frifi
  • Frifi

    Player Hater

  • Members
  • Joined: 03 Apr 2012

#11

Posted 03 April 2012 - 06:31 PM

Hi there.

I seriously need help with this. On max i only get 4 -5 frames and on lowest i get 32-53 frames.

Is there something i can do to run it high and still get 50+ frames?

Please help.

Thanx in advance.

My Rig
CPU: HexaCore AMD Phenom II X6 Black Edition 1090T @ 3.2ghz
MOBO: Gigabyte GA-990FXA-UD5
GPU: Saphire HD5970 2gb
RAM: 8 GB DDR3 1600 MHz Kingston HyperX
PSU: NZXT 1000W
OS: Windows 7 Ultimate 64bit

Grand Theft Auto IV
Resolution = 1920 x 1080 @ 60 Hz
Texture Quality = High
Reflection Quality = Very High
Water Quality = High
Shadow Quality = Very High
Sliders = 100; 100; 100; 16
Frames Per Second = 4 - 5

YankeesPwnMets
  • YankeesPwnMets

    More Betterer

  • Members
  • Joined: 28 Sep 2010
  • United-States

#12

Posted 03 April 2012 - 10:50 PM

Sliders down to 50
Shadows down to high
Night shadows off

^Try these settings

Gertrude73
  • Gertrude73

    Player Hater

  • BUSTED!
  • Joined: 26 Mar 2012

#13

Posted 04 April 2012 - 01:47 AM

user posted imageBut your settings are just too high. Lower them, especially sliders to 50 or lower.

unc13bud
  • unc13bud

    Weekend Answerer

  • Members
  • Joined: 05 Dec 2010
  • None

#14

Posted 04 April 2012 - 02:27 AM

does GTA IV even auto-configure to 100 on any of the detail settings? i ask because i think original poster set those settings up there so high, which means he is might be one of these goofy cats that cannot be satisfied.

Frifi
  • Frifi

    Player Hater

  • Members
  • Joined: 03 Apr 2012

#15

Posted 04 April 2012 - 04:08 AM

Thanx will try it.

Have installed patch 7 now and it seem to handle maxed out now with 38-56 fps.

luceberg
  • luceberg

    Homeboy

  • Members
  • Joined: 27 Dec 2008

#16

Posted 06 April 2012 - 12:13 AM

Spacecraft, that would run better if you downclocked your cpu to 4Ghz, a closer balance for an amd 6950.

hexelbit
  • hexelbit

    Player Hater

  • Members
  • Joined: 18 Jul 2011

#17

Posted 12 April 2012 - 07:34 AM

check out the post boys, I can help. You will be happy. dont forget to format your pc too, nah but you can. go here http://www.gtaforums...howtopic=502804

dansgas1000
  • dansgas1000

    Posts: 1400

  • Members
  • Joined: 14 Jun 2011
  • None

#18

Posted 29 April 2012 - 06:56 PM

In my opinion i think you shouldn't get better performance with your specs. Actually i think your performance is quite good smile.gif




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users