Quantcast

Jump to content

» «
Photo

Begging for help on my knees!

2 replies to this topic
TheIsingGuy
  • TheIsingGuy

    Player Hater

  • Members
  • Joined: 27 Mar 2012

#1

Posted 27 March 2012 - 04:51 PM

Hi everyone, I'm new here, I'm also new to the GTA community, I have bought GTA 4 today and I have some graphical issues that are bothering me. So I have seen another post on this forum about this problem of stuttering, but now there are new AMD drivers and I was wondering if that makes a difference? So the latest one is 12.2

My PC:
ATI Radeon HD 6850 1GB VRAM
6GB RAM
Core i5 2400
120GB SSD+2TB 7200rpm HDD

Now, with the autodetect, GTA 4 set my settings to High at 1920x1200 (60hz), Benchmark looks good 35+, but when I run the game, I noticed the frame freeze and resumes every second or 2, I think this is called "stuttering" but I am not sure that.

Also, after a while, the image gets smeared out, first the light and then the car etc, and then the whole screen just became some blurry mess.

Just to say that with this setup I expected no problems to running GTA 4 at maximum setting, as this game was released in 2008 and I am able to run BF3 and Skyrim all maxed out with HD res+mods, I can not think of why this couldn't work.

I saw this solution http://www.overclock...-with-windows-7 after a good search and that hasnt solved my problem. I have the latest drivers 12.2 and Catalyst, I am updating the game now, so maybe that will solve the problem, but in the mean time, can anybody provide any suggestion as to what I could try?

Thanks a million!

TheIsingGuy
  • TheIsingGuy

    Player Hater

  • Members
  • Joined: 27 Mar 2012

#2

Posted 27 March 2012 - 05:24 PM

Update: New patch installed, everything is fine! Yay!

luceberg
  • luceberg

    Homeboy

  • Members
  • Joined: 27 Dec 2008

#3

Posted 27 March 2012 - 09:16 PM

Ok, good job you got it sorted.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users