Quantcast

Jump to content

» «
Photo

Scripthook keeps giving me problems!

1 reply to this topic
SomerenV
  • SomerenV

    Player Hater

  • Members
  • Joined: 12 Dec 2010

#1

Posted 23 March 2012 - 01:32 PM Edited by SomerenV, 23 March 2012 - 02:04 PM.

Yesterday I tried using TrafficLoad ( for using custom police, taxi and exotic car models). I placed the corresponding files in the GTAIV main dir and I placed Scripthook (.net) 0.5.0 in the main dir. After that I downloaded and installed both .Net 4.0 and Visual C++ 2010 x86. As an ASI loader I use XLiveless (newest version).

Anyways, everything is done as described in the readme's but when starting GTAIV I got the MSVCR100D.dll error (not found). The readme of TrafficLoad stated that this could happend so I placed the MSVCR100D.dll that came with the script in the main GTAIV dir. I started up GTAIV once again, didn't get an error, but this time the game crashed at the end of the loading screen (GTAIV.exe has stopped working. APPCRASH).

Without Scripthook and Trafficload the game runs just fine but that's not quite the solution. I've searched high and low but didn't find a working solution. Also, the Scripthook log says that TrafficLoad is loaded and doesn't show any errors.

I'm using:
- GTAIV 1.0.4.0
- Scripthook 0.5.0 (0.5.1 isn't compatible with GTAIV 1.0.4)
- The latest TrafficLoad version
- The newest version of Xliveless

- .Net 4.0 en Visual C++ are downloaded from Microsoft.com

I'm running GTAIV on a fresh installation of Windows 7 Ultimate x64

So far I've tried:
- Other traffic loading script
- Other versions of Xliveless and Scripthook
- Using only Scripthook.net without any scripts/add-ons
- Placing the MSVCR100D.dll in System32
- Running as admin
- Reinstalling GTAIV, .Net 4.0 and Visual C++

Nothing seems to fix the problem so I come here to ask for some help. Usually I know what I'm doing but GTAIV is really driving me nuts with this problem. So any solutions are more then welcome!

lamar_mustapha
  • lamar_mustapha

    Player Hater

  • BUSTED!
  • Joined: 17 Mar 2012

#2

Posted 23 March 2012 - 06:45 PM

- GTAIV 1.0.4.0
- Scripthook 0.4.0

fixed that for u




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users