Quantcast

Jump to content

» «
Photo

[Q] Custom Head model not showing textures.

5 replies to this topic
Pants_Johnson
  • Pants_Johnson

    Player Hater

  • Members
  • Joined: 29 Feb 2012

#1

Posted 29 February 2012 - 01:44 AM Edited by Pants_Johnson, 29 February 2012 - 01:57 AM.

Hi all,

I am new to the forums and I have been doing alot of reading up on creating models etc. So far I have been using this tutorial as my main guide among a few others.

gta forumshttp://www.gtaforums.com/index.php?showtopic=481411&st=0

Anyways i have successfully got my head in game, its a custom mesh i created in Zbrush. I have created a good UV structure and I have created spec maps,normal maps and bump maps and diffuse maps which all look great. When i get my model inside of 3ds Max everything looks fine texture wise, 3ds isn't showing bump maps but its showing the texture just fine. So i export my model and get it in game, i don't get any errors either but somehow my head is misaligned which i think i know how to fix but the real problem is that my textures are not showing and instead i get a reflective metal/terminator effect. The effect doesn't show so much indoors but outdoors at night and during the day the textures are insane.If anyone could help that would be great, im going to post screenshots of my materials setup in max and a shot from in game.

user posted image
user posted image
user posted image

Pants_Johnson
  • Pants_Johnson

    Player Hater

  • Members
  • Joined: 29 Feb 2012

#2

Posted 29 February 2012 - 01:55 AM

Another note i forgot to mention, when I hit the preview button in 3dsmax my model becomes transparent in some spots, maybe this could have an effect on why my model isn't working in game?

Model's textures seem broken when preview is enabled?
user posted image

quechus13
  • quechus13

    Boss

  • Members
  • Joined: 19 Dec 2008

#3

Posted 04 March 2012 - 10:24 PM

the preview button is messed up.

You must make your model use the normal and spec maps inside the wdr so click include in those.

the spec map slider is wrong.

You must have 93.2 of value on it which works for me otherwise the game will only use that tiny bit.

the reflection is the specularity.


Then replace your texture (diffuse) in the wtd of the head.

it also has to follow the same sizes

256, 512, 1024, 2048....

Pants_Johnson
  • Pants_Johnson

    Player Hater

  • Members
  • Joined: 29 Feb 2012

#4

Posted 12 March 2012 - 06:49 AM

Thanks for the help I do appreciate it, ok so i have figured out some things but whenever i export my head and I have included the diffuse and bump textures OPEN IV loops when i import my head. When i dont use the include option and just leave the material as Dictionary then the import into OPEN IV works, any thoughts on that? ALso there is an OTD option in GIMS, any idea on what that is for, i know it creates textures in a different file other than tex_include?

Pants_Johnson
  • Pants_Johnson

    Player Hater

  • Members
  • Joined: 29 Feb 2012

#5

Posted 13 March 2012 - 11:30 PM

Alrighty I have figured everything out, I had to edit my material in GIMS and not the default 3dsMax material editor, silly mistake but im new to 3dsMax, forgive me for my nooblect smile.gif I have meow got my head working ing-ame and textured, its still a little shiny in some spots but i think i can figure that out with my spec levels now that i can change them, my model had no eyes so i will wait until the head rigging tutorial shows up, super excited for that, im guessing removing hair is as simple as replacing the model with nothing or a dummy and if its a tex i can just use something transparent?


thanks to everyone who helped me in this thread and the original, GTA FORUMShttp://www.gtaforums.com/index.php?showtopic=481411 . I have posted pics below, THANKS AGAIN GUYS! Without you i would never have figured it out!

user posted image
user posted image
user posted image

Pants_Johnson
  • Pants_Johnson

    Player Hater

  • Members
  • Joined: 29 Feb 2012

#6

Posted 13 March 2012 - 11:43 PM

ps anyone know why my zbrush texture looks so crap ingame, im using a 4096 tex that retains most of its clarity even in photoshop? Im posting a zbrush shot to show you guys, i dont think my bump map is working? Any ideas?
user posted image




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users