Quantcast

Jump to content

» «
Photo

DriveFelony & TrafficLightsFix?

4 replies to this topic
Shogyn
  • Shogyn

    Player Hater

  • Members
  • Joined: 16 Feb 2011

#1

Posted 14 January 2012 - 06:56 PM

I have been trying unsuccessfully for awhile now to get either of these 2 mods to work. Here's my folders and whats in them...

Main GTA folder(patched to 1.04)- ScriptHook.txt, ScriptHookDotNet.asi, xlive.dll
'scripts' folder(located in main GTA folder)- DriveFelony.ini, DriveFelony.net.dll, ScriptHook.dll, TrafficLightsFix.v1.4, TrafficLightsFix.v1.4.net.dll

I adjusted the ini files in each according to the authors specs. Especially the DriveFelony mod,I made it so police and peds would notice and report even the least traffic infraction. But I have to practically kill peds on the sidewalks to get a notice from police. I have adjusted the ini in the TrafficLightsFix to each different setting specified, but can always knock down any traffic light with just a bump.

I must be missing something or have misplaced something. But Im sure Ive followed the install instructions correctly.

Any and all help with this would be greatly appreciated! Thank you.

AngryAmoeba
  • AngryAmoeba

    Symbiote

  • Members
  • Joined: 12 Jan 2009

#2

Posted 14 January 2012 - 08:13 PM

ScriptHook.dll belongs in the main folder, not the "scripts" folder.

If that makes your game crash, it's simply because your ScriptHook.dll file is incompatible with patch 1.0.4.0. Just replace it with this older version instead, and it should work fine.

Shogyn
  • Shogyn

    Player Hater

  • Members
  • Joined: 16 Feb 2011

#3

Posted 14 January 2012 - 09:24 PM

Thanks for replying and trying to help!

I did what you said and moved the scripthook.dll to the main folder. Game always starts but not before displaying the "GTA IV has stopped working" error message first before loading screens start. Under problem details where it states the Fault Module Name, it is always one of the following....

"scripthook.dll unloaded" or "WER.dll" or "ntdll.dll"

Then on the Windows error box I click 'Close the program' and the game will then start. However the 2 mods I'm trying to get working never do.

Then I tried your other suggestion and replaced the scripthook.dll with the one I Dled from the link you provided. Same error messages, same mods not working.
Also I read somewhere that there should be some logs created if the scripts are being implemented? There are no 'log' files whatsoever in any folder that I can see.

jitsuin
  • jitsuin

    Meat Popsicle

  • BUSTED!
  • Joined: 06 Dec 2011

#4

Posted 15 January 2012 - 03:38 AM Edited by jitsuin, 15 January 2012 - 04:01 AM.

If u have scripthook.dll 0.4.0.0 and scripthookdotnet.asi 1.7.1.7 beta and xlive.dll in the same directory as gtaiv.exe is then it will work. I think u have files in the wrong place. And those other dll's u r talking about might be part of net framework 4.0 go download that too and install. So if u have .net framework 4.0 and those 3 files installed and still doesn't work then reinstall game.

Edit: Oh yeah I only say cuz maybe he moved or deleted the wrong file on accident

AngryAmoeba
  • AngryAmoeba

    Symbiote

  • Members
  • Joined: 12 Jan 2009

#5

Posted 15 January 2012 - 03:49 AM

Reinstalling the game shouldn't be necessary. But do make sure you've installed the Microsoft .NET Framework and Microsoft Visual C++ redistributable in the .NET script hook thread, under "Requirements".




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users