Quantcast

Jump to content

» «
Photo

GTA 4 STEAM Version Mod Help

10 replies to this topic
dkosmack
  • dkosmack

    Player Hater

  • Members
  • Joined: 24 Oct 2011

#1

Posted 24 October 2011 - 08:26 AM

Ok, first ill apologize for possibly posting the same topic as someone else, you get SO much run-around on the internet when youre trying to find an answer to something and its near impossible.

Heres my questions/ problem:

First, i have the STEAM version of GTA 4, its version 1.0.7.0.
i want to mod with GTA 4. im not new to modding, but im new to modding with GTA 4, so if you post on this thread expect alot of questions.
i used this link to find out how to install the ASI Loader:
i placed all the correct folders into the main GTA 4 directory, but when i try to run the game through STEAM...nothing happens. the game does not load, and im left staring at my game library like i never even clicked on anything...
i then moved GTA 4 to a desktop icon and tried to run it as an administrator, and got this msg: binkw32.dll not found.
i went back into ...STEAM/steamapps/common/GTA4..etc., and saw that the binkw32.dll folder is sitting in the main GTA4 Directory, but not acknowledged for some reason.

the versions im using for all this stuff are:

ASI Loader 1.0.2.0
Scripthook 0.3.0
inGameTrainer 1.9.0

Any insight on this would be helpful. anything i find out im also sharing with a buddy of mine who wants to mod too, so helping me would be like helping 2 people.

Is all i wanna do is mod the STEAM version of GTA4...

thanks to whoever finds this and tries to help


AngryAmoeba
  • AngryAmoeba

    Symbiote

  • Members
  • Joined: 12 Jan 2009

#2

Posted 24 October 2011 - 05:39 PM

Well one thing I can see is that you have an outdated scripthook. The latest version is 0.5.1 and you can get it here.

Also, see if removing the ASI loader makes the game work again. If so, you'll probably have to try a different ASI loader, such as this one.

dkosmack
  • dkosmack

    Player Hater

  • Members
  • Joined: 24 Oct 2011

#3

Posted 24 October 2011 - 06:33 PM

Ok ill try to update my main GTA4 directory with those files instead and see what happens

dkosmack
  • dkosmack

    Player Hater

  • Members
  • Joined: 24 Oct 2011

#4

Posted 24 October 2011 - 07:06 PM

i got the trainer program to work in-game, but I just ran into another problem too, i have an alienware m14x, which does not have the number keypad on the right side of the keyboard, so i can bring up the mod menu in-game, but i cant navigate through it. does anyone have this problem too? im sure the solution is really easy i just dont know it

AngryAmoeba
  • AngryAmoeba

    Symbiote

  • Members
  • Joined: 12 Jan 2009

#5

Posted 24 October 2011 - 08:38 PM

Are the keys configurable somewhere, maybe in an .ini file? If not, I guess you'll have to find a different trainer.

gonnaenodaethat
  • gonnaenodaethat

    Yellow Car!!!

  • Members
  • Joined: 01 Jun 2011

#6

Posted 24 October 2011 - 09:10 PM

Try this link:

http://www.gta4-mods...r-laptops-f8680


Hope it works for you

dkosmack
  • dkosmack

    Player Hater

  • Members
  • Joined: 24 Oct 2011

#7

Posted 24 October 2011 - 11:23 PM

yea thanks for that link, i looked at it and dwnlded it, it looks like thats exactly what i need, the trainer that can run the mods but with a different control setup so i can navigate through it on my m14x, problem is i replaced the trainer i had in my main GTA4 directory with the trainer from that link, and before the game loads it stops and has the "GTA 4 has stopped working" window, "searching for a solution" or whatever it says. Ill see if i can find a tutorial on how to install that trainer, maybe i didnt place all the right files into the GTA4 folder...

dkosmack
  • dkosmack

    Player Hater

  • Members
  • Joined: 24 Oct 2011

#8

Posted 25 October 2011 - 08:44 PM

i figured it out. for anyone who has the STEAM version of GTA 4 v1.0.7.0, this is what im using to mod:

1. GTAIV .Net Script Hook v1.7.1.7 BETA
© 2009 Hazard ([email protected])

2. YAASIL (ASI LOADER
GTAIV YAASIL - Yet Another ASI Loader - v1.0 BETA
© 2009 Hazard ([email protected])

3. simple in-game trainer v6.2.4


after a long time of messing around with it i finally got stuff to work with this ^^

Gilligan
  • Gilligan

    Midnight Toker

  • Andolini Mafia Family
  • Joined: 25 Oct 2011
  • None

#9

Posted 27 October 2011 - 12:28 PM

Here, I'll post what you need to do so that others who view this can work out how to install modifications (my example being the Simple Native Trainer 6.3) simply. I'll explain it, and the links will be at the bottom.

Well, I too play Grand Theft Auto IV through Steam. I was like you, too. I wanted to download a modification (Simple Native Trainer 6.3). Now, unlike you I had the modification work first time around, so I didn't have to mess around as you've had to. So, I'm going to tell you what you're going to download, and how to install it into your Grand Theft Auto IV game.

Alright, first step is to download the actual modification. For this, I'll use an example (Simple Native Trainer 6.3). You can find modifications around a lot of websites. The two I usually use are the "GTA Garage", which is powered by GTAForums, and I also tend to use GTAGaming (I'll give links at the bottom of the post). So, for most modifications you're going to need WinRar. WinRar's simple to use, and there's many websites around that have links to download the version for free. Only problem, it pops up saying you're on the 40 day trial, but you'll have it for ever. (That's what mine does, anyway).

So. You've got your modification, now what? Well, now you're going to need the ASI Loader. Now, the XLiveless and original ASI Loader won't work, so, you're going to need to download YAASIL if you're playing from a Steam version of Grand Theft Auto IV PC. You can download this from various websites, but, I'll post a link to the topic on GTAForums so that it's easier to find if you need it again.

So, you've got your ASI Loader, and you've got your modification. Now you're going to need to install the modification into the Grand Theft Auto IV game. I'd recommend saving your current game, and exiting Grand Theft Auto IV whilst you do this, to avoid any data corruption. So, here's how to do it, step-by-step:

1.) Open up your Grand Theft Auto IV main directory (Program Files\Steam\steamapps\common\grand theft auto iv). An easier way to get to your Grand Theft Auto main directory is to go to Computer -> Program Files, and then search "Grand Theft Auto IV" in the search bar. (Click the file, not the white piece of paper icon). Then click on the GTAIV folder.

2.) Alright, first you want to move some files from your Modification's file to your Grand Theft Auto IV main directory. The following files are what you need to place in the IV directory: ScriptHook.dll, Trainer.asi and your Trainer.ini.

3.) Now that you've sorted out the Modification, you need to make sure your ASI Loader's in your Grand Theft Auto IV main directory too. Now, you need to place the dsound.dll file from your ASI Loader into the Grand Theft Auto IV main directory.

4.) Now your Simple Native Trainer 6.3 should work. Open Grand Theft Auto IV and see for yourself! But, it's only going to work in the original Grand Theft Auto. If you want it to work in Episodes of Liberty City too, you're going to have to follow other steps in order to make it work. If you wish to do this, send me a PM and I'll reply to you with these steps.

Here's some links to things I mentioned in my post:
YAASIL ASI Loader
Simple Native Trainer 6.3
Win-Rar 32-Bit
YouTube tutorial for Simple Native Trainer 6.3

Hope this helps. If you get confused with the YouTube video, and need help with anything more regarding the Simple Native Trainer's installation on either Grand Theft Auto IV or Episodes From Liberty City, don't hesitate to PM me. Happy Modding!

wbates115
  • wbates115

    Player Hater

  • Members
  • Joined: 10 Aug 2013

#10

Posted 10 August 2013 - 02:35 PM

Ive done all these things, and its still not working. Ive got 2 questions,

1. when installing mods (ex. xar mods, weapon mods, player models) do you simply drag all the files into your GTA 4 folder?
2. Im using the trainer that gonnaenodaethat suggested, and i dont have a trainer.ini. I do, however, have a trainerbogt.asi,
and a trainertlad.asi. WTF are these?

Urethra
  • Urethra

    Player Hater

  • Members
  • Joined: 09 Aug 2013

#11

Posted 10 August 2013 - 04:12 PM Edited by Urethra, 11 August 2013 - 01:25 AM.

trainertbogt.asi and trainertlad.asi are for The Ballad of Gay Tony and The Lost and Damned. If you're only modding the original campaign, ignore them.
When I first got the error about "binkw32.dll is missing", I was very confused.
This fixed the problem, for me: Run GTA IV from the desktop icon or elsewhere, running it as an administrator:
user posted image

When installing mods, not all of them just go into the GTA directory. Sometimes you have to open up your GTA .img with SparkIV and insert weapon models and data there. Many mods are different.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users