Quantcast

Jump to content

» «
Photo

Simple Native Trainer 6.3 Doesn't work

3 replies to this topic
Chromerz
  • Chromerz

    Player Hater

  • Members
  • Joined: 23 Jul 2011

#1

Posted 23 July 2011 - 07:10 PM Edited by Chromerz, 25 July 2011 - 09:42 AM.

[SOLVED] Check post below for fix

I downloaded the simple native trainer 6.3 from the original uploader. After following alot tutorials it still doesn't work. I do everything like they said and tried already different ASI loaders but the Trainer still won't work.
When I enter the game (1.0.0.4) and press F3 nothing happends. I'm using Win7 with a clear GTA IV install without any DLC's (I'm using the Razor1911 Crack + 1.0.0.4 patch. (I bought the game on my PS3) )
Also with the Xlive dll it doesn't work.
I give some logs:

SCRIPTHOOK LOG:
-----------------------
[INFO] GTA IV Script Hook 0.5.1 - © 2009, Aru - Initialized
[INFO] Process base address: 0x12a0000
[INFO] Auto detecting game version
[INFO] Using game version 1.0.4
[INFO] Script Hook - Shutdown

ASI LOG:
------------------------

// -- GTA IV ASI LOADER LOG -- //
//-- © Alexander Blade 2008 -- //
C:\Windows\system32\dsound.dll is loaded, address 0x74EA0000
Hooking dsound proc named "DirectSoundCreate"
"DirectSoundCreate" hooked, address 0x74EA7E3D
Hooking dsound proc named "DirectSoundEnumerateA"
"DirectSoundEnumerateA" hooked, address 0x74EED993
Hooking dsound proc named "DirectSoundEnumerateW"
"DirectSoundEnumerateW" hooked, address 0x74EED9B0
Hooking dsound proc named "DllCanUnloadNow"
"DllCanUnloadNow" hooked, address 0x74ED41BB
Hooking dsound proc named "DllGetClassObject"
"DllGetClassObject" hooked, address 0x74EA7792
Hooking dsound proc named "DirectSoundCaptureCreate"
"DirectSoundCaptureCreate" hooked, address 0x74EED2C5
Hooking dsound proc named "DirectSoundCaptureEnumerateA"
"DirectSoundCaptureEnumerateA" hooked, address 0x74EED9CD
Hooking dsound proc named "DirectSoundCaptureEnumerateW"
"DirectSoundCaptureEnumerateW" hooked, address 0x74EED9EA
Hooking dsound proc named "GetDeviceID"
"GetDeviceID" hooked, address 0x74EED160
Hooking dsound proc named "DirectSoundFullDuplexCreate"
"DirectSoundFullDuplexCreate" hooked, address 0x74EED429
Hooking dsound proc named "DirectSoundCreate8"
"DirectSoundCreate8" hooked, address 0x74EDDE69
Hooking dsound proc named "DirectSoundCaptureCreate8"
"DirectSoundCaptureCreate8" hooked, address 0x74EED371
Loading ASI G:\Games\GTA IV\Trainer.asi
ASI loaded : G:\Games\GTA IV\Trainer.asi, Address 0x5F570000

-------------------------------------------------------------------------------------------


Is there any way to fix this problem? It would be very cool if it works wink.gif

Chromerz
  • Chromerz

    Player Hater

  • Members
  • Joined: 23 Jul 2011

#2

Posted 25 July 2011 - 09:35 AM Edited by Chromerz, 25 July 2011 - 09:43 AM.

Ok, I solved it. This is what I did:

1) Make a clear install of the game (If you have problems with the ASI who can't create a Log file , just install it on an external hard drive)
2) If u use a crack , Download the Razor1911 1.0.1.0 Patch+Crack or 1.0.2.0
3) Update your game to 1.0.1.0 or 1.0.2.0 (Not more , I only tested these) , and put the crack in it (if u use cracked version)
4) Dowload the newest files ( Alexander's ASI loader and Simple native trainer 6.3)
5) If there come a new version of ASI loader or Trainer, check if it's compatible with your game client (1.0.1.0)
6) Put the these files in your main GTA IV folder: trainer.asi , trainer.ini , scripthook.dll- OLD PATCHES
It's very imprtant you use scripthook.dll - Old patches because your game will crash if u use the normal one

7)When these files are in your GTA IV folder, just rename the scripthook.dll - OLD PATCHES to scripthook.dll (so just remove the '-OLD PATCHES'), and it
will become a normal dll file
8) Start the game as administrator and press F3 in the game, everything will work fine now wink.gif


So just remember to stop your updates at 1.0.1.0 or 1.0.2.0 and use the scripthook.dll - OLD patches (Which will be renamed to scripthook.dll)

Maybe a bug in the cracked 1.0.4.0 patch?


IF THIS STILL DOESN'T WORK OR YOU DON'T WANT TO USE OLDER PATCHES
--------------------------------------------------------------------------------------------

There is still a car spawner trainer without ASI files but you can only spawn cars with it.
Link: http://www.gtagaming...a-iv/tools/1931

Extract the files in a new folder on your desktop, run the game and open the trainer (You don't need to put any files in your GTA IV folder, it just works like an other trainer)

When the game is started , Move Niko outside and press Alt+Tab , select the car you want (Optional: Set a hotkey for fast in-game spawning), Press Spawn Car or the hotkey you made. Go back in-game and you will se there is no car (I think) , Just open up your phone (Arrow Up) and close it again and you car will be spawned in front of you.

neilmrobinson
  • neilmrobinson

    Player Hater

  • Members
  • Joined: 21 Sep 2011

#3

Posted 21 September 2011 - 11:48 AM

So if I do this, I can get the mod to enable me to unlock all cities?

Khel09
  • Khel09

    Player Hater

  • Members
  • Joined: 30 Oct 2011

#4

Posted 30 October 2011 - 05:08 PM

There you go! All suffering in run a mod LIKE - RealizmIV + VisualIV thru 1.0.4.0 Patch.. i search and clear the problem....! just Renamed the f*cking Scripthook.dll - OLD PATCHES to scripthook.dll.... AND WUULAAA.... The Game run smoothly and ROCK ON! Tnx for this Info...!




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users