Jump to content

» «

Language loader

6 replies to this topic
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009
  • Poland
  • Best Conversion 2016 [GTA: Underground] [Contribution]
    Contribution Award [Mods]


Posted 13 July 2011 - 10:34 AM

Language loader 1.0

This ASI plugin adjusts number of possible languages to configure.
By default GTA San Andreas is able to load 5 of languages, while US menu is configured to display 2 of them.
Even though there are 5 languages, it is not enough for someone who is gonna add new language instead of overwritting existing one
Now you can configure more than 5 languages, up to 11.
Adding languages is very simple: add language GXT key like "FEL_POL" to every used .gxt with a name of added language
according to a GXT. Configure .ini to use added .gxt

Works with GTA San Andreas v1.0 [US] HOODLUM No-CD Fixed EXE & GTA: San Andreas v1.01 [EURO] No-CD/Fixed EXE

Make sure you are using following gta_sa.exe versions:
1. GTA San Andreas v1.0 [US] HOODLUM No-CD Fixed EXE:
EXE size: 14 383 616 bytes

You need to have ASI loader installed in order to run .asi
If you have CLEO Library you already have it.

- Put LanguageLoader.asi to a root of GTA San Andreas directory.
- Copy one of "text" folders included in archive of this mod.
- "text" here is default configuration with 2 languages only

- if you are polish, copy "5 standard languages + 6th polish\text"
- you will get 6 languages possible to configure in menu

- "text\5 standard languages from EURO version" 5 languages to configure, just like in EURO versions

The main purpose of this plugin is not just to use default 5 languages, but do something more - adjust limit of languages.
You can have up to 11 your own configured languages.

Adding language
- Open text\Languages.ini
- Find: Number_of_languages in [MAIN] section
- Increase Number_of_languages as you are want to one one.
- Add new section with number of language like this:

GXT_language_key = FEL_POL
GXT_file = polish.gxt
Is_system_metric = 1

- GXT_language_key - name of GXT key which contains adjectival name of language e.g FEL_POL
- This GXT key should exist in all of .gxt while name of language will be different in different languages.
- FEL_POL would be "Polish" in american.gxt, while it is "Polski" in polish.gxt

- GXT_file - very simple property to understand, it is just name of used GXT file for this language relative to "text\" .
- Is_system_metric - if set to 1, GTA San Andreas will use metric units like meters (M) in Statistics >> Archievements
- as well as opcode 0424: is_system_metric will be affected
- Otherwise if you set it to 0, imperial units such as foots (FT) will be used and 0424 opcode will return false.

Now editing all GXT files. Download good GXT editor for .gxt files. I recommend GTA: San Andreas GXT Editor 1.3 created by Hammer83
Download here: http://www.thegtapla...-gxt-editor-1-3

- Add new .gxt file to "text\" directory.
- Open every of .gxt files (gxt file of added language as well). Do steps as described below
- Select MAIN section
- Click Entry >> Add
- Enter name of GXT key as configured GXT_language_key
- Enter value of created GXT entry, it should be adjectival name of added language according to edited .gxt file.
- It means if you add e.g polish language, then new key in american.gxt should have a value "Polish"
- but the same key in german.gxt would have a value "Polnisch"

Author: fastman92
Version: 1.0
For: GTA San Andreas
Email: fastman92@gmail.com
Visit fastman92.tk

  • [GwM]Chavez

    offline modus

  • Members
  • Joined: 13 Jun 2009
  • Turkey


Posted 13 July 2011 - 10:47 AM

heh polak potrafi ! biggrin.gif
anyway good job men !!

  • hristobg


  • Members
  • Joined: 01 Aug 2009
  • None


Posted 07 September 2011 - 07:19 PM

I did everything as it was wroten, but didn't work! I added a table FEL_BUL (bulgarian) to every GXT file,
I configured languages.ini and everything and ingame the text of the new added file doesn't show up! It loads it, but with empty text. sad.gif

  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009
  • Poland
  • Best Conversion 2016 [GTA: Underground] [Contribution]
    Contribution Award [Mods]


Posted 11 September 2011 - 12:25 PM Edited by fastman92, 11 September 2011 - 12:29 PM.

I added a table FEL_BUL (bulgarian) to every GXT file

It`s your problem.
You need to add FEL_BUL as a key to MAIN table.

Do as follows for american, the same for other files, but give different content:
open american.gxt using GXT editor
Select MAIN section
Add FEL_BUL. Enter content e.g "Bulgarian".
After you save GXT make sure FEL_BUL is available in MAIN section.
If you still have problems PM me

  • mirh


  • Members
  • Joined: 01 Aug 2012
  • Italy


Posted 08 May 2016 - 11:11 AM

Almighty fastman, since people really doesn't seem cooperative, could you check whether this mod works with modloader, whatever that means?


Also, could you add some links?

  • Tomasak

  • The Yardies
  • Joined: 04 Jan 2009
  • None
  • Spam Commando 2017
    Best Conversion 2016 [GTA: Underground] [Contribution]


Posted 08 May 2016 - 11:47 AM


  • The In-Game menu is ready to be used (go into Options > Mod Configuration). (make sure it's enabled from modloader/.data/config.ini, EnableMenu=true).
It is not working for me very well:
My bad, it conflict with language loader, thanks for this awesome mod



@Tomasak & Ural
I've just looked into those conflicts, I can't do anything about it really :/
Language Loader uses the menu original menu table, I've relocated this table.
SAORS calls game functions that aren't supposed to be called from another thread, in it's own thread, super bad in general...


Language loader - I'll update my plugin soon.

  • mirh likes this

  • jm-9

    Player Hater

  • Members
  • Joined: 16 Feb 2016
  • Ireland


Posted 10 October 2016 - 10:13 PM

It's worth noting that a glitch occurs if language files from the first edition are present in the same folder as language files from later versions. If this happens, only the language files that are the same version as the language currently selected will appear in the menu, although all languages are still selectable. It's possible that this also happens without this mod, but if anyone isn't seeing an added language, this could be the reason.

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users