Quantcast

Jump to content

» «
Photo

Maxo's Vehicle Loader

VC Released
2,084 replies to this topic
Xegethra
  • Xegethra

    Trick

  • Members
  • Joined: 13 Sep 2007

#1981

Posted 04 December 2013 - 11:08 AM

 

And new problems. Againt it seems to happen under heavy rain. It happens mostly on vigilante, not letting me complete it. I have an error log this time

http://puu.sh/5AGaz.txt

 

http://puu.sh/5AGYB.txt

 

*edit*

Ok really seems to be a rain problem, or it could just be a coincidence....but every crash so far has been when it is raining. I would cheat the rain away but I am trying to do a playthrough for YouTube....luckily I am not recording the trips inbetween missions, but I am recording any drives within them....so if it rains then, I don't wanna cheat on camera. I know it's only weather, but a cheat is a cheat. I guess the run of no crashes was a bit of luck for me, because now rain will just kill it every time.

 

Strange, why is your game loading "mss/vehmod.flt"? Since 0.98c it should load "mvl/vehmod_retail.dll" instead. If the vehmod.flt file in mss folder is left over from a previous version, it's getting loaded instead of the new version. You should probably delete that file.

 

 

O.k, I made sure it's that way. New version is up and running, however the rain still kills the game. On one save I have, it rains just after the game loads, and will crash when it does. I have to cheat code the weather to sunny to get rid of it and it doesn't crash (If I'm quick enough to activate it). Like before, if the mod isn't installed, the rain is fine and no crashes. I have another errorlog where it crashed with the new version in the rain. Sometimes it has difficulty loading that save, but other ones are fine. (until it rains in them).

 

http://puu.sh/5BLFK.txt


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1982

Posted 04 December 2013 - 08:08 PM Edited by maxorator, 04 December 2013 - 09:48 PM.

 

O.k, I made sure it's that way. New version is up and running, however the rain still kills the game. On one save I have, it rains just after the game loads, and will crash when it does. I have to cheat code the weather to sunny to get rid of it and it doesn't crash (If I'm quick enough to activate it). Like before, if the mod isn't installed, the rain is fine and no crashes. I have another errorlog where it crashed with the new version in the rain. Sometimes it has difficulty loading that save, but other ones are fine. (until it rains in them).

 

http://puu.sh/5BLFK.txt

 

 

Try with this (it does not fix anything, but it should create a special error file on that crash, dump640FE5h.txt (it's actually a binary file)):

http://maxorator.com..._retail_dbg3.7z

 

 

 

In other news, messing with an experimental vehicle spawning system:

  • Wesser likes this

TJGM
  • TJGM

    Politically correct.

  • GTA Mods Staff
  • Joined: 14 Jun 2011
  • Ireland
  • Helpfulness Award
    Contribution Award [Mods]

#1983

Posted 04 December 2013 - 08:45 PM

That video.. I don't even. :p Should we expect it to be apart of MVL soon?


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1984

Posted 04 December 2013 - 09:24 PM Edited by maxorator, 04 December 2013 - 09:25 PM.

That video.. I don't even. :p Should we expect it to be apart of MVL soon?

 

Yep. You can test it already if you want, if you extract this to your MVL folder: http://maxorator.com..._retail_spwn.7z  and set "testmenus" to "true" in globalm.xml. Keys are currently hardcoded (numpad * to open/close, numpad +- to scroll, numpad / to spawn), but I'll probably make it possible to customize this.


TJGM
  • TJGM

    Politically correct.

  • GTA Mods Staff
  • Joined: 14 Jun 2011
  • Ireland
  • Helpfulness Award
    Contribution Award [Mods]

#1985

Posted 04 December 2013 - 09:37 PM

Tested, works really well. Minor FPS drops when the menu is open, but its fine when closed.


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1986

Posted 04 December 2013 - 09:47 PM

Tested, works really well. Minor FPS drops when the menu is open, but its fine when closed.

 

Yeah it's quite a resource hog. I guess I could add an option to stop them from rotating for people with weaker computers.

  • I MD Pradipta likes this

cabron-jon
  • cabron-jon

    The Last Hero

  • Members
  • Joined: 12 Jan 2012
  • Russia

#1987

Posted 06 December 2013 - 06:20 AM Edited by cabron-jon, 06 December 2013 - 06:31 AM.

478104d700f40c9f6aade410bf8ec78f.jpg


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1988

Posted 06 December 2013 - 02:00 PM Edited by maxorator, 06 December 2013 - 04:42 PM.

478104d700f40c9f6aade410bf8ec78f.jpg

 

Do you have any vehicles installed. Only MVL vehicles show up on that list and if you don't have any, then it just shows black rectangles.

 

 

Edit:
Fixed some problems with rendering, if the previous version doesn't work, try this: http://maxorator.com...retail_spwn2.7z


TJGM
  • TJGM

    Politically correct.

  • GTA Mods Staff
  • Joined: 14 Jun 2011
  • Ireland
  • Helpfulness Award
    Contribution Award [Mods]

#1989

Posted 06 December 2013 - 08:47 PM

 

478104d700f40c9f6aade410bf8ec78f.jpg

 

Do you have any vehicles installed. Only MVL vehicles show up on that list and if you don't have any, then it just shows black rectangles.

 

 

Edit:
Fixed some problems with rendering, if the previous version doesn't work, try this: http://maxorator.com...retail_spwn2.7z

 

Crashes when exiting interiors with auto-interiors, fine with it disabled though.


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1990

Posted 06 December 2013 - 08:49 PM

Crashes when exiting interiors with auto-interiors, fine with it disabled though.

 

 

This should fix it: http://maxorator.com...ail_eventbf5.7z


TJGM
  • TJGM

    Politically correct.

  • GTA Mods Staff
  • Joined: 14 Jun 2011
  • Ireland
  • Helpfulness Award
    Contribution Award [Mods]

#1991

Posted 06 December 2013 - 08:59 PM

Works like a charm. Thanks!


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1992

Posted 08 December 2013 - 03:57 AM Edited by maxorator, 08 December 2013 - 03:57 AM.

New version:

CHANGELOG OF 0.98e

  • Vehicle (Num*) and weapon (Num5) selecting screens, Num-+ to scroll, Num/ to spawn, <testmenus> in globalm.xml must be enabled.
  • Added streaming memory limit setting to globalm.xml (check help/sample_globalm.xml for usage).
  • Added "createVehicle" and "createExplosion" functions to Python scripts (check help/samplescripts/vehiclegrid.py).
  • Added "eventBulletFired" event to Python scripts (check help/samplescripts/explosivem4.py).
  • Fixed a crash on decapitation after starting a new game for the second time.
  • Extra save XML file is only loaded if it is not older than the main save file.
  • MVL weapons carried by player are not saved to main save file, but to extra save XML.
  • Added shotgun specific settings to weapon XML (check shotgun xmls in help/samplewepxmls).
  • Fixed a VC bug that caused crashes on "heavy" collisions (many spheres of a collision model colliding at once).
  • Fixed a VC bug that caused a crash when too many sound effects were played at the same time.
  • Fixed a crash when there were too many files in IMG that didn't have an IDE entry.
  • Some errors about IPL/IDE/IMG issues logged to messagelog.txt if <debugidedata> "true" in globalm.xml.
  • Increased maximum number of explosions.
  • Fixed some automatic interior switching bugs (wrong interior on first cutscene, interior color switching issues).
  • Opcode 0801 for checking if MVL has Python loaded, opcode 0802 for getting MVL version number (currently 9850).

ThirteenAG
  • ThirteenAG

    Gangsta

  • Feroci
  • Joined: 29 Dec 2008
  • None
  • Contribution Award [Mods]

#1993

Posted 08 December 2013 - 03:18 PM



http://www.gtagarage...ow.php?id=16073

GamerShotgun
  • GamerShotgun

    The main protagonist.

  • Members
  • Joined: 03 Oct 2005

#1994

Posted 10 December 2013 - 03:18 AM

Oh gosh, I'd love to get a mod pack like that. 


I MD Pradipta
  • I MD Pradipta

    Boy you should have known by now, Eazy does it

  • Members
  • Joined: 14 Dec 2012
  • Indonesia

#1995

Posted 11 December 2013 - 04:34 AM

98e

mvletest.jpg

riquenunes
  • riquenunes

    Soldier

  • Members
  • Joined: 28 Apr 2008
  • Brazil

#1996

Posted 11 December 2013 - 04:50 PM

What is this? A screenshot for ants?

  • ALMOST610, Silent, ED-E and 1 other like this

I MD Pradipta
  • I MD Pradipta

    Boy you should have known by now, Eazy does it

  • Members
  • Joined: 14 Dec 2012
  • Indonesia

#1997

Posted 12 December 2013 - 03:16 AM

The screenshot is an error message i got from mvl 98e.

djopu
  • djopu

    Player Hater

  • Members
  • Joined: 19 Apr 2013

#1998

Posted 12 December 2013 - 11:29 AM

 
Experimental MVL vehicle spawner v2 and bullethole not working
and where is vehmod.flt file ? I didn't find on maxovehmod098e that file
plz upload the latest vehmod.flt file ... I need that .... plz ( maxorator ) 
thanks ....

Tadzik
  • Tadzik

    Hustler

  • Members
  • Joined: 07 Jul 2011
  • Poland

#1999

Posted 12 December 2013 - 12:00 PM

 

Experimental MVL vehicle spawner v2 and bullethole not working
and where is vehmod.flt file ? I didn't find on maxovehmod098e that file
plz upload the latest vehmod.flt file ... I need that .... plz ( maxorator ) 
thanks ....

 

you do not need vehmod.flt. vehmod_chooser.flt is choosing dll file depends on your VC version(steam/box aka retail)


djopu
  • djopu

    Player Hater

  • Members
  • Joined: 19 Apr 2013

#2000

Posted 12 December 2013 - 12:49 PM

thanks ... brother .... many many thank .... but that file shows Virus ... on my avira anti-virus software .... can U fix it ?


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#2001

Posted 12 December 2013 - 02:41 PM

thanks ... brother .... many many thank .... but that file shows Virus ... on my avira anti-virus software .... can U fix it ?

 

You happen to be the unlucky user of one of the two only antivirus programs that think every small dll/exe is a virus:

https://www.virustot...beec5/analysis/

 

98e

mvletest.jpg

 

Fixed in the next release, accidentally used a function that didn't exist in XP.


djopu
  • djopu

    Player Hater

  • Members
  • Joined: 19 Apr 2013

#2002

Posted 13 December 2013 - 03:36 PM

on 0.98e sometime My game will crash ... and show this
can anyone help ?

http://s14.postimg.o...tled_1_copy.jpg

Untitled_1_copy.jpg


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#2003

Posted 13 December 2013 - 06:39 PM

on 0.98e sometime My game will crash ... and show this
can anyone help ?

http://s14.postimg.o...tled_1_copy.jpg

 

Send me the errorlog.txt from mvl directory after you get a crash.


djopu
  • djopu

    Player Hater

  • Members
  • Joined: 19 Apr 2013

#2004

Posted 13 December 2013 - 07:39 PM

here it is 

http://pastebin.ca/2497960


Bondergomme
  • Bondergomme

    j'la Pologne pas

  • Members
  • Joined: 10 Nov 2009
  • Canada

#2005

Posted 19 December 2013 - 07:13 PM

How can I make MVL work on GTA : LC? I try everything and It always lag.

 

 

Also, MVL finally work on my computer with this fix : http://www.youtube.c...h?v=gngG_WLmCLM


ToyGT_one
  • ToyGT_one

    Homie

  • Members
  • Joined: 17 Sep 2012
  • None

#2006

Posted 21 December 2013 - 07:52 AM

Did I missed any thing about the mod (Mvl)?

Flame
  • Flame

    HRT 1.4 mod author

  • Members
  • Joined: 24 Sep 2011
  • None
  • Contribution Award [Mods]

#2007

Posted 21 December 2013 - 10:55 AM

I have installed the mod only recently. Very good work. I am most interested the dynamic shadows for main hero.

Is this mod can work with another gta-vc.exe files, not only gta-vc.exe 1.0? In Russian localisation of game with .exe 1.0 texts looks badly.

markusizr
  • markusizr

    :D

  • Members
  • Joined: 04 Nov 2011

#2008

Posted 21 December 2013 - 11:45 AM

can this  work with mods 


Lacrix84
  • Lacrix84

    Sorry for my English

  • Members
  • Joined: 15 Apr 2013
  • Ukraine

#2009

Posted 21 December 2013 - 10:24 PM Edited by Lacrix84, 22 December 2013 - 09:51 PM.

Is it possible to add realtime shadows for all peds?


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#2010

Posted 23 December 2013 - 05:58 AM

I have installed the mod only recently. Very good work. I am most interested the dynamic shadows for main hero.

Is this mod can work with another gta-vc.exe files, not only gta-vc.exe 1.0? In Russian localisation of game with .exe 1.0 texts looks badly.

 

It only works with 1.0 and Steam version.

 

can this  work with mods 

 

Depends on the mod, swapping out models should not affect it, but it might not work with some .asi mods or CLEO scripts.

 

Is it possible to add realtime shadows for all peds?

 

Yes. It's on my todo list.

  • TJGM likes this




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users