Quantcast

Jump to content

» «
Photo

Maxo's Vehicle Loader

VC Released
2,157 replies to this topic
maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1951

Posted 01 December 2013 - 02:29 AM Edited by maxorator, 01 December 2013 - 02:30 AM.

Game crashes instantly when starting a new game or loading a save, any idea why? (game is modded too, btw)
 
11142481054_4a69dc7503_b.jpg

MVL Error Log: http://pastebin.com/DwZc8g7h

 

Can you check which mod causes this to happen? Perhaps by trying to disable some of them. Also, is your exe modified?

 

Once I know which mod it doesn't get along with, I can probably do something about it.


TJGM
  • TJGM

    Politically incorrect.

  • Members
  • Joined: 14 Jun 2011
  • Ireland
  • Helpfulness Award
    Contribution Award [Mods]

#1952

Posted 01 December 2013 - 02:48 AM Edited by TheJAMESGM, 01 December 2013 - 08:52 AM.

 

Game crashes instantly when starting a new game or loading a save, any idea why? (game is modded too, btw)
 
11142481054_4a69dc7503_b.jpg

MVL Error Log: http://pastebin.com/DwZc8g7h

 
Can you check which mod causes this to happen? Perhaps by trying to disable some of them. Also, is your exe modified?
 
Once I know which mod it doesn't get along with, I can probably do something about it.

Deleted almost every single mod I had and still got a crash. :/ Tried with an original exe and still crashes, same error too.

 

EDIT: Also, deleted all vehicles and weapons I had with MVL, didn't make a difference.

 

EDIT2: Decided to start on a clean game again, but now MVL disables all my CLEO mods for some reason, removing it and they all work again.

 

EDIT3: Okay, so it turns out starting a new game disables all the CLEO mods, loading works fine though.


theNGclan
  • theNGclan

    ps3 has no games

  • Members
  • Joined: 06 Apr 2011
  • United-States
  • Best Topic 2014 [GTA V and Steam]

#1953

Posted 01 December 2013 - 05:57 PM

Could you add some features from VCMP into MVL like the interior loading or something? I remember you and I discussed it during the second public beta of VCMP 0.4. I'd love to see the interior loading with MVL.


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1954

Posted 01 December 2013 - 06:21 PM

Could you add some features from VCMP into MVL like the interior loading or something? I remember you and I discussed it during the second public beta of VCMP 0.4. I'd love to see the interior loading with MVL.

 

Yeah, can do. I had forgotten about it, will probably include in the next version.


Tadzik
  • Tadzik

    Hustler

  • Members
  • Joined: 07 Jul 2011
  • Poland

#1955

Posted 01 December 2013 - 06:48 PM Edited by Ridd1cK, 01 December 2013 - 06:49 PM.

Crashes when I load save after missions Riot, Jury Fury(I have only saves after this missions), does not crash after loading In The Beggining

Does not load Cleo when starting new game

mvl/errorlog.txt

http://pastebin.com/nvSZ2FPD

I'm using no-cd exe (3 088 896 bytes)


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1956

Posted 01 December 2013 - 06:55 PM

Crashes when I load save after missions Riot, Jury Fury(I have only saves after this missions), does not crash after loading In The Beggining

Does not load Cleo when starting new game

mvl/errorlog.txt

http://pastebin.com/nvSZ2FPD

I'm using no-cd exe (3 088 896 bytes)

 

Didn't the error log contain a module list? Also, can you perhaps send the save game that crashes?


Tadzik
  • Tadzik

    Hustler

  • Members
  • Joined: 07 Jul 2011
  • Poland

#1957

Posted 01 December 2013 - 07:11 PM Edited by Ridd1cK, 01 December 2013 - 07:13 PM.

Didn't the error log contain a module list? Also, can you perhaps send the save game that crashes?

http://www.speedysha...y-User-Files.7z All the saves that crashes.

about errorlog.txt, that's all what was in the file

Maybe it's because of save anywhere cleo script?


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1958

Posted 01 December 2013 - 07:45 PM

Didn't the error log contain a module list? Also, can you perhaps send the save game that crashes?

http://www.speedysha...y-User-Files.7z All the saves that crashes.
about errorlog.txt, that's all what was in the file
Maybe it's because of save anywhere cleo script?


Those save files loaded fine for me. You can try this version, which fixes CLEO scripts not loading on new game, not sure if it also affects your problem (replace the dll in mvl folder):
http://maxorator.com...d_retail_nci.7z

Tadzik
  • Tadzik

    Hustler

  • Members
  • Joined: 07 Jul 2011
  • Poland

#1959

Posted 01 December 2013 - 07:53 PM

Those save files loaded fine for me. You can try this version, which fixes CLEO scripts not loading on new game, not sure if it also affects your problem (replace the dll in mvl folder):
http://maxorator.com...d_retail_nci.7z

Works great! Thanks!

 

I have small idea, maybe can you add ability to add new peds like adding new cars? we can assign them to groups(cops, swat, gangs, normal people)?


Xegethra
  • Xegethra

    Trick

  • Members
  • Joined: 13 Sep 2007

#1960

Posted 02 December 2013 - 09:53 AM

Just checking too see what's what with the mod so far. Nothing to report but the mod seems to be behaving for me now. (Although it would still wanna crash when I picked up two hidden packages, so to collect them all I had to remove the mod).

 

But other than that it's fine.


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1961

Posted 02 December 2013 - 12:23 PM

Just checking too see what's what with the mod so far. Nothing to report but the mod seems to be behaving for me now. (Although it would still wanna crash when I picked up two hidden packages, so to collect them all I had to remove the mod).

 

But other than that it's fine.

 

Can you elaborate on the hidden packages crash? Does it happen on any two collected packages or some specific ones?


Zera
  • Zera

    Mack Pimp

  • Members
  • Joined: 26 Feb 2005
  • Brazil

#1962

Posted 02 December 2013 - 12:58 PM

Why are the weapon models darkened when using real-time shadows?


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1963

Posted 02 December 2013 - 01:47 PM

Why are the weapon models darkened when using real-time shadows?

 

Never noticed such an issue. Do the actual weapons look darker when real-time shadows are enabled?


Zera
  • Zera

    Mack Pimp

  • Members
  • Joined: 26 Feb 2005
  • Brazil

#1964

Posted 02 December 2013 - 02:10 PM

 

Why are the weapon models darkened when using real-time shadows?

 

Never noticed such an issue. Do the actual weapons look darker when real-time shadows are enabled?

 

Indeed, they do. It's more noticeable if you use high quality model replacements.


ThirteenAG
  • ThirteenAG

    Gangsta

  • Feroci
  • Joined: 29 Dec 2008
  • None
  • Contribution Award [Mods]

#1965

Posted 02 December 2013 - 07:08 PM

The latest version works great, issues i mentioned before are gone now. Also, MVL contains a fix for cleo, which allows to load save from already loaded game. I just checked, and it seems like it doesn't applies to a new game.
To reproduce the crash:
MVL+CLEO.asi: load save. die. after spawning in the hospital - start new game. Error log - http://pastebin.com/p6NhJ9rW
MVL: same actions, works fine.

Can this also be fixed?

maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1966

Posted 02 December 2013 - 07:14 PM

The latest version works great, issues i mentioned before are gone now. Also, MVL contains a fix for cleo, which allows to load save from already loaded game. I just checked, and it seems like it doesn't applies to a new game.
To reproduce the crash:
MVL+CLEO.asi: load save. die. after spawning in the hospital - start new game. Error log - http://pastebin.com/p6NhJ9rW
MVL: same actions, works fine.

Can this also be fixed?

 

Yeah, that's another thing that happens even without MVL. I'll probably collaborate with CLEO developers to get a fixed version of CLEO out instead.


TJGM
  • TJGM

    Politically incorrect.

  • Members
  • Joined: 14 Jun 2011
  • Ireland
  • Helpfulness Award
    Contribution Award [Mods]

#1967

Posted 02 December 2013 - 07:21 PM Edited by TheJAMESGM, 02 December 2013 - 07:21 PM.

Why are the weapon models darkened when using real-time shadows?

 
Never noticed such an issue. Do the actual weapons look darker when real-time shadows are enabled?

Indeed, they do. It's more noticeable if you use high quality model replacements.

I can confirm this. Notice how dark the gun is with MVL compared to without it.
 
Without MVL: 11176743273_33227bdbaf_b.jpg
With MVL: 11176595306_d85b8e5214_b.jpg

Zera
  • Zera

    Mack Pimp

  • Members
  • Joined: 26 Feb 2005
  • Brazil

#1968

Posted 02 December 2013 - 07:56 PM Edited by Zera, 02 December 2013 - 07:56 PM.

Your pictures aren't visible, JAMESGM. You should try hosting them somewhere else.


maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1969

Posted 03 December 2013 - 01:38 AM Edited by maxorator, 03 December 2013 - 01:38 AM.

Small update.

 

CHANGELOG OF 0.98d
  • Automatic interior switching option (doesn't fade in or teleport), which is also teleport-safe (global.xml setting "autointeriors").
  • Fixed an issue with compatibility with some other modifications (CLEO and others).
  • Fixed weapons being darkened when using real-time shadow for player.

theNGclan
  • theNGclan

    ps3 has no games

  • Members
  • Joined: 06 Apr 2011
  • United-States
  • Best Topic 2014 [GTA V and Steam]

#1970

Posted 03 December 2013 - 01:46 AM Edited by theNGclan, 03 December 2013 - 01:56 AM.

 

Small update.

 

CHANGELOG OF 0.98d
  • Automatic interior switching option (doesn't fade in or teleport), which is also teleport-safe (global.xml setting "autointeriors").
  • Fixed an issue with compatibility with some other modifications (CLEO and others).
  • Fixed weapons being darkened when using real-time shadow for player.

 

Thanks for adding the interior switching! Gonna test this on the GTA LC mod to see if this works on it.

 

EDIT: When I went into the Malibu Club and exited, everything was foggy. It seems the game detected I was inside when I was outside, vice versa.


Xegethra
  • Xegethra

    Trick

  • Members
  • Joined: 13 Sep 2007

#1971

Posted 03 December 2013 - 02:19 AM

 

Just checking too see what's what with the mod so far. Nothing to report but the mod seems to be behaving for me now. (Although it would still wanna crash when I picked up two hidden packages, so to collect them all I had to remove the mod).

 

But other than that it's fine.

 

Can you elaborate on the hidden packages crash? Does it happen on any two collected packages or some specific ones?

 

Sure. The packages it first happened on were the first two on this map.

I would get the first package no problem, but only seconds after collecting the second package it would crash. If I got the first one no crashes, I waited just standing there for a few minutes and no crash, until I got the second one. It would crash whether I got it right away or waited.

 

It even worked the other way around, causing it to crash.

 

One odd thing was, I could avoid the problem by collecting package 3, then getting 2, then getting 1 and it wouldn't crash (at least it didn't for me now).

 

Sometimes, it would crash on getting package 4 first, then going down to 3 and 2 and 1.

 

Other than that I hadden't noticed any problems with packages. So I try them again without the mod and I got them all with no crashes. I put the mod back in after collecting them and everything seems to be fine again. I remember dreading the rain, it would crash usually just before it ran out or a little time after. I wouldn't get any crashes at all as far as I can rememeber when not going for packages.

 

 5ArN7.jpg


TJGM
  • TJGM

    Politically incorrect.

  • Members
  • Joined: 14 Jun 2011
  • Ireland
  • Helpfulness Award
    Contribution Award [Mods]

#1972

Posted 03 December 2013 - 03:41 AM

Your pictures aren't visible, JAMESGM. You should try hosting them somewhere else.


Really? I can see them just fine.. weird, besides the problem is fixed now so it doesn't matter.

Anyway, really nice update Max.

Xegethra
  • Xegethra

    Trick

  • Members
  • Joined: 13 Sep 2007

#1973

Posted 03 December 2013 - 07:58 AM Edited by Xegethra, 03 December 2013 - 08:28 AM.

And new problems. Againt it seems to happen under heavy rain. It happens mostly on vigilante, not letting me complete it. I have an error log this time

http://puu.sh/5AGaz.txt

 

http://puu.sh/5AGYB.txt

 

*edit*

Ok really seems to be a rain problem, or it could just be a coincidence....but every crash so far has been when it is raining. I would cheat the rain away but I am trying to do a playthrough for YouTube....luckily I am not recording the trips inbetween missions, but I am recording any drives within them....so if it rains then, I don't wanna cheat on camera. I know it's only weather, but a cheat is a cheat. I guess the run of no crashes was a bit of luck for me, because now rain will just kill it every time.


ThirteenAG
  • ThirteenAG

    Gangsta

  • Feroci
  • Joined: 29 Dec 2008
  • None
  • Contribution Award [Mods]

#1974

Posted 03 December 2013 - 09:36 AM

I don't see any difference between "autointeriors" enabled and disabled. How does it work exactly?

theNGclan
  • theNGclan

    ps3 has no games

  • Members
  • Joined: 06 Apr 2011
  • United-States
  • Best Topic 2014 [GTA V and Steam]

#1975

Posted 03 December 2013 - 12:08 PM

I don't see any difference between "autointeriors" enabled and disabled. How does it work exactly?

It removes the fading in/out transition of entering/exiting an interior. So it loads as you walk in, similar to IV.


I MD Pradipta
  • I MD Pradipta

    Boy you should have known by now, Eazy does it

  • Members
  • Joined: 14 Dec 2012
  • Indonesia

#1976

Posted 03 December 2013 - 01:02 PM

When i have 3 or more wanted star,three police helicopter come to chase me. Is it a bug? I use 0.98d

maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1977

Posted 03 December 2013 - 01:39 PM Edited by maxorator, 03 December 2013 - 01:41 PM.

And new problems. Againt it seems to happen under heavy rain. It happens mostly on vigilante, not letting me complete it. I have an error log this time

http://puu.sh/5AGaz.txt

 

http://puu.sh/5AGYB.txt

 

*edit*

Ok really seems to be a rain problem, or it could just be a coincidence....but every crash so far has been when it is raining. I would cheat the rain away but I am trying to do a playthrough for YouTube....luckily I am not recording the trips inbetween missions, but I am recording any drives within them....so if it rains then, I don't wanna cheat on camera. I know it's only weather, but a cheat is a cheat. I guess the run of no crashes was a bit of luck for me, because now rain will just kill it every time.

 

Strange, why is your game loading "mss/vehmod.flt"? Since 0.98c it should load "mvl/vehmod_retail.dll" instead. If the vehmod.flt file in mss folder is left over from a previous version, it's getting loaded instead of the new version. You should probably delete that file.

 

When i have 3 or more wanted star,three police helicopter come to chase me. Is it a bug? I use 0.98d

 

Actually it's 4! It happens when you have the "trashbin" turned on in config, because I wanted to test how it destroys multiple helicopters in a row. I should probably make it a separate setting somewhere I guess.


ThirteenAG
  • ThirteenAG

    Gangsta

  • Feroci
  • Joined: 29 Dec 2008
  • None
  • Contribution Award [Mods]

#1978

Posted 03 December 2013 - 02:04 PM Edited by ThirteenAG, 03 December 2013 - 02:05 PM.

I figured what i did wrong, everything works now. Also i noticed this with interiors option:
aa64f47611125db7518b07a9a260ecd0.jpg

P.S. Vice Cry runs with MVL limit adjuster only, plus stream memory fix. Cool.

I MD Pradipta
  • I MD Pradipta

    Boy you should have known by now, Eazy does it

  • Members
  • Joined: 14 Dec 2012
  • Indonesia

#1979

Posted 04 December 2013 - 03:37 AM

I hope this can be fixed in the next release:
- crash when pressing alt+tab if windowed set to false
- I use 640x480 resolution to make low quality (to speed up game performance). But while playing in windowed mode the quality is high. I want to play in low quality

maxorator
  • maxorator

    VC:MP lead developer

  • Members
  • Joined: 24 Feb 2006
  • None
  • Contribution Award [Mods]

#1980

Posted 04 December 2013 - 10:35 AM

I hope this can be fixed in the next release:
- crash when pressing alt+tab if windowed set to false
- I use 640x480 resolution to make low quality (to speed up game performance). But while playing in windowed mode the quality is high. I want to play in low quality

 

I'll check if I can reproduce the crash.

 

About the windowed mode, it is not possible to have a resolution that is different from the window size.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users