Quantcast

Jump to content

» «
Photo

Iomega Portable Hard Drive Broken

5 replies to this topic
Ottae
  • Ottae

    (/'ɒteɪ/)

  • Zaibatsu
  • Joined: 16 Jun 2005
  • None

#1

Posted 04 March 2011 - 01:42 PM

I've got this Iomega 320gb portable hard drive and it worked fine for months. I think I must have removed it unsafely because now, it doesn't show up in My Computer. It's listed under Disk Management in Computer Management but only as " " with a status of "Healthy (Recovery Partition)". It's also listed in Devices, but I can't format it or do anything with it.
Any help to get it working again would be greatly appreciated. I'm not bothered about losing the data on there, I'd rather just get it back up and working again!

Thanks muchly

Specs:

Operating System (OS): Windows Vista Home Premium x32 SP2
Amount of RAM: 4.00GB
Processor (CPU): Intel Pentium Dual-Core CPU T4200 @ 2.00GHz, 2.00GHz

Ryan
  • Ryan

    Resident Ginger

  • Zaibatsu
  • Joined: 10 Apr 2006
  • Canada

#2

Posted 04 March 2011 - 02:38 PM

I had a similar problem with my hard drive a few months ago (Topic Link). I'd plug it into my PC and it would just tell me it needed to be formated before use. Eventually it just decided to work for me. Sometimes it still acts up, so I just turn off the drive, unplug it from my laptop and then hook it up again, and that usually does the trick. Occasionally that won't work work, so I just leave it for a bit then try that method again.

Ottae
  • Ottae

    (/'ɒteɪ/)

  • Zaibatsu
  • Joined: 16 Jun 2005
  • None

#3

Posted 04 March 2011 - 03:00 PM

It did ask to format it before and when I tried it said it couldn't format it.

The furthest it gets now is displaying in the Device Manager but nothing else confused.gif

Wolf68k
  • Wolf68k

    always howling

  • Members
  • Joined: 12 Mar 2003
  • None

#4

Posted 04 March 2011 - 04:47 PM

Tried it on another computer?

Ottae
  • Ottae

    (/'ɒteɪ/)

  • Zaibatsu
  • Joined: 16 Jun 2005
  • None

#5

Posted 04 March 2011 - 04:50 PM

Good idea! I'll try it on my flatmate's laptop.

Otter
  • Otter

    sea dwelling madman

  • Moderator
  • Joined: 30 Jan 2003
  • Canada

#6

Posted 04 March 2011 - 05:37 PM

And try another cable, failing that.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users