Quantcast

Jump to content

» «
Photo

EFLC - Crash on exit

8 replies to this topic
SlingShotUK
  • SlingShotUK

    GTA Collector and fan since 2001

  • Members
  • Joined: 20 Nov 2008

#1

Posted 05 January 2011 - 03:21 PM

Hi guys,

Just installed a fresh copy of EFLC and patched to the latest level (1.1.2.0).

Running on X64 Windows 7 Ultimate.

I then installed the latest XLiveLess, ScriptHook and Simple Trainer.

All works fine, but when I exit the game it crashes. Not a huge issue but I'd prefer it to exit correctly and clean up any resources it's been using etc.

Any ideas what could be causing this?

Thanks in advance.

sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None
  • Modding Contribution Award

#2

Posted 09 January 2011 - 03:25 PM

This started happening with the latest patch and ONLY if you entered a MP game. I think the same will happen with any mod based upon the scripthook.dll, but not entirely sure. I did mention it to the author of the hook at testing. Of course it is not a big deal, and not really something that warrents anyone's precious time.




SlingShotUK
  • SlingShotUK

    GTA Collector and fan since 2001

  • Members
  • Joined: 20 Nov 2008

#3

Posted 09 January 2011 - 03:30 PM

QUOTE (sjaak327 @ Jan 9 2011, 15:25)
This started happening with the latest patch and ONLY if you entered a MP game. I think the same will happen with any mod based upon the scripthook.dll, but not entirely sure. I did mention it to the author of the hook at testing. Of course it is not a big deal, and not really something that warrents anyone's precious time.

Thanks for confirming sjaak327. Good to know it's not just my config.
You're right that's not really a big deal. I imagine on Windows 7 the memory management is good enough to clean up what the crashed GTA process leaves behind.

Just good to know it's something related to the latest patch and scripthook. It wouldn't surprise me if it suddenly goes away with future updates of the awesome hook.

BTW, thanks for continuing to develop your truly essential trainer - it really is the definitive mod. Looking forward to using it more with some new vid's I want to produce.

iriedreadlock23
  • iriedreadlock23

    Dr. Frankenstein

  • Members
  • Joined: 14 Jan 2009

#4

Posted 10 January 2011 - 02:08 AM

I've had this problem regulary when exiting game. It has always brought two errors, one caused by EFLC.exe and one by my ATI card. I've had MSI ATI Radeon 3850 OC with 256mb. After I bought a new ASUS Radeon 4770 Formula 512mb, I dont see this error on exiting game. It could be driver issue. Note that I've been using EFLC 1.1.1.0 and 1.1.2.0. Had the same issue with regular GTA IV, 1.0.3 and 1.0.4, aswell.

Also, related to exiting crash, I have also been experiencing crashes on returning to game from Video Editor.

sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None
  • Modding Contribution Award

#5

Posted 10 January 2011 - 04:20 PM

QUOTE (iriedreadlock23 @ Jan 10 2011, 04:08)
I've had this problem regulary when exiting game. It has always brought two errors, one caused by EFLC.exe and one by my ATI card. I've had MSI ATI Radeon 3850 OC with 256mb. After I bought a new ASUS Radeon 4770 Formula 512mb, I dont see this error on exiting game. It could be driver issue. Note that I've been using EFLC 1.1.1.0 and 1.1.2.0. Had the same issue with regular GTA IV, 1.0.3 and 1.0.4, aswell.

Also, related to exiting crash, I have also been experiencing crashes on returning to game from Video Editor.

The problems of the game crashing returning from the video editor should have been fixed with the latest scripthook 0.5.1.


iriedreadlock23
  • iriedreadlock23

    Dr. Frankenstein

  • Members
  • Joined: 14 Jan 2009

#6

Posted 10 January 2011 - 09:44 PM

Scripthook 0.5.1 unfortunatelly did not help me with crashing. I was hoping that it would fix the bug, but it's obviously still appearing for certain users. I am using 0.5.1 for some time, but as I said, it could be related to Graphic card drivers.

iriedreadlock23
  • iriedreadlock23

    Dr. Frankenstein

  • Members
  • Joined: 14 Jan 2009

#7

Posted 12 January 2011 - 03:35 PM

Important: If you save game after hacking and using mods, like I did, and change the GPU, you can experience crashes even when reloading your save game. Removing scripts does not help.

Cannot confirm if it is because of the GPU, or mods. But starting a fresh New game, and saving, can solve the problem.

Arares
  • Arares

    Player Hater

  • Members
  • Joined: 07 Jan 2011

#8

Posted 15 January 2011 - 07:07 PM

Hey guys,

I replaced some cars (two or three) and if i was driving that car i got a crash "EFLC.EXE ERROR : evurable fault". Why? If i have original cars (no new) than i havent crash confused.gif...

nkjellman
  • nkjellman

    OG

  • Members
  • Joined: 28 Aug 2008
  • United-States

#9

Posted 15 January 2011 - 09:38 PM

I have a program called Clean Mem. If you wanted the game to shut down properly because it clears its left over memory just use Clean Mem. It will still get an error but all extra you have to do is click on a butten on the task bar.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users