Quantcast

Jump to content

» «
Photo

Small Alice (LUA) Patch

25 replies to this topic
Skorpro
  • Skorpro

    GTAholic

  • Members
  • Joined: 19 Jul 2009
  • Germany

#1

Posted 20 December 2010 - 03:38 AM Edited by Skorpro, 08 March 2012 - 11:26 PM.

Hi folks!
Some time ago I created some LUA mods. Unfortunately after the GTA4 update to version 1.0.7.0 they don't work. "Wie wunderbar" I thought! And no Alice update far and wide...
Yesterday I found out a method how Alice could work with the version 1.0.7.0! It's so simple, I can't believe it!
I created a small "patch" (actually, it's just a simple batch wink.gif )...


IMPORTANT:
Please create a backup of your savegames! If possible make a complete copy of the GTA GAME folder!

You can find the savegames here:
Win VISTA: C:\Users\ USERNAME \AppData\Local\Rockstar Games\GTA IV (backup this folder!)
Win XP: C:\Documents and Settings\ USERNAME \Local Settings\Applicationdata\Rockstar Games\GTA IV (backup this folder!)
German XP: C:\Dokumente und Einstellungen\ USERNAME \Lokale Einstellungen\Anwendungsdaten\Rockstar Games\GTA IV (backup this folder!)


Download the patch here (6.15 MB)! (gtainside.com)


All necessary files are included:

- Alice v0.9 (LUA) © by the one and only Alexander Blade!
- Scripthook © by the great Aru!
- XLiveLess © by Listener!
- GTAIV.exe v1.0.0.4 © by Rockstar!
- 5 old LUA-Mods © by me (Skorpro)!

Special Thanx to: Alexander Blade, Aru and Listener for their great work! smile.gif


THE INSTALLATION IS FOR ADVANCED USERS ONLY!!! USE AT YOUR OWN RISK!!! I WILL NOT TAKE ANY LIABILITY FOR DAMAGES!!!

INSTALLATION:
01. Make a backup of your settings and savegames!! (see above)
02. Extract "Small_AlicePatch_by_SKORPRO.zip" in the GTA4 game folder (e.g. C:\Program Files\Rockstar Games\Grand Theft Auto IV)
03. Start "!Alice Install & Uninstall.bat"
04. Then run the "LaunchGTAIV.exe"
05. Now the game displays an internal error message. The old savegames can not be loaded and GTA starts a "New Game"!
06. Drive Roman home and save the game. Now you can exit the game
07. Open "C:\Users\ USERNAME \AppData\Local\Rockstar Games\GTA IV\Savegames\ userXXXXXXXXXXXXX " (see above) and copy all files into "C:\Users\ USERNAME \Documents\Rockstar Games\GTA IV\Savegames"
08. Start the game again. Load your favourite savegame and save it immediately. You may need to change the settings (e.g. keyboard layout)
09. And that's all!... Put your Alice mods into the Alice folder (search in game folder). There you can find my mods and the mod instructions.


UNINSTALLING:
Start "!Alice Install & Uninstall.bat". The removal is done automatically!


KNOWN BUGS:
- You may need to change the settings
- The shadows of the cars are not visible
- The CAR_GENERATOR creates sometimes a lot of equaling vehicle models
- The loading time is longer again


TESTED WITH:
- GTA 4 v1.0.7.0 Update
- inGame Trainer v1.9.0 (Awwu)
- Simple Trainer v6.2 (sjaak327)


NOT TESTED:
- Online game
- Other GTA 4 versions


Click here to get detailed description of my Bomb Mod v1.0 & Special Parked Cars v1.2!

NEW: Click here to get my Undercover Police Car Mod v1.0 Beta (incl. No Police Mod v1.1)!

Hope you have fun!

Skorpro

Kucikuc24
  • Kucikuc24

    C/C++ Developer

  • Members
  • Joined: 29 Nov 2009
  • None

#2

Posted 20 December 2010 - 05:22 AM

This isnt solution...we really need update, no patches etc...

Skorpro
  • Skorpro

    GTAholic

  • Members
  • Joined: 19 Jul 2009
  • Germany

#3

Posted 20 December 2010 - 05:53 AM

QUOTE
This isnt solution...we really need update, no patches etc...


Yes, I know! But test this one and you will see: IT WORKS! biggrin.gif
So, at least it's an alternative...


Rapier
  • Rapier

    Retired scripter

  • Members
  • Joined: 14 Aug 2005

#4

Posted 20 December 2010 - 06:50 AM

This patch is valid for EXT scripts too?

Skorpro
  • Skorpro

    GTAholic

  • Members
  • Joined: 19 Jul 2009
  • Germany

#5

Posted 20 December 2010 - 12:48 PM

QUOTE (Rapier @ Dec 20 2010, 06:50)
This patch is valid for EXT scripts too?


I've tested the "Superman.EXT" mod and IT WORKS TOO! tounge.gif


Rapier
  • Rapier

    Retired scripter

  • Members
  • Joined: 14 Aug 2005

#6

Posted 20 December 2010 - 07:51 PM

Hummm... It's good to know. icon14.gif

eightball123
  • eightball123

    Player Hater

  • Members
  • Joined: 01 May 2011

#7

Posted 28 May 2011 - 06:44 PM

Hi
could you please have another link for this patch? when i click it, it just says its not available in my location.

thanks in advance man

Skorpro
  • Skorpro

    GTAholic

  • Members
  • Joined: 19 Jul 2009
  • Germany

#8

Posted 29 May 2011 - 12:27 AM

QUOTE (eightball123 @ May 28 2011, 18:44)
Hi
could you please have another link for this patch?

Hi,
New download link: GTAInside.com !

Ciao

coin-god
  • coin-god

    High Roller

  • $outh $ide Hoodz
  • Joined: 18 Mar 2007

#9

Posted 29 May 2011 - 12:42 AM

I would like to play one of thouse Zombie LUA mods that are around. Will they work with this patch?

eightball123
  • eightball123

    Player Hater

  • Members
  • Joined: 01 May 2011

#10

Posted 29 May 2011 - 11:41 AM

thanks for the new link biggrin.gif
em loving your parked cars and traffic control mod
keep up the good work icon14.gif

ZAZ
  • ZAZ

    Kernlochbohrer

  • Members
  • Joined: 10 Jan 2005
  • European-Union

#11

Posted 29 May 2011 - 05:36 PM

Nice work so far and good to know that the 7-installation works with 4-exe

For those who have problems: my firewall makes a check and breakes the game between the loadscreens
i have shut down the game with ctrl+alt+del and then confirm that the changed exe have permission
then i can start the game
disable firewall can also be an option

If it won't work after adding old savegames into C:\Users\USERNAME\Documents\Rockstar Games\GTA IV\Savegames
so don't add savegames of TLaD or TBoGD

Important: it needs to remove everything (Alice folder, BACKUPfiles folder, !Alice Install & Uninstall.bat)
if you wanna change back to version 7
otherwise the game selects you to cheat server, then you won't have everything for multiplayer

Skorpro
  • Skorpro

    GTAholic

  • Members
  • Joined: 19 Jul 2009
  • Germany

#12

Posted 31 May 2011 - 03:07 AM

QUOTE (goin-god @ May 29 2011, 00:42)
I would like to play one of thouse Zombie LUA mods that are around. Will they work with this patch?

Hi,

@goin-god
When the mod is compatible with Alice v0.9 then it should work smile.gif

@eightball123
Thanx & have fun biggrin.gif

@ZAZ
Thank you for the useful information!! smile.gif


razor911
  • razor911

    Player Hater

  • Members
  • Joined: 03 Jul 2011

#13

Posted 07 July 2011 - 03:27 PM

does this work with the drgoldfoot's bikiniguard mods and anarchy mod ? i have tried but it doesnt seem to work.

Skorpro
  • Skorpro

    GTAholic

  • Members
  • Joined: 19 Jul 2009
  • Germany

#14

Posted 08 July 2011 - 09:47 AM

QUOTE (razor911 @ Thursday, Jul 7 2011, 15:27)
does this work with the drgoldfoot's bikiniguard mods and anarchy mod ? i have tried but it doesnt seem to work.

Hi,

I don't know the "drgoldfoot's bikiniguard" mod, but the "anarchy mod" works with ALICE 0.3 only!!
So you can't start it with my patch... Sorry!

BUT try this (not tested!):
- Download the GTA4 patch 1.0.3.0 (archiv not exe)
(if you got the exe only: right click on "GTAIV_Patch_1030.exe" and extract it with 7-Zip! Open "$0" folder now.)
- Copy "GTAIV.exe" (v1.0.3.0) to game folder.
- Download ALICE 0.3 (or 0.32) and install it (maybe you must use an old ASI Loader)

OR (not tested!):
Use "Alice-installer" by ZAZ (uninstall my patch first) and read THIS !

Hope it works...




boyd_747
  • boyd_747

    Player Hater

  • Members
  • Joined: 16 Aug 2009

#15

Posted 12 July 2011 - 03:17 PM

All It work BUT ...there would be no shadows in the game sad.gif same install GTAIV patch 1.0.0.4 .... Can u Help me to fix it cry.gif

Skorpro
  • Skorpro

    GTAholic

  • Members
  • Joined: 19 Jul 2009
  • Germany

#16

Posted 12 July 2011 - 09:06 PM Edited by Skorpro, 12 July 2011 - 09:30 PM.

QUOTE (boyd_747 @ Tuesday, Jul 12 2011, 15:17)
All It work BUT ...there would be no shadows in the game  sad.gif   same install GTAIV patch 1.0.0.4 .... Can u Help me to fix it  cry.gif

Hi,

it's not so easy. With the patch 1.0.7.0 you got a graphics update (shadows...) too. My patch change the GTA.exe only and install all necessary files.

Hmmm... Ok, try this (NOT tested!):

- Make a backup of the hole shaders folder ("...\Rockstar Games\Grand Theft Auto IV\common\shaders")!!!
- Right click on "GTAIV_Patch_1004.exe" and extract it with 7-Zip!
- Open the "common" folder (e.g. "...GTAIV_UPDATE_1004\$0\common")
- Copy this "shaders" to your "shaders" folder ("...\Rockstar Games\Grand Theft Auto IV\common\shaders")

... maybe it works smile.gif

EDIT:
I found this (NOT tested!):
VisualIV


fallendawn
  • fallendawn

    Player Hater

  • Members
  • Joined: 08 Jun 2011

#17

Posted 13 July 2011 - 01:39 AM

Good work guy
I was longing to use the in-game enb editor but I only have a 1.07 version

You work solved my problem now

THANKS

SEKoner
  • SEKoner

    Player Hater

  • Members
  • Joined: 27 Jul 2005

#18

Posted 18 July 2011 - 04:18 PM Edited by SEKoner, 18 July 2011 - 10:05 PM.

At the beginning, your solution works fine so far and i updated my Trainer Script to the new Syntax. I'm happy with that, but one thing is missing in my favorite gta setting. The ELS and the First Person Mod are not running inside the game. Both need the .asi loader. I've testet some versions of the scripthook.dll, but no one will works fine. Cann you help me to find out in which combination the ELS Mod will work with this .... solution ?! smile.gif

And now ... from Landsmann zu Landsmann ...
Ich frickel mir einen dämlich bei dem Versuch die Emergency Lights Mod zu installieren. Hilf mir bitte den ELS Mod noch ans laufen zu bekommen, dann kann ich auf Version 1.007 sch****** !

EDIT:
OK, some version mixes later, it will work proper ! Thnaks anyway from my site

EDIT2:
It works not really good, because in this alice solution ELS wants the script from latest verion 6 and the sripthook and effects from v3. All teted mixes crashes the game. A real alice version vor 1.070 is needed sad.gif

Skorpro
  • Skorpro

    GTAholic

  • Members
  • Joined: 19 Jul 2009
  • Germany

#19

Posted 21 July 2011 - 04:57 PM

QUOTE (SEKoner @ Monday, Jul 18 2011, 16:18)
It works not really good, because in this alice solution ELS wants the script from latest verion 6 and the sripthook and effects from v3. All teted mixes crashes the game. A real alice version vor 1.070 is needed sad.gif

Hi,

I never tested the ELS mod. But if you told us that ELS didn't work with Alice... sad.gif

(Versuch mal deine Mod in C++ (mittels ScriptHook SDK von ARU) zu schreiben. Mit ein wenig Übung und der vorhandenen Beispiele wird es gehen! Ich bin von Alice (LUA) weg, denn ich wollte auch Mods für TBogT & Multiplayer schreiben. Habe Gedult, dann klappt's smile.gif VIEL GLÜCK)

SEKoner
  • SEKoner

    Player Hater

  • Members
  • Joined: 27 Jul 2005

#20

Posted 21 July 2011 - 05:05 PM Edited by SEKoner, 22 July 2011 - 02:14 PM.

Hab mich mal nen Tag hingesetzt und inzwischen ne andere Lösung gefunden wink.gif Trotzdem DANKE smile.gif

Modified Alice.asi for 1.0.7.0 ->Testversion!<-

After a long time i reinstalled GTA IV and was a bit sad that alice is no longer updatet by Alexander. [b]I bypassed the starting sequence of the alice.asi (0.9) and now it starts and runs under version 1.0.6.0 and 1.0.7.0. Please test this version and give response for other modifications. Beside this, i have testet it a couple of hours, and for me it looks that Alice runs fine under newer GTA IV versions.

Download the Alice for 1.0.7.0 HERE
Hope it will work fine for you too !

CODE
Modified Alice for V.1.0.7.0 !
************************************************
Description:
Modified Version of Alexander Blades Alice V.0.9.
For me it worked fine. Please Test and give
response on following thread:

http://www.gtaforums.com/index.php?showtopic=386816&st=1460

Changes:
Just a very small bypass to start Alice V.09 in
all GTA Versions. Calling the natives seems OK,
which were testet with my "trainerlike" LUA
Script.

Known Problems:
-It seems that loading the game will much slower
than in normal versions, but, it works (for me)

************************************************
*** WORKS NOW IN ALL VERSIONS BUT YOU USE   ****
*** AT OWN RISK. THIS IS NOT A REAL ALICE   ****
*** UPDATE !!        ****
************************************************

Added Trainer LUA:

--Press F1 = Godmode ON
--Press F2 = Add Armour
--Press F3 = Clear Wanted Level
--Press F4 = Repair Car
--Press F5 = Save Game
--Press F6 = Add Money 3754$
--Press F7 = Unlock Bridges
--Press F8 = Reset Cheat-Count
--Press F9 = Give Weapons
--Press ALT+F1 = = Godmode OFF
--Press ALT+F4 = = Exit Game
--Press CTRL+1 = = Spawn Police Car 2
--Press CTRL+2 = = Spawn Schafter
--Press CTRL+3 = = Spawn Sentinel
--Press CTRL+4 = = Spawn Feltzer
--Press CTRL+5 = = Spawn FBI Buffalo
--Press CTRL+6 = = Spawn Annihilator

************************************************

yazn
  • yazn

    Player Hater

  • Members
  • Joined: 07 Apr 2012

#21

Posted 17 April 2012 - 06:26 PM

hey every one i download Modified.Alice.for.V.1.070

for me gta iv .V.1.0.7.0 but is not work sad.gif


westsidebud
  • westsidebud

    Descanter The Insalubrious

  • Members
  • Joined: 11 Jun 2005

#22

Posted 19 June 2012 - 09:50 AM

so basicly you down graded your game and say it works now LOL

uhhhmm yeah of course it does.. your not running version 1.0.7.0 anymore

doing this is not a good idea
pick one or the other (104 or 107)
don't do crap like this, your asking for trouble

Skorpro
  • Skorpro

    GTAholic

  • Members
  • Joined: 19 Jul 2009
  • Germany

#23

Posted 24 June 2012 - 01:37 AM Edited by Skorpro, 24 June 2012 - 01:41 AM.

QUOTE (westsidebud @ Tuesday, Jun 19 2012, 09:50)
don't do crap like this, your asking for trouble

Hi,
plz notice at the time of this release there were many players & coders who still had many LUA mods but had updated their game too... Alexander Blade had left the scene for some month without any updates for Alice cryani.gif . Far and wide no solution for this problem! This "patch" was a simple and fast way (for beginners too!) to play the old Alice mods again...
...and yes, I know it wasn't my "best" mod wink.gif

JaggerJack844
  • JaggerJack844

    Player Hater

  • Members
  • Joined: 01 Aug 2012

#24

Posted 01 August 2012 - 01:43 AM

Can you help me.

I downloaded this because I have a mod that is an lua script and I have mods for 1.0.7.0 as well. So I need Alice to work on 1.0.7.0. Is this the right place? Because I tried and when I run the .bat it gives me the menu and I click any key, is gives text then tells me it's done. But there is nothing new (nor no Alice folder) in the GTAIV directory. I am running Windows 7.

ModsIncorporated
  • ModsIncorporated

    Player Hater

  • Members
  • Joined: 10 Feb 2013

#25

Posted 16 March 2013 - 03:10 PM

Corrupts GTAIV even after uninstall. congrats.

Skorpro
  • Skorpro

    GTAholic

  • Members
  • Joined: 19 Jul 2009
  • Germany

#26

Posted 16 March 2013 - 04:58 PM

QUOTE (ModsIncorporated @ Saturday, Mar 16 2013, 15:10)
Corrupts GTAIV even after uninstall. congrats.

Please, if you got any problems with my or any mod(s) so simply ask for help next time...!
Navigate to the GTA IV folder and then to "BACKUPfiles" folder.
Copy all files and paste them into your GTA IV folder... this should solve your problem.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users