Jump to content

» «

San Andreas gym glitch...

  • This topic is locked This topic is locked
7 replies to this topic
  • HoraceSlughorn

    Player Hater

  • Members
  • Joined: 10 Dec 2009


Posted 12 December 2009 - 04:26 PM

Hey guys I' ve got into some trouble with the gym glitch...need help!

After i completed burglar missions i can't use any of the gyms. I found a link to a fix in this section but it is expired or something, gives a 404 error.

Any ideas about what i should do to fix this?

lil weasel
  • lil weasel

    Shoot Looters, Hang Pirates!

  • GTA Series Staff
  • Joined: 25 Dec 2006
  • United-States
  • Contribution Award [San Andreas]


Posted 12 December 2009 - 05:00 PM




EAT, change clothes (?)

  • OrionSR

    Chain Game Development Team

  • Feroci
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]


Posted 12 December 2009 - 09:22 PM

If you are playing the PC version then hmvartak's Online Glitch Repair Tool can fix the gym glitch.

  • HoraceSlughorn

    Player Hater

  • Members
  • Joined: 10 Dec 2009


Posted 13 December 2009 - 06:09 AM Edited by HoraceSlughorn, 13 December 2009 - 03:12 PM.

QUOTE (lil weasel @ Dec 12 2009, 17:00)



EAT, change clothes (?)

Hey thanks lil weasel!!! i found a tip about changing clothes and saving 6 times in the links you mentioned, and it worked!!!

just in case anyone else is browsing these forums to solve the gym glitch problem, here's what i did:

changed all items of clothing (i changed all to Binco clothes but maybe others will work also)
saved six times in succession,
went to gym and it works!

Oh and there's something else i want to add...here's what I did BEFORE the glitch started. Try to avoid doing these things. Other players also seem to have got the glitch after doing these things:

1. Not eating out for long periods of time
2. Saving the game immediately after a mission
3. Keeping fat level at zero
4. Not working out at gym for days

  • tanslec


  • Members
  • Joined: 19 Jan 2010


Posted 27 January 2010 - 08:37 AM

hey this sounds cool thanks dudes. It just keeps saying 'you have worked out enough today' -wrong-o! Thanks I'll give it a go once I finish making 1 of my san andreas movies, cj wears the same clothes in the movie you see.....

  • WAL575

    Player Hater

  • Members
  • Joined: 04 Feb 2010


Posted 12 February 2010 - 04:44 AM

Grouse! Thanks for the tip, it happened to me after doing the Vigilante missions using the helicopter. I got up to level 150 or some ridiculous number. I'd eaten just before beginning, had full health, maximum muscle and played for quite some time until everything had diminshed. Normally after doing that I could just go to the gym and rebuild but it didn't let me ('you have worked out enough for today'). So instead, I just went mad with the physical activities like cycling, swimming, jogging, triatholons until my stats were up again. Nothing like a cross country run around San Andreas to get the muscles pumpin...

  • Krawk


  • Feroci
  • Joined: 23 Sep 2009
  • None


Posted 12 February 2010 - 06:45 AM

NOT working out for awhile doesn't seem to cause this glitch, I have not worked out since attaining Max Muscle early in the game. You won't lose muscle as long as there's fat to burn. NOT eating was the original cause of my glitch I think so on any restarts I make sure to visit a snack machine and buy enough snacks to make the fat meter move a notch (about 10 or so).

  • Hashemian

    Player Hater

  • New Members
  • Joined: 27 Jul 2014
  • None


Posted 27 July 2014 - 08:15 AM Edited by Hashemian, 27 July 2014 - 08:21 AM.

For PC

Simply repair the save game file :


Currently , this online repair tool is working well (active since 2008) but if it was corrupted or expired you may google this : gta san andreas glitch repair tool


This is probably same as what OrionSR said but the host of that link has been expired.

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users