Quantcast

Jump to content

» «
Photo

[ IV | SA | REL ] X Mod Installer V.1.5 Xtreme

7 replies to this topic
xmen
  • xmen

    Foot Soldier

  • Members
  • Joined: 02 Jun 2005

#1

Posted 07 September 2009 - 06:50 PM

user posted image

user posted image


X Mod Installer/Packer
X Mod Installer aka XMI is an advance tool to install GTA IV/SA mod, it provides a high-level security to your mod files and very safe installation. It supports mod security option if its checked the mod will only install in IV/SA directory. Moreover, XMI supports vary range of operations, from Files, Text to all IMG operations.

Screenshots
user posted image

user posted image

user posted image

user posted image

user posted image




Major Features :
In V.1.0

Auto-Backup of current files
Supports Operations
 -Archive
   -IMG
     -Add
     -Delete
     -Rename
     -Replace
 -File/Directory
    -Copy
    -Delete
    -Rename
 -Text
    -Insert
    -Delete
    -Replace
Intellisence And Flexible
Very Safe Installation
Secured MOD Info And Files
Can Handle Upto 8191 PB Data, 1.9 GB Each File
Instant Installer Preview


In V.1.5

Added Support for GTA San Andreas
Added Support for GTA IV 1.0.4
Added Changeable/Editable* Skins
Added Auto 'Check for Update' for Mods
Fixed Internal Bugs
Fixed XMI Layout
Updated 'X Archive Poison' Lib, Much smarter now


* Skin Editor allows you to create your own skins

Download

Graphix14
  • Graphix14

    New York

  • Members
  • Joined: 04 Apr 2007

#2

Posted 07 September 2009 - 07:03 PM

Awesome job! sigh.gif

SLAYERMAGGOT
  • SLAYERMAGGOT

    Stay Wild

  • Members
  • Joined: 19 Mar 2008

#3

Posted 07 September 2009 - 10:12 PM

You are awesome, thanks for this great & very useful tool biggrin.gif icon14.gif

SLAYERMAGGOT
  • SLAYERMAGGOT

    Stay Wild

  • Members
  • Joined: 19 Mar 2008

#4

Posted 24 December 2009 - 05:22 PM

Hey xmen,

please check my post in the gta iv beta mod CLICK

there are 5 files missing when X Mod Installer checks the files, you should remove the file check i think.

Those files are missing:
- common\data\taskParams.txt
- pc\data\gta_cache.dat
- pc\data\naturalmotion\Fred.html
- pc\data\naturalmotion\Wilma.html

Patch 1.004 also deletes
- LaunchGTAIV.exe

Also i had a problem because of the shorcut "Revoke License", in the german version it's called "Lizenz wiederrufen", and that's just dumb to check those files, since it's a sh*tty shortcut and i don't understand why i it should check that, since GTA IV can run without this crappy stupid shortcut... dozingoff.gif

I've made a temporary fix for this. DL it HERE
There no virus/no cd crack in this, but Patch 1.004 deletes the LaunchGTAIV.exe for some weird reasons.

xmen you should really fix this please.

And why i got that error message, the validating thing could be more detailed...

sorry for double post btw ph34r.gif

xmen
  • xmen

    Foot Soldier

  • Members
  • Joined: 02 Jun 2005

#5

Posted 24 December 2009 - 05:40 PM

QUOTE (SLAYERMAGGOT @ Dec 24 2009, 22:52)
Hey xmen,

please check my post in the gta iv beta mod CLICK

there are 5 files missing when X Mod Installer checks the files, you should remove the file check i think.

Those files are missing:
- common\data\taskParams.txt
- pc\data\gta_cache.dat
- pc\data\naturalmotion\Fred.html
- pc\data\naturalmotion\Wilma.html

Patch 1.004 also deletes
- LaunchGTAIV.exe

Also i had a problem because of the shorcut "Revoke License", in the german version it's called "Lizenz wiederrufen", and that's just dumb to check those files, since it's a sh*tty shortcut and i don't understand why i it should check that, since GTA IV can run without this crappy stupid shortcut... dozingoff.gif

I've made a temporary fix for this. DL it HERE
There no virus/no cd crack in this, but Patch 1.004 deletes the LaunchGTAIV.exe for some weird reasons.

xmen you should really fix this please.

And why i got that error message, the validating thing could be more detailed...

sorry for double post btw ph34r.gif

XMI will only checks for the files if you've chose to encrypt the info vault while building as well as the installation details will minimum. It was done to make the mod's files secure. In short if you choose to encrypt your info vault, the installer will check for all the files plus will minimize the installation details.

I didn't download the file you provided, dunno why it is needed and I don't even have gta 4 smile.gif


PS. If for any reason, I start working on XMI again...I will add a feature that will let the builder choose which files needs to be checked before the installation.

nixolas1
  • nixolas1

    Creator/Destroyer

  • Members
  • Joined: 23 Dec 2008
  • None

#6

Posted 05 January 2010 - 03:24 PM

You have made WAY to many anti-features. First of all, you need to install the mod installer to install the mod, couldn't you make the mod packet stand-alone? second you need to install the somewhat useless updater for everything to work, and when i finnaly want to pack my mod, i have to wait for some minutes for some "important" note to slowly pop up? bAaaaad coder....

BUT exept from that, it is really awesome.

xmen
  • xmen

    Foot Soldier

  • Members
  • Joined: 02 Jun 2005

#7

Posted 05 January 2010 - 03:32 PM

QUOTE (nixolas1 @ Jan 5 2010, 20:54)
You have made WAY to many anti-features. First of all, you need to install the mod installer to install the mod, couldn't you make the mod packet stand-alone? second you need to install the somewhat useless updater for everything to work, and when i finnaly want to pack my mod, i have to wait for some minutes for some "important" note to slowly pop up? bAaaaad coder....

BUT exept from that, it is really awesome.

QUOTE
You have made WAY to many anti-features. First of all, you need to install the mod installer to install the mod, couldn't you make the mod packet stand-alone? second you need to install the somewhat useless updater for everything to work, and when i finnaly want to pack my mod, i have to wait for some minutes for some "important" note to slowly pop up? bAaaaad coder....


wow...what a nice review whatsthat.gif

but FYI,
A. you do *not* need to install the mod installer to install any mod. If you did, you sure biggest n00b.
B. YES, you need to install the updater application...and its quite useless for n00bs !! but if user have little brain he wouldn't think that.
C. That "important" note is for helping n00bs and appears only first time.
D. If you really have any problem with the tool, then simply dont use it or write your ideas with a bit of respect.

gtabwoy
  • gtabwoy

    Rat

  • Members
  • Joined: 21 Jan 2012

#8

Posted 09 June 2012 - 04:25 PM

hello,

I keep getting a message from the x-mod packer application. it keeps saying that i need to download Microsoft.NET Framework 2.0. Since I have windows 7, i believe it's already installed on my pc.

any suggestions?

gtabwoy




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users