Quantcast

Jump to content

» «
Photo

Add New Car GTA IV

791 replies to this topic
Nico
  • Nico

    I don't know, I was really drunk at the time

  • Zaibatsu
  • Joined: 10 Feb 2010
  • None

#781

Posted 30 July 2016 - 02:44 PM

Have you installed Fastman's tools correctly? Maybe you forgot to place the Audio Loader file. Check the folder where you put the Fastman's files after the decompression and look for an ini file called gtaiv_vehicleAudioSettings. It should be in:
fastman limit adjuster 2.1/32-bit/pc/audio/Config
and you must be place that file in:
GTA IV directory/pc/audio/Config
  • Rocket Man FI likes this

Kerouha
  • Kerouha

    Rest In Passive

  • Members
  • Joined: 11 Apr 2016
  • Russia

#782

Posted 01 August 2016 - 03:53 PM

Have you installed Fastman's tools correctly? Maybe you forgot to place the Audio Loader file. Check the folder where you put the Fastman's files after the decompression and look for an ini file called gtaiv_vehicleAudioSettings. It should be in:

fastman limit adjuster 2.1/32-bit/pc/audio/Config
and you must be place that file in:
GTA IV directory/pc/audio/Config

The file is there, I'm not a complete idiot.

 

I also have:

$fastman92limitAdjuster.asi

fastman92limitAdjuster_GTAIV.ini

DllTricks.dll

MinHook.x86.dll

zlib1.dll

FXT/vehicles.fxt

common/data/gtaiv_trainTypeCarriages.dat


Nico
  • Nico

    I don't know, I was really drunk at the time

  • Zaibatsu
  • Joined: 10 Feb 2010
  • None

#783

Posted 01 August 2016 - 04:47 PM

The file is there, I'm not a complete idiot.

I apologize if I made you feel that way, I just wanted to help.

unbid
  • unbid

    Everybody needs a bosom for a pillow

  • Zaibatsu
  • Joined: 13 Jun 2011
  • Indonesia

#784

Posted 01 August 2016 - 05:58 PM

• NOTE: Upon using Fastman's Limit Adjuster to increase the number of acceptable handling lines for handling.dat (from 160 to 260+), this WILL correct the annoying handling bug issue.
For those of us using added car handling.ide files (newhandling.ide), you do NOT need to transfer the lines from this file to handling.cfg. ANY form of handling.ide will work.
 
The reason the bug occurs is because adding the extra handling line of your added car somehow interferes with the bikes' handling line section, which ultimately causes issues.

I did this and the game still crash on the loading screen for me. I don't know what I did wrong, but the handling bug doesn't occur to me before and I've been adding tons of cars in IV. At first the crash came from the added handling files that contain the added bike line. After I removed the added bike lines, the vanilla handling decided to crash on me. Is there any solution that can solve the crash issue?

Here's the limitadjuster.ini files with the patch applied:

Spoiler


and here's the added handling file for the bikes (there's actually only two added files but I separate the one for bikes after the crash. Still won't solve the problem and it become the source of crash):

Spoiler

fastman92
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009
  • Poland
  • Best Conversion 2016 [GTA: Underground] [Contribution]
    Contribution Award [Mods]

#785

Posted 02 August 2016 - 01:02 PM Edited by fastman92, 02 August 2016 - 01:09 PM.

 

• NOTE: Upon using Fastman's Limit Adjuster to increase the number of acceptable handling lines for handling.dat (from 160 to 260+), this WILL correct the annoying handling bug issue.
For those of us using added car handling.ide files (newhandling.ide), you do NOT need to transfer the lines from this file to handling.cfg. ANY form of handling.ide will work.
 
The reason the bug occurs is because adding the extra handling line of your added car somehow interferes with the bikes' handling line section, which ultimately causes issues.

I did this and the game still crash on the loading screen for me. I don't know what I did wrong, but the handling bug doesn't occur to me before and I've been adding tons of cars in IV. At first the crash came from the added handling files that contain the added bike line. After I removed the added bike lines, the vanilla handling decided to crash on me. Is there any solution that can solve the crash issue?

Here's the limitadjuster.ini files with the patch applied:

Spoiler


and here's the added handling file for the bikes (there's actually only two added files but I separate the one for bikes after the crash. Still won't solve the problem and it become the source of crash):

Spoiler

 

You didn't adjust any limits. Try to figure out why.


unbid
  • unbid

    Everybody needs a bosom for a pillow

  • Zaibatsu
  • Joined: 13 Jun 2011
  • Indonesia

#786

Posted 02 August 2016 - 03:11 PM Edited by unbid, 02 August 2016 - 03:56 PM.

You didn't adjust any limits. Try to figure out why.

You don't have any friends, do you?

Edit: solved. Thanks to a good friend of mine, and no thanks to fastman92.
  • Nico likes this

Zolika1351
  • Zolika1351

    Ladies, hide your titties!

  • Members
  • Joined: 16 Jun 2014
  • Hungary

#787

Posted 28 January 2017 - 10:38 AM Edited by Zolika1351, 28 January 2017 - 10:44 AM.

I have a strange problem.

I had random crashing, so I decided to remove some added cars that were made before 2016.

And it seems that if I remove this line from newveh:

banshee2,    banshee,        car,        BANSHEE,        BANSHEE,    [email protected],        [email protected]_CONV,    10,    999,        0.2967,    0.2967,        0,    5,    1.0    ,0,    ext_rare
the game crashes on the loading screen.

If I add another car instead of it, it also crashes. And I think I found out that this car is the reason I'm getting random crashes.


Lupin_III
  • Lupin_III

    Le Voleur.

  • Members
  • Joined: 17 Feb 2015
  • United-States

#788

Posted 05 February 2017 - 06:33 PM Edited by Lupin_III, 05 February 2017 - 06:35 PM.

I have a strange problem.

I had random crashing, so I decided to remove some added cars that were made before 2016.

And it seems that if I remove this line from newveh:

banshee2,    banshee,        car,        BANSHEE,        BANSHEE,    [email protected],        [email protected]_CONV,    10,    999,        0.2967,    0.2967,        0,    5,    1.0    ,0,    ext_rare
the game crashes on the loading screen.

If I add another car instead of it, it also crashes. And I think I found out that this car is the reason I'm getting random crashes.

Your problem looks like it's here:

banshee2,    banshee,

If I'm not mistaken you're not supposed to differentiate the model/mesh names like this in the vehicle identification file, otherwise you're going to have issues such as crashing presumably, and other ones also.

Just make all of the names 'banshee2' (given you have a Banshee already) except for the very last one (this one controls the vehicle sound attachment) and this may solve your issue. If you're adding cars, I strongly suggest creating custom model names entirely as I've done; it makes things a lot easier and less confusing too.

WA0otxj.jpg

 

If the game continuously crashes—since you didn't specify exactly how many added cars you do have and replacing the car still crashed the game—then you may have to resort to using Fastman's Limit Adjuster that was previously mentioned in this thread; it's a lifesaver.

  • fastman92 likes this

Lupin_III
  • Lupin_III

    Le Voleur.

  • Members
  • Joined: 17 Feb 2015
  • United-States

#789

Posted 14 February 2017 - 12:25 AM Edited by Lupin_III, 14 February 2017 - 12:31 AM.

 

-snip-

 

I did this and the game still crash on the loading screen for me. I don't know what I did wrong, but the handling bug doesn't occur to me before and I've been adding tons of cars in IV. At first the crash came from the added handling files that contain the added bike line. After I removed the added bike lines, the vanilla handling decided to crash on me. Is there any solution that can solve the crash issue?

Here's the limitadjuster.ini files with the patch applied:

Spoiler


and here's the added handling file for the bikes (there's actually only two added files but I separate the one for bikes after the crash. Still won't solve the problem and it become the source of crash):

Spoiler

 

I can't see the upper part of your limit adjuster initiation/configuration file. From what I can see however, you didn't adjust the amount of vehicle handling lines from the original/parenthetical value of 160 to something that is higher than that (with the patch enabled), because you are adding handling lines into the actual handling file for the original set of vehicles, so please adjust this value to something reasonable—like 260 for example as I have—to make the necessary 'room' within the file to comfortably add more handling lines into the file without further jeopardizing the game's functionality. I'll safely assume you didn't adjust the vehicle model limit either because the aforementioned for which you didn't adjust the handling line limit is the case. Because you've added handling lines and added cars themselves (or models) to the necessary files without actually adjusting the maximum handling line and vehicle model limits, the game is attempting to load handling lines/added cars past the imposed limits you didn't adjust in the file, which is most likely causing the game to crash.

 

Another glaring issue is the fact that you've separated the bike handling lines into their own file, which is otherwise unnecessary because you should have increased the handling line/(added) car model limits in the limit adjuster's configuration file in order to retain everything within the same file. Because you've created an individual handling line specifically containing the bikes, you would have to adjust the general GTA IV configuration files (specifically gta.dat) to include the individualized handling file that you created, which would also crash the game if you neglected to do this. This is also another huge aspect that is more than likely crashing your game. Carefully put the bike lines back into the handling file where you found them, adjust the aforementioned limits in the configuration file for the limit adjuster, and fire the game up again to see how it behaves after you've done this.

 

I made a post in this thread I believe, or somewhere else, about removing 1 unnecessary handling line from the handling.dat file which is literally a leftover from GTA San Andreas for which the model does not appear and is not necessary to have in GTA IV. I can show you how to do that to free up one slot in the handling file to switch with an added/replaced car of your choice.

 

The following reflects the upper and lower portions of my initiation/configuration file for the limit adjuster for you to see.

1inFyNh.jpg

  • unbid likes this

fastman92
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009
  • Poland
  • Best Conversion 2016 [GTA: Underground] [Contribution]
    Contribution Award [Mods]

#790

Posted 14 February 2017 - 06:59 PM

Adding vehicles shouldn't be difficult.

Vehicle only needs:
- IDE declaraction using cars section - standard vehicles made by R* are defined vehicles.ide
- handling line(s), in handling.dat file. Referenced by the handlingName in IDE declaration.
- Model file and Texture archive, standard vehicles in vehicles.img
- Car colour, to set the possible car colours, edit carcols.dat, if you don't do this the vehicle will use colour 0, which is black.
- Sound settings for vehicle model - the FLA uses file pc\audio\Config\gtaiv_vehicleAudioSettings.ini
- Text, when entering the vehicle. You can create the FXT files e.g vehicles.fxt. Use the FXT loader from the FLA.
  • Lupin_III likes this

unbid
  • unbid

    Everybody needs a bosom for a pillow

  • Zaibatsu
  • Joined: 13 Jun 2011
  • Indonesia

#791

Posted 19 February 2017 - 03:15 PM

-snip-

Late reply, but with FLA, is it still necessary to make multiple newhandling.dat file and newvec.dat file since the limit of each file have been increased?

fastman92
  • fastman92

    фастман92 | ف

  • Members
  • Joined: 28 Jul 2009
  • Poland
  • Best Conversion 2016 [GTA: Underground] [Contribution]
    Contribution Award [Mods]

#792

Posted 19 February 2017 - 03:21 PM

-snip-

Late reply, but with FLA, is it still necessary to make multiple newhandling.dat file and newvec.dat file since the limit of each file have been increased?

No.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users