Quantcast

Jump to content

» «
Photo

New Catalyst drivers for ATI cards released

42 replies to this topic
Gangxxter
  • Gangxxter

    A Gangster with style

  • Members
  • Joined: 16 Dec 2008
  • Austria

#1

Posted 16 May 2009 - 10:03 AM

Catalyst 9.5 is out now.

http://www.techpower...5_Released.html

The new version gave me a moderate, but significant, performance boost in GTA IV smile.gif

mikemax12
  • mikemax12

    Player Hater

  • Members
  • Joined: 10 Dec 2008

#2

Posted 16 May 2009 - 01:30 PM

Made my game much more smooth, and i got rid of the stuttering.

Thumbs up ATI icon14.gif

The Horror Is Alive
  • The Horror Is Alive

    Monkey-fighting snakes on this Monday to Friday plane.

  • BUSTED!
  • Joined: 10 Jan 2008

#3

Posted 16 May 2009 - 01:47 PM

Coolio. Downloading now.

Rallzor
  • Rallzor

    SGFVIDEOS

  • Members
  • Joined: 06 Dec 2008

#4

Posted 16 May 2009 - 02:59 PM

Do they really give a significant performance boost?

craig3000
  • craig3000

    Punk-ass Bitch

  • Awaiting Authorisation
  • Joined: 06 Dec 2008

#5

Posted 16 May 2009 - 03:10 PM

Thanks I almost forgot about the drivers tihs month

I posted the download link on the AMD GAME forums too

They being AMD have said the drivers won't be uploaded to their site until monday, I assume these drivers provided by techpowerup are the official anyway

craig3000
  • craig3000

    Punk-ass Bitch

  • Awaiting Authorisation
  • Joined: 06 Dec 2008

#6

Posted 16 May 2009 - 03:12 PM

QUOTE (Rallzor @ May 16 2009, 14:59)
Do they really give a significant performance boost?

I will try right now give me 10 minutes

Gangxxter
  • Gangxxter

    A Gangster with style

  • Members
  • Joined: 16 Dec 2008
  • Austria

#7

Posted 16 May 2009 - 03:14 PM

QUOTE (Rallzor @ May 16 2009, 16:59)
Do they really give a significant performance boost?

For me: yes.

Rallzor
  • Rallzor

    SGFVIDEOS

  • Members
  • Joined: 06 Dec 2008

#8

Posted 16 May 2009 - 03:16 PM

QUOTE (Gangxxter @ May 16 2009, 15:14)
QUOTE (Rallzor @ May 16 2009, 16:59)
Do they really give a significant performance boost?

For me: yes.

How much, in fps?

Gangxxter
  • Gangxxter

    A Gangster with style

  • Members
  • Joined: 16 Dec 2008
  • Austria

#9

Posted 16 May 2009 - 03:34 PM

QUOTE (Rallzor @ May 16 2009, 17:16)
QUOTE (Gangxxter @ May 16 2009, 15:14)
QUOTE (Rallzor @ May 16 2009, 16:59)
Do they really give a significant performance boost?

For me: yes.

How much, in fps?

Somtimes I had the stuttering issue: gone
Sometimes FPS dropped to 25 FPS when I drove fast from one island to another one or when I drove down a highway very fast: with Catalyst 9.5 FPS drops to 30 FPS in such situations.

mikemax12
  • mikemax12

    Player Hater

  • Members
  • Joined: 10 Dec 2008

#10

Posted 16 May 2009 - 03:35 PM

QUOTE (Gangxxter @ May 16 2009, 15:34)
QUOTE (Rallzor @ May 16 2009, 17:16)
QUOTE (Gangxxter @ May 16 2009, 15:14)
QUOTE (Rallzor @ May 16 2009, 16:59)
Do they really give a significant performance boost?

For me: yes.

How much, in fps?

Somtimes I had the stuttering issue: gone
Sometimes FPS dropped to 25 FPS when I drove fast from one island to another one or when I drove down a highway very fast: with Catalyst 9.5 FPS drops to 30 FPS in such situations.

Exactly the same here.

No stuttering, and no lag when driving fast.

ikt
  • ikt

     

  • Members
  • Joined: 02 Oct 2006

#11

Posted 16 May 2009 - 03:44 PM

Will this magically turn my Pentium 4 into a Core i7? tounge.gif

Cr!minal
  • Cr!minal

    Career Criminal

  • Members
  • Joined: 09 Feb 2008
  • None

#12

Posted 16 May 2009 - 03:56 PM

QUOTE (ikt @ May 16 2009, 15:44)
Will this magically turn my Pentium 4 into a Core i7? tounge.gif

It turned mine. Really good stuff I say lol.gif

ikt
  • ikt

     

  • Members
  • Joined: 02 Oct 2006

#13

Posted 16 May 2009 - 04:01 PM

Oh. Then. Cool. Installing it now. smile.gif

craig3000
  • craig3000

    Punk-ass Bitch

  • Awaiting Authorisation
  • Joined: 06 Dec 2008

#14

Posted 16 May 2009 - 04:13 PM

well I just played GTA4 for a bit with them, no problems and it does seem to be 'smoother', worth installing

Rallzor
  • Rallzor

    SGFVIDEOS

  • Members
  • Joined: 06 Dec 2008

#15

Posted 16 May 2009 - 06:26 PM

Alrighty it gave me a 8 fps boost and reduced some stuttering issues.

ikt
  • ikt

     

  • Members
  • Joined: 02 Oct 2006

#16

Posted 16 May 2009 - 07:18 PM

Yes. But it f*cking bugs with 2D crap. They downclocked the powersaving mode, making it MORE IMPOSSIBLE to surf on sites which have many ads on it.

bartekxyz
  • bartekxyz

    ▲▼▲▼▲▼▲

  • Members
  • Joined: 20 Dec 2008

#17

Posted 16 May 2009 - 07:29 PM

WTF? On amd forum it says new drivers are delayed till monday

Gangxxter
  • Gangxxter

    A Gangster with style

  • Members
  • Joined: 16 Dec 2008
  • Austria

#18

Posted 16 May 2009 - 09:42 PM

^I think, the drivers are already finished and the developers made them somehow public on the internet. But the webmasters haven't updated the downloadpage yet and because it's weekend, they will update the page not before monday.

I've installed the driver and it works perfectly, so there is nothing to worry about. But keep in mind, cards older than the HD2000 series aren't supported!

Kiabbo
  • Kiabbo

    Thug

  • Members
  • Joined: 17 Aug 2008

#19

Posted 16 May 2009 - 10:09 PM

I'll post benchmarks in 10 minutes

bartekxyz
  • bartekxyz

    ▲▼▲▼▲▼▲

  • Members
  • Joined: 20 Dec 2008

#20

Posted 16 May 2009 - 10:28 PM

ok, I gave it a try... I don't see any performance increase... From 52FPS in 9.4 to 52FPS in 9.5. But it doesn't mean this drivers are bad... they are just as good as previous one

Ghett0
  • Ghett0

    Dodo Pilot

  • Members
  • Joined: 06 Jul 2008

#21

Posted 16 May 2009 - 10:31 PM

Actually that just means your getting framelimited.

Kiabbo
  • Kiabbo

    Thug

  • Members
  • Joined: 17 Aug 2008

#22

Posted 16 May 2009 - 10:39 PM Edited by Kiabbo, 16 May 2009 - 10:49 PM.

I heard it just work with 4000 series.
FUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
Is that true?

EDIT:
Fresh benchmarks!Get yours:

*Catalyst 9.4

Statistics
Average FPS: 28.20
Duration: 37.52 sec
CPU Usage: 95%
System memory usage: 75%
Video memory usage: 43%

Graphics Settings
Video Mode: 1440 x 900 (75 Hz)
Texture Quality: Medium
Texture Filter Quality: Medium
View Distance: 15
Detail Distance: 15

Hardware
Microsoft® Windows Vista" Business
Microsoft® Windows Vista" Business
Video Adapter: ATI Radeon HD 3800 Series
Video Driver version: 8.14.10.655
Audio Adapter: Alto-falantes (Dispositivo de High Definition Audio)
Intel® Pentium® Dual CPU E2180 @ 2.00GHz

File ID: benchmark.cli

*Catalyst 9.5

Statistics
Average FPS: 29.89
Duration: 37.34 sec
CPU Usage: 93%
System memory usage: 79%
Video memory usage: 43%

Graphics Settings
Video Mode: 1440 x 900 (75 Hz)
Texture Quality: Medium
Texture Filter Quality: Medium
View Distance: 15
Detail Distance: 15

Hardware
Microsoft® Windows Vista" Business
Microsoft® Windows Vista" Business
Video Adapter: ATI Radeon HD 3800 Series
Video Driver version: 8.14.10.662
Audio Adapter: Alto-falantes (Dispositivo de High Definition Audio)
Intel® Pentium® Dual CPU E2180 @ 2.00GHz

File ID: Benchmark.cli

I liked it... 2 FPS boost in benchmarks mean a little bit more in-game.Finally, a driver that works fine with GTA IV.Thanks ATI.

PS:It says video memory usage 43%, but it's a lie, I'm using -availablevidmem 2, so don't be WOWOWLOLOLWTFWOOTLMAO, I'm using a E2180 dual pentium processor and a HD3870, 2GB RAM DDR2 800mhz, HDD 80GB.

Cr!minal
  • Cr!minal

    Career Criminal

  • Members
  • Joined: 09 Feb 2008
  • None

#23

Posted 16 May 2009 - 11:00 PM

Any people with ATI 4890 card here who did try those new drivers yet?

Arkangel
  • Arkangel

    Prankster

  • Members
  • Joined: 11 Dec 2008

#24

Posted 16 May 2009 - 11:23 PM

4850 user here, according to the benchmark the fps went up to 53 (+4) in game i do not notice any difference as the game ran extremely smooth before:

Statistics
Average FPS: 53.32
Duration: 37.32 sec
CPU Usage: 64%
System memory usage: 58%
Video memory usage: 45%

Graphics Settings
Video Mode: 1680 x 1050 (60 Hz)
Texture Quality: Medium
Texture Filter Quality: Highest
View Distance: 25
Detail Distance: 37

Hardware
Microsoft® Windows Vista" Ultimate
Service Pack 1
Video Adapter: ATI Radeon HD 4800 Series
Video Driver version: 8.14.10.662
Audio Adapter: Speakers (SB Audigy)
Intel® Core™2 Quad CPU Q6600 @ 2.40GHz

File ID: benchmark.cli


Rallzor
  • Rallzor

    SGFVIDEOS

  • Members
  • Joined: 06 Dec 2008

#25

Posted 17 May 2009 - 01:25 AM

QUOTE (Arkangel @ May 16 2009, 23:23)
4850 user here, according to the benchmark the fps went up to 53 (+4) in game i do not notice any difference as the game ran extremely smooth before:

Statistics
Average FPS: 53.32
Duration: 37.32 sec
CPU Usage: 64%
System memory usage: 58%
Video memory usage: 45%

Graphics Settings
Video Mode: 1680 x 1050 (60 Hz)
Texture Quality: Medium
Texture Filter Quality: Highest
View Distance: 25
Detail Distance: 37

Hardware
Microsoft® Windows Vista" Ultimate
Service Pack 1
Video Adapter: ATI Radeon HD 4800 Series
Video Driver version: 8.14.10.662
Audio Adapter: Speakers (SB Audigy)
Intel® Core™2 Quad CPU    Q6600  @ 2.40GHz

File ID: benchmark.cli

Thanks a BUNCH for showing me that benchmark!

I'm a ATI 4850 user as well, and i'm running the goddamn game at a average fps of 15, all settings low.... How come?,

well, i think it is my CPU, bottlenecks the card a LOT?

Anyways, i've been thinking of upgrading to a new Mobo and that CPU.

Skyforger
  • Skyforger

    Rat

  • Members
  • Joined: 20 Apr 2009

#26

Posted 17 May 2009 - 04:06 AM

upgraded !!

don't know about benchmark but i thin it is the same for me from 35 - 50 all on High settings except water.


Uxot
  • Uxot

    Rat

  • Members
  • Joined: 10 Dec 2008

#27

Posted 17 May 2009 - 07:47 AM

uh well normaly i get 26-30 but now i get 14-22 ..had to disable..shadows to make it back to 24-28

gona wait for official release......

Gangxxter
  • Gangxxter

    A Gangster with style

  • Members
  • Joined: 16 Dec 2008
  • Austria

#28

Posted 17 May 2009 - 07:53 AM

^It IS the official release. They only update the download page on Monday, where you'll be able to download the exact same drivers as now.
If you have such a high performance loss, I'll suggest you to revert to version 9.4.

Uxot
  • Uxot

    Rat

  • Members
  • Joined: 10 Dec 2008

#29

Posted 17 May 2009 - 09:02 AM

QUOTE (Gangxxter @ May 17 2009, 07:53)
^It IS the official release. They only update the download page on Monday, where you'll be able to download the exact same drivers as now.
If you have such a high performance loss, I'll suggest you to revert to version 9.4.

well i just did...even media player classic was laggy,bugged and crashing :S + it reverted my dual screens to 1-2 to 2-1 all screwed my desktop -_-'

oh and in EVE Online it was laggy dropping often to 30 fps :S

damn i want a driver like 8.6 !! 9.6 plz xD 8.6 were awsome... (well for me lolz..)

craig3000
  • craig3000

    Punk-ass Bitch

  • Awaiting Authorisation
  • Joined: 06 Dec 2008

#30

Posted 17 May 2009 - 10:08 AM

QUOTE (Uxot @ May 17 2009, 09:02)
QUOTE (Gangxxter @ May 17 2009, 07:53)
^It IS the official release. They only update the download page on Monday, where you'll be able to download the exact same drivers as now.
If you have such a high performance loss, I'll suggest you to revert to version 9.4.

well i just did...even media player classic was laggy,bugged and crashing :S + it reverted my dual screens to 1-2 to 2-1 all screwed my desktop -_-'

oh and in EVE Online it was laggy dropping often to 30 fps :S

damn i want a driver like 8.6 !! 9.6 plz xD 8.6 were awsome... (well for me lolz..)

It must be a bad driver for you revert to the previous ones




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users